summaryrefslogtreecommitdiff
path: root/packages/gtk-engines/gtk-engines_2.7.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gtk-engines/gtk-engines_2.7.4.bb')
-rw-r--r--packages/gtk-engines/gtk-engines_2.7.4.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/packages/gtk-engines/gtk-engines_2.7.4.bb b/packages/gtk-engines/gtk-engines_2.7.4.bb
index 29c20e1e65..7ad1acc0ca 100644
--- a/packages/gtk-engines/gtk-engines_2.7.4.bb
+++ b/packages/gtk-engines/gtk-engines_2.7.4.bb
@@ -14,14 +14,16 @@ RDEPENDS_gtk-theme-clearlooks = "gtk-engine-clearlooks"
SRC_URI = "${GNOME_MIRROR}/${PN}/2.7/${P}.tar.bz2"
-inherit autotools pkgconfig
+inherit autotools pkgconfig gtk-binver
PACKAGES_DYNAMIC = "gtk-engine-* gtk-theme-*"
python populate_packages_prepend() {
import os.path
- engines_root = os.path.join(bb.data.getVar('libdir', d, 1), "gtk-2.0/2.4.0/engines")
+ engines_ver = ['gtk-2.0/', gtkbinver_find(d), '/engines']
+
+ engines_root = os.path.join(bb.data.getVar('libdir', d, 1), ''.join(engines_ver))
themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')