summaryrefslogtreecommitdiff
path: root/packages/gs/gs_8.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gs/gs_8.01.bb')
-rw-r--r--packages/gs/gs_8.01.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/gs/gs_8.01.bb b/packages/gs/gs_8.01.bb
index e69de29bb2..2495aa7732 100644
--- a/packages/gs/gs_8.01.bb
+++ b/packages/gs/gs_8.01.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "An interpreter of the Postscript language"
+LICENSE = GPL
+SECTION = "console/utils"
+SRC_URI = "ftp://ftp.gnu.org/gnu/ghostscript/gnughostscript-${PV}.tar.gz"
+DEPENDS = "jpeg zlib"
+PR = "r2"
+
+# | make: ./obj/echogs: Command not found
+BROKEN = 1
+
+S = "${WORKDIR}/gnughostscript-${PV}"
+
+FILES_${PN} += "${datadir}/ghostscript"
+
+inherit autotools flow-lossage
+
+EXTRA_OECONF = "--without-x"
+
+do_compile() {
+ oe_runmake CCAUX="${BUILD_CC}"
+}
+
+do_install() {
+ oe_runmake bindir='${D}${bindir}' datadir='${D}${datadir}' libdir='${D}${libdir}' install
+}