summaryrefslogtreecommitdiff
path: root/packages/gpephone/libidn_0.5.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gpephone/libidn_0.5.19.bb')
-rw-r--r--packages/gpephone/libidn_0.5.19.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/gpephone/libidn_0.5.19.bb b/packages/gpephone/libidn_0.5.19.bb
new file mode 100644
index 0000000000..9c37e015a9
--- /dev/null
+++ b/packages/gpephone/libidn_0.5.19.bb
@@ -0,0 +1,20 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "glibc"
+PR = "r0"
+
+inherit pkgconfig autotools
+
+SRC_URI = "http://josefsson.org/libidn/releases/${P}.tar.gz"
+
+EXTRA_OECONF = " --disable-tld"
+
+do_configure_prepend () {
+ autoreconf -f -i -s
+}
+
+do_stage () {
+ autotools_stage_all
+}