summaryrefslogtreecommitdiff
path: root/packages/gpe-bootsplash
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gpe-bootsplash')
-rw-r--r--packages/gpe-bootsplash/gpe-bootsplash_1.13.bb19
-rw-r--r--packages/gpe-bootsplash/gpe-bootsplash_1.14.bb2
2 files changed, 20 insertions, 1 deletions
diff --git a/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb b/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb
index e69de29bb2..bcf50ae7d2 100644
--- a/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb
+++ b/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb
@@ -0,0 +1,19 @@
+inherit gpe
+
+DEPENDS = "gtk+ librsvg"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI += "file://splash-p.svg file://splash-l.svg"
+
+FILES_${PN} += "${datadir}/gpe"
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-p.svg
+ install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-l.svg
+ mv ${D}/${sysconfdir}/rcS.d/S00bootsplash ${D}/${sysconfdir}/rcS.d/S02bootsplash
+}
+
diff --git a/packages/gpe-bootsplash/gpe-bootsplash_1.14.bb b/packages/gpe-bootsplash/gpe-bootsplash_1.14.bb
index ab096f4426..a2bda8b6e0 100644
--- a/packages/gpe-bootsplash/gpe-bootsplash_1.14.bb
+++ b/packages/gpe-bootsplash/gpe-bootsplash_1.14.bb
@@ -14,6 +14,6 @@ FILES_${PN} += "${datadir}/gpe"
do_install_append() {
install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-p.svg
install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-l.svg
- mv ${D}/etc/rcS.d/S00bootsplash ${D}/etc/rcS.d/S02bootsplash
+ mv ${D}/${sysconfdir}/rcS.d/S00bootsplash ${D}/${sysconfdir}/rcS.d/S02bootsplash
}