summaryrefslogtreecommitdiff
path: root/packages/gpe-bootsplash/gpe-bootsplash_1.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gpe-bootsplash/gpe-bootsplash_1.15.bb')
-rw-r--r--packages/gpe-bootsplash/gpe-bootsplash_1.15.bb20
1 files changed, 16 insertions, 4 deletions
diff --git a/packages/gpe-bootsplash/gpe-bootsplash_1.15.bb b/packages/gpe-bootsplash/gpe-bootsplash_1.15.bb
index 2e5f18b11f..fd17846103 100644
--- a/packages/gpe-bootsplash/gpe-bootsplash_1.15.bb
+++ b/packages/gpe-bootsplash/gpe-bootsplash_1.15.bb
@@ -5,15 +5,27 @@ MAINTAINER = "Phil Blundell <pb@handhelds.org>"
SECTION = "gpe"
PRIORITY = "optional"
LICENSE = "GPL"
-PR = "r0"
+PR = "r2"
-SRC_URI += "file://splash-p.svg file://splash-l.svg"
+SRC_URI += "file://splash-p.svg \
+ file://splash-l.svg \
+ file://tty2-message.patch;patch=1"
FILES_${PN} += "${datadir}/gpe"
do_install_append() {
- install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-p.svg
- install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-l.svg
+ install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-gpe-portrait.svg
+ install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-gpe-landscape.svg
mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S07bootsplash
}
+pkg_postinst() {
+
+ update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg 10
+ update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg 10
+}
+
+pkg_postrm() {
+ update-alternatives --remove bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg
+ update-alternatives --remove bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg
+}