summaryrefslogtreecommitdiff
path: root/packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb')
-rw-r--r--packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb b/packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb
index e95c09b3e8..5eeee0fffa 100644
--- a/packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb
+++ b/packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb
@@ -3,20 +3,19 @@ SECTION = "base"
PRIORITY = "optional"
MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
LICENSE = "GPL"
-
DEPENDS = "gpe-bootsplash"
RDEPENDS = "gpe-bootsplash"
-
-PR = "r0"
+PR = "r1"
export THEME = "e"
-SRC_URI = "file://*.svg"
-
-FILES_${PN} = "/usr/share/gpe/splash-${THEME}-*"
+SRC_URI = "file://splash-e-portrait.svg \
+ file://splash-e-landscape.svg"
+#FIXME: Please use $datadir instead of /usr/share
+#FIXME: please use an gpe-bootsplash-theme.inc to reduce duplication
-do_install(){
+do_install() {
install -d "${D}/usr/share/gpe"
install -m 0644 ${WORKDIR}/splash-${THEME}* ${D}/usr/share/gpe
}
@@ -30,3 +29,5 @@ pkg_postrm() {
update-alternatives --remove bootsplash-l /usr/share/gpe/splash-${THEME}-landscape.svg
update-alternatives --remove bootsplash-p /usr/share/gpe/splash-${THEME}-portrait.svg
}
+
+FILES_${PN} = "/usr/share/gpe/splash-${THEME}-*"