summaryrefslogtreecommitdiff
path: root/packages/gnutls
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gnutls')
-rw-r--r--packages/gnutls/gnutls-1.4.4/.mtn2git_empty0
-rw-r--r--packages/gnutls/gnutls-1.4.4/gnutls-openssl.patch120
-rw-r--r--packages/gnutls/gnutls-1.6.3/configure_madness.patch31
-rw-r--r--packages/gnutls/gnutls.inc6
-rw-r--r--packages/gnutls/gnutls_1.4.5.bb2
-rw-r--r--packages/gnutls/gnutls_1.6.3.bb2
6 files changed, 36 insertions, 125 deletions
diff --git a/packages/gnutls/gnutls-1.4.4/.mtn2git_empty b/packages/gnutls/gnutls-1.4.4/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/gnutls/gnutls-1.4.4/.mtn2git_empty
+++ /dev/null
diff --git a/packages/gnutls/gnutls-1.4.4/gnutls-openssl.patch b/packages/gnutls/gnutls-1.4.4/gnutls-openssl.patch
deleted file mode 100644
index 6eca97efd7..0000000000
--- a/packages/gnutls/gnutls-1.4.4/gnutls-openssl.patch
+++ /dev/null
@@ -1,120 +0,0 @@
---- gnutls-1.3.5/libextra/gnutls_openssl.c.orig 2006-04-28 20:01:40.000000000 +0100
-+++ gnutls-1.3.5/libextra/gnutls_openssl.c 2006-04-28 20:10:33.000000000 +0100
-@@ -252,12 +252,17 @@
- ssl->rfd = (gnutls_transport_ptr_t) - 1;
- ssl->wfd = (gnutls_transport_ptr_t) - 1;
-
-+ ssl->ssl_peek_buffer = NULL;
-+ ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
-+
- return ssl;
- }
-
- void
- SSL_free (SSL * ssl)
- {
-+ if (ssl->ssl_peek_buffer)
-+ free(ssl->ssl_peek_buffer);
- gnutls_certificate_free_credentials (ssl->gnutls_cred);
- gnutls_deinit (ssl->gnutls_state);
- free (ssl);
-@@ -281,6 +286,7 @@
- SSL_set_fd (SSL * ssl, int fd)
- {
- gnutls_transport_set_ptr (ssl->gnutls_state, (gnutls_transport_ptr_t) fd);
-+ ssl->rfd = ssl->wfd = fd;
- return 1;
- }
-
-@@ -306,6 +312,17 @@
- return 1;
- }
-
-+int SSL_get_rfd(SSL *ssl)
-+{
-+ return ssl->rfd;
-+}
-+
-+int SSL_get_wfd(SSL *ssl)
-+{
-+ return ssl->wfd;
-+}
-+
-+
- void
- SSL_set_bio (SSL * ssl, BIO * rbio, BIO * wbio)
- {
-@@ -321,6 +338,8 @@
- int
- SSL_pending (SSL * ssl)
- {
-+ if (ssl->ssl_peek_avail)
-+ return ssl->ssl_peek_avail;
- return gnutls_record_check_pending (ssl->gnutls_state);
- }
-
-@@ -476,11 +495,50 @@
- return 1;
- }
-
-+int SSL_peek(SSL *ssl, void *buf, int len)
-+{
-+ if (len > ssl->ssl_peek_buffer_size) {
-+ ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
-+ ssl->ssl_peek_buffer_size = len;
-+ }
-+
-+ if (ssl->ssl_peek_avail == 0) {
-+
-+ int ret;
-+
-+ ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
-+ ssl->last_error = ret;
-+
-+ if (ret > 0)
-+ ssl->ssl_peek_avail += ret;
-+ }
-+
-+ if (len > ssl->ssl_peek_avail)
-+ len = ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, len);
-+
-+ return len;
-+}
-+
- int
- SSL_read (SSL * ssl, void *buf, int len)
- {
- int ret;
-
-+ if (ssl->ssl_peek_avail) {
-+ int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, n);
-+
-+ if (ssl->ssl_peek_avail > n)
-+ memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
-+
-+ ssl->ssl_peek_avail -= n;
-+
-+ return n;
-+ }
-+
- ret = gnutls_record_recv (ssl->gnutls_state, buf, len);
- ssl->last_error = ret;
-
---- gnutls-1.3.5/includes/gnutls/openssl.h.orig 2006-04-28 20:10:55.000000000 +0100
-+++ gnutls-1.3.5/includes/gnutls/openssl.h 2006-04-28 20:11:52.000000000 +0100
-@@ -164,6 +164,11 @@
-
- gnutls_transport_ptr_t rfd;
- gnutls_transport_ptr_t wfd;
-+
-+ char *ssl_peek_buffer;
-+ size_t ssl_peek_buffer_size;
-+ size_t ssl_peek_avail;
-+
- };
-
- #define rbio gnutls_state
diff --git a/packages/gnutls/gnutls-1.6.3/configure_madness.patch b/packages/gnutls/gnutls-1.6.3/configure_madness.patch
index 26111dfe96..bdee81cc54 100644
--- a/packages/gnutls/gnutls-1.6.3/configure_madness.patch
+++ b/packages/gnutls/gnutls-1.6.3/configure_madness.patch
@@ -1,7 +1,7 @@
Index: gnutls-1.6.3/configure.in
===================================================================
---- gnutls-1.6.3.orig/configure.in 2007-05-25 12:28:59.000000000 +0000
-+++ gnutls-1.6.3/configure.in 2007-11-13 17:53:23.000000000 +0000
+--- gnutls-1.6.3.orig/configure.in 2008-02-29 09:58:12.000000000 +0000
++++ gnutls-1.6.3/configure.in 2008-02-29 09:58:15.000000000 +0000
@@ -574,13 +574,13 @@
AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
@@ -20,3 +20,30 @@ Index: gnutls-1.6.3/configure.in
AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)
export ac_full
+Index: gnutls-1.6.3/lib/gnutls.pc.in
+===================================================================
+--- gnutls-1.6.3.orig/lib/gnutls.pc.in 2008-02-29 09:58:23.000000000 +0000
++++ gnutls-1.6.3/lib/gnutls.pc.in 2008-02-29 09:58:49.000000000 +0000
+@@ -18,6 +18,7 @@
+ Name: GnuTLS
+ Description: Transport Security Layer implementation for the GNU system
+ Version: @VERSION@
++Requires.private: gcrypt
+ Libs: -L${libdir} -lgnutls
+-Libs.private: @LIBGNUTLS_LIBS@
++Libs.private: -L${libdir} -lgnutls
+ Cflags: -I${includedir}
+Index: gnutls-1.6.3/libextra/gnutls-extra.pc.in
+===================================================================
+--- gnutls-1.6.3.orig/libextra/gnutls-extra.pc.in 2008-02-29 09:59:02.000000000 +0000
++++ gnutls-1.6.3/libextra/gnutls-extra.pc.in 2008-02-29 09:59:31.000000000 +0000
+@@ -18,7 +18,8 @@
+ Name: GnuTLS-extra
+ Description: Additional add-ons for GnuTLS licensed under GPL
+ Requires: gnutls
++Requires.private: gnutls
+ Version: @VERSION@
+ Libs: -L${libdir} -lgnutls-extra
+-Libs.private: @LIBGNUTLS_EXTRA_LIBS@
++Libs.private: -L${libdir} -lgnutls-extra
+ Cflags: -I${includedir}
diff --git a/packages/gnutls/gnutls.inc b/packages/gnutls/gnutls.inc
index d08b0ca931..781267093c 100644
--- a/packages/gnutls/gnutls.inc
+++ b/packages/gnutls/gnutls.inc
@@ -1,7 +1,6 @@
DESCRIPTION = "GNU Transport Layer Security Library"
HOMEPAGE = "http://www.gnu.org/software/gnutls/"
DEPENDS = "zlib libgcrypt lzo"
-
LICENSE = "LGPL"
SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2"
@@ -10,6 +9,11 @@ inherit autotools binconfig pkgconfig
EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
+# fix wrong dependency
+do_configure_append() {
+ sed -i s,gcrypt,libgcrypt, lib/gnutls.pc.in
+}
+
do_stage() {
oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
diff --git a/packages/gnutls/gnutls_1.4.5.bb b/packages/gnutls/gnutls_1.4.5.bb
index 3337e0b370..4c247717ae 100644
--- a/packages/gnutls/gnutls_1.4.5.bb
+++ b/packages/gnutls/gnutls_1.4.5.bb
@@ -1,3 +1,3 @@
require gnutls.inc
-PR = "r1"
+PR = "r2"
diff --git a/packages/gnutls/gnutls_1.6.3.bb b/packages/gnutls/gnutls_1.6.3.bb
index ddaef1dea3..cc35d8b7a3 100644
--- a/packages/gnutls/gnutls_1.6.3.bb
+++ b/packages/gnutls/gnutls_1.6.3.bb
@@ -6,4 +6,4 @@ SRC_URI += "\
file://configure_madness.patch;patch=1 \
"
-PR = "r3"
+PR = "r5"