summaryrefslogtreecommitdiff
path: root/packages/gnutls
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gnutls')
-rw-r--r--packages/gnutls/gnutls-1.0.23/export-symbols.patch11
-rw-r--r--packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch126
-rw-r--r--packages/gnutls/gnutls-1.0.25/.mtn2git_empty0
-rw-r--r--packages/gnutls/gnutls-1.0.25/export-symbols.patch11
-rw-r--r--packages/gnutls/gnutls-1.0.25/gnutls-openssl.patch126
-rw-r--r--packages/gnutls/gnutls-1.3.5/.mtn2git_empty0
-rw-r--r--packages/gnutls/gnutls-1.4.0/.mtn2git_empty0
-rw-r--r--packages/gnutls/gnutls-1.4.0/gnutls-openssl.patch120
-rw-r--r--packages/gnutls/gnutls-1.4.0/gnutls-texinfo-euro.patch16
-rw-r--r--packages/gnutls/gnutls-1.4.4/gnutls-texinfo-euro.patch16
-rw-r--r--packages/gnutls/gnutls.inc (renamed from packages/gnutls/gnutls_1.4.0.bb)47
-rw-r--r--packages/gnutls/gnutls/.mtn2git_empty (renamed from packages/gnutls/gnutls-1.0.23/.mtn2git_empty)0
-rw-r--r--packages/gnutls/gnutls/gnutls-openssl.patch (renamed from packages/gnutls/gnutls-1.3.5/gnutls-openssl.patch)24
-rw-r--r--packages/gnutls/gnutls/gnutls-texinfo-euro.patch (renamed from packages/gnutls/gnutls-1.3.5/gnutls-texinfo-euro.patch)0
-rw-r--r--packages/gnutls/gnutls/onceonly.m4 (renamed from packages/gnutls/gnutls-1.4.4/onceonly.m4)0
-rw-r--r--packages/gnutls/gnutls_1.0.23.bb33
-rw-r--r--packages/gnutls/gnutls_1.0.25.bb33
-rw-r--r--packages/gnutls/gnutls_1.3.5.bb38
-rw-r--r--packages/gnutls/gnutls_1.4.4.bb42
-rw-r--r--packages/gnutls/gnutls_1.6.0.bb7
20 files changed, 49 insertions, 601 deletions
diff --git a/packages/gnutls/gnutls-1.0.23/export-symbols.patch b/packages/gnutls/gnutls-1.0.23/export-symbols.patch
deleted file mode 100644
index 22a1373944..0000000000
--- a/packages/gnutls/gnutls-1.0.23/export-symbols.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gnutls-1.0.23/lib/Makefile.am.orig 2005-06-04 13:46:26.000000000 +0200
-+++ gnutls-1.0.23/lib/Makefile.am 2005-06-04 13:48:38.000000000 +0200
-@@ -9,7 +9,7 @@
- pkgconfig_DATA = gnutls.pc
- DISTCLEANFILES = $(pkgconfig_DATA)
-
--LIBGNUTLS_EXPORTS = -export-symbols-regex '^(_gnutls|gnutls|_E_).*'
-+LIBGNUTLS_EXPORTS = -export-symbols-regex '^(asn1_|_gnutls|gnutls|_E_).*'
-
- DIST_SUBDIRS = minitasn1 x509
- if ENABLE_MINITASN1
diff --git a/packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch b/packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch
deleted file mode 100644
index 3ddd8b3a18..0000000000
--- a/packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch
+++ /dev/null
@@ -1,126 +0,0 @@
---- clean/gnutls-1.0.23/libextra/gnutls_openssl.c 2004-08-04 22:36:03.000000000 +0100
-+++ gnutls-1.0.23/libextra/gnutls_openssl.c 2005-01-02 19:50:49.000000000 +0000
-@@ -31,7 +31,6 @@
-
- static int last_error = 0;
-
--
- /* Library initialisation functions */
-
- int SSL_library_init(void)
-@@ -219,12 +218,17 @@
-
- ssl->rfd = (gnutls_transport_ptr)-1;
- ssl->wfd = (gnutls_transport_ptr)-1;
-+
-+ ssl->ssl_peek_buffer = NULL;
-+ ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
-
- return ssl;
- }
-
- void SSL_free(SSL *ssl)
- {
-+ if (ssl->ssl_peek_buffer)
-+ free(ssl->ssl_peek_buffer);
- gnutls_certificate_free_credentials(ssl->gnutls_cred);
- gnutls_deinit(ssl->gnutls_state);
- free(ssl);
-@@ -245,6 +249,7 @@
- int SSL_set_fd(SSL *ssl, int fd)
- {
- gnutls_transport_set_ptr (ssl->gnutls_state, (gnutls_transport_ptr)fd);
-+ ssl->rfd = ssl->wfd = fd;
- return 1;
- }
-
-@@ -268,6 +273,16 @@
- return 1;
- }
-
-+int SSL_get_rfd(SSL *ssl)
-+{
-+ return ssl->rfd;
-+}
-+
-+int SSL_get_wfd(SSL *ssl)
-+{
-+ return ssl->wfd;
-+}
-+
- void SSL_set_bio(SSL *ssl, BIO *rbio, BIO *wbio)
- {
- gnutls_transport_set_ptr2 (ssl->gnutls_state, rbio->fd, wbio->fd);
-@@ -280,6 +295,9 @@
-
- int SSL_pending(SSL *ssl)
- {
-+ if (ssl->ssl_peek_avail)
-+ return ssl->ssl_peek_avail;
-+
- return gnutls_record_check_pending(ssl->gnutls_state);
- }
-
-@@ -430,10 +448,49 @@
- return 1;
- }
-
-+int SSL_peek(SSL *ssl, void *buf, int len)
-+{
-+ if (len > ssl->ssl_peek_buffer_size) {
-+ ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
-+ ssl->ssl_peek_buffer_size = len;
-+ }
-+
-+ if (ssl->ssl_peek_avail == 0) {
-+
-+ int ret;
-+
-+ ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
-+ ssl->last_error = ret;
-+
-+ if (ret > 0)
-+ ssl->ssl_peek_avail += ret;
-+ }
-+
-+ if (len > ssl->ssl_peek_avail)
-+ len = ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, len);
-+
-+ return len;
-+}
-+
- int SSL_read(SSL *ssl, void *buf, int len)
- {
- int ret;
-
-+ if (ssl->ssl_peek_avail) {
-+ int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, n);
-+
-+ if (ssl->ssl_peek_avail > n)
-+ memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
-+
-+ ssl->ssl_peek_avail -= n;
-+
-+ return n;
-+ }
-+
- ret = gnutls_record_recv(ssl->gnutls_state, buf, len);
- ssl->last_error = ret;
-
---- clean/gnutls-1.0.23/includes/gnutls/openssl.h 2004-08-04 22:36:02.000000000 +0100
-+++ gnutls-1.0.23/includes/gnutls/openssl.h 2005-01-02 19:48:35.000000000 +0000
-@@ -139,6 +139,10 @@
-
- gnutls_transport_ptr rfd;
- gnutls_transport_ptr wfd;
-+
-+ char *ssl_peek_buffer;
-+ size_t ssl_peek_buffer_size;
-+ size_t ssl_peek_avail;
- } SSL;
-
- typedef struct
diff --git a/packages/gnutls/gnutls-1.0.25/.mtn2git_empty b/packages/gnutls/gnutls-1.0.25/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/gnutls/gnutls-1.0.25/.mtn2git_empty
+++ /dev/null
diff --git a/packages/gnutls/gnutls-1.0.25/export-symbols.patch b/packages/gnutls/gnutls-1.0.25/export-symbols.patch
deleted file mode 100644
index 22a1373944..0000000000
--- a/packages/gnutls/gnutls-1.0.25/export-symbols.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gnutls-1.0.23/lib/Makefile.am.orig 2005-06-04 13:46:26.000000000 +0200
-+++ gnutls-1.0.23/lib/Makefile.am 2005-06-04 13:48:38.000000000 +0200
-@@ -9,7 +9,7 @@
- pkgconfig_DATA = gnutls.pc
- DISTCLEANFILES = $(pkgconfig_DATA)
-
--LIBGNUTLS_EXPORTS = -export-symbols-regex '^(_gnutls|gnutls|_E_).*'
-+LIBGNUTLS_EXPORTS = -export-symbols-regex '^(asn1_|_gnutls|gnutls|_E_).*'
-
- DIST_SUBDIRS = minitasn1 x509
- if ENABLE_MINITASN1
diff --git a/packages/gnutls/gnutls-1.0.25/gnutls-openssl.patch b/packages/gnutls/gnutls-1.0.25/gnutls-openssl.patch
deleted file mode 100644
index 3ddd8b3a18..0000000000
--- a/packages/gnutls/gnutls-1.0.25/gnutls-openssl.patch
+++ /dev/null
@@ -1,126 +0,0 @@
---- clean/gnutls-1.0.23/libextra/gnutls_openssl.c 2004-08-04 22:36:03.000000000 +0100
-+++ gnutls-1.0.23/libextra/gnutls_openssl.c 2005-01-02 19:50:49.000000000 +0000
-@@ -31,7 +31,6 @@
-
- static int last_error = 0;
-
--
- /* Library initialisation functions */
-
- int SSL_library_init(void)
-@@ -219,12 +218,17 @@
-
- ssl->rfd = (gnutls_transport_ptr)-1;
- ssl->wfd = (gnutls_transport_ptr)-1;
-+
-+ ssl->ssl_peek_buffer = NULL;
-+ ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
-
- return ssl;
- }
-
- void SSL_free(SSL *ssl)
- {
-+ if (ssl->ssl_peek_buffer)
-+ free(ssl->ssl_peek_buffer);
- gnutls_certificate_free_credentials(ssl->gnutls_cred);
- gnutls_deinit(ssl->gnutls_state);
- free(ssl);
-@@ -245,6 +249,7 @@
- int SSL_set_fd(SSL *ssl, int fd)
- {
- gnutls_transport_set_ptr (ssl->gnutls_state, (gnutls_transport_ptr)fd);
-+ ssl->rfd = ssl->wfd = fd;
- return 1;
- }
-
-@@ -268,6 +273,16 @@
- return 1;
- }
-
-+int SSL_get_rfd(SSL *ssl)
-+{
-+ return ssl->rfd;
-+}
-+
-+int SSL_get_wfd(SSL *ssl)
-+{
-+ return ssl->wfd;
-+}
-+
- void SSL_set_bio(SSL *ssl, BIO *rbio, BIO *wbio)
- {
- gnutls_transport_set_ptr2 (ssl->gnutls_state, rbio->fd, wbio->fd);
-@@ -280,6 +295,9 @@
-
- int SSL_pending(SSL *ssl)
- {
-+ if (ssl->ssl_peek_avail)
-+ return ssl->ssl_peek_avail;
-+
- return gnutls_record_check_pending(ssl->gnutls_state);
- }
-
-@@ -430,10 +448,49 @@
- return 1;
- }
-
-+int SSL_peek(SSL *ssl, void *buf, int len)
-+{
-+ if (len > ssl->ssl_peek_buffer_size) {
-+ ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
-+ ssl->ssl_peek_buffer_size = len;
-+ }
-+
-+ if (ssl->ssl_peek_avail == 0) {
-+
-+ int ret;
-+
-+ ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
-+ ssl->last_error = ret;
-+
-+ if (ret > 0)
-+ ssl->ssl_peek_avail += ret;
-+ }
-+
-+ if (len > ssl->ssl_peek_avail)
-+ len = ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, len);
-+
-+ return len;
-+}
-+
- int SSL_read(SSL *ssl, void *buf, int len)
- {
- int ret;
-
-+ if (ssl->ssl_peek_avail) {
-+ int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, n);
-+
-+ if (ssl->ssl_peek_avail > n)
-+ memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
-+
-+ ssl->ssl_peek_avail -= n;
-+
-+ return n;
-+ }
-+
- ret = gnutls_record_recv(ssl->gnutls_state, buf, len);
- ssl->last_error = ret;
-
---- clean/gnutls-1.0.23/includes/gnutls/openssl.h 2004-08-04 22:36:02.000000000 +0100
-+++ gnutls-1.0.23/includes/gnutls/openssl.h 2005-01-02 19:48:35.000000000 +0000
-@@ -139,6 +139,10 @@
-
- gnutls_transport_ptr rfd;
- gnutls_transport_ptr wfd;
-+
-+ char *ssl_peek_buffer;
-+ size_t ssl_peek_buffer_size;
-+ size_t ssl_peek_avail;
- } SSL;
-
- typedef struct
diff --git a/packages/gnutls/gnutls-1.3.5/.mtn2git_empty b/packages/gnutls/gnutls-1.3.5/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/gnutls/gnutls-1.3.5/.mtn2git_empty
+++ /dev/null
diff --git a/packages/gnutls/gnutls-1.4.0/.mtn2git_empty b/packages/gnutls/gnutls-1.4.0/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/gnutls/gnutls-1.4.0/.mtn2git_empty
+++ /dev/null
diff --git a/packages/gnutls/gnutls-1.4.0/gnutls-openssl.patch b/packages/gnutls/gnutls-1.4.0/gnutls-openssl.patch
deleted file mode 100644
index 6eca97efd7..0000000000
--- a/packages/gnutls/gnutls-1.4.0/gnutls-openssl.patch
+++ /dev/null
@@ -1,120 +0,0 @@
---- gnutls-1.3.5/libextra/gnutls_openssl.c.orig 2006-04-28 20:01:40.000000000 +0100
-+++ gnutls-1.3.5/libextra/gnutls_openssl.c 2006-04-28 20:10:33.000000000 +0100
-@@ -252,12 +252,17 @@
- ssl->rfd = (gnutls_transport_ptr_t) - 1;
- ssl->wfd = (gnutls_transport_ptr_t) - 1;
-
-+ ssl->ssl_peek_buffer = NULL;
-+ ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
-+
- return ssl;
- }
-
- void
- SSL_free (SSL * ssl)
- {
-+ if (ssl->ssl_peek_buffer)
-+ free(ssl->ssl_peek_buffer);
- gnutls_certificate_free_credentials (ssl->gnutls_cred);
- gnutls_deinit (ssl->gnutls_state);
- free (ssl);
-@@ -281,6 +286,7 @@
- SSL_set_fd (SSL * ssl, int fd)
- {
- gnutls_transport_set_ptr (ssl->gnutls_state, (gnutls_transport_ptr_t) fd);
-+ ssl->rfd = ssl->wfd = fd;
- return 1;
- }
-
-@@ -306,6 +312,17 @@
- return 1;
- }
-
-+int SSL_get_rfd(SSL *ssl)
-+{
-+ return ssl->rfd;
-+}
-+
-+int SSL_get_wfd(SSL *ssl)
-+{
-+ return ssl->wfd;
-+}
-+
-+
- void
- SSL_set_bio (SSL * ssl, BIO * rbio, BIO * wbio)
- {
-@@ -321,6 +338,8 @@
- int
- SSL_pending (SSL * ssl)
- {
-+ if (ssl->ssl_peek_avail)
-+ return ssl->ssl_peek_avail;
- return gnutls_record_check_pending (ssl->gnutls_state);
- }
-
-@@ -476,11 +495,50 @@
- return 1;
- }
-
-+int SSL_peek(SSL *ssl, void *buf, int len)
-+{
-+ if (len > ssl->ssl_peek_buffer_size) {
-+ ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
-+ ssl->ssl_peek_buffer_size = len;
-+ }
-+
-+ if (ssl->ssl_peek_avail == 0) {
-+
-+ int ret;
-+
-+ ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
-+ ssl->last_error = ret;
-+
-+ if (ret > 0)
-+ ssl->ssl_peek_avail += ret;
-+ }
-+
-+ if (len > ssl->ssl_peek_avail)
-+ len = ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, len);
-+
-+ return len;
-+}
-+
- int
- SSL_read (SSL * ssl, void *buf, int len)
- {
- int ret;
-
-+ if (ssl->ssl_peek_avail) {
-+ int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, n);
-+
-+ if (ssl->ssl_peek_avail > n)
-+ memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
-+
-+ ssl->ssl_peek_avail -= n;
-+
-+ return n;
-+ }
-+
- ret = gnutls_record_recv (ssl->gnutls_state, buf, len);
- ssl->last_error = ret;
-
---- gnutls-1.3.5/includes/gnutls/openssl.h.orig 2006-04-28 20:10:55.000000000 +0100
-+++ gnutls-1.3.5/includes/gnutls/openssl.h 2006-04-28 20:11:52.000000000 +0100
-@@ -164,6 +164,11 @@
-
- gnutls_transport_ptr_t rfd;
- gnutls_transport_ptr_t wfd;
-+
-+ char *ssl_peek_buffer;
-+ size_t ssl_peek_buffer_size;
-+ size_t ssl_peek_avail;
-+
- };
-
- #define rbio gnutls_state
diff --git a/packages/gnutls/gnutls-1.4.0/gnutls-texinfo-euro.patch b/packages/gnutls/gnutls-1.4.0/gnutls-texinfo-euro.patch
deleted file mode 100644
index e2a2762424..0000000000
--- a/packages/gnutls/gnutls-1.4.0/gnutls-texinfo-euro.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-The version of texinfo in Debian Sarge does not understand the @euro{} command.
-This patch replaces the @euro{} command with the word "euro".
-
---- gnutls-1.3.5/doc/signatures.texi.orig 2006-04-26 08:06:40.918268000 +0930
-+++ gnutls-1.3.5/doc/signatures.texi 2006-04-26 08:06:52.446515440 +0930
-@@ -11,8 +11,8 @@
- long as it is difficult enough to generate two different messages with
- the same hash algorithm output. In that case the same signature could
- be used as a proof for both messages. Nobody wants to sign an innocent
--message of donating 1 @euro{} to Greenpeace and find out that he
--donated 1.000.000 @euro{} to Bad Inc.
-+message of donating 1 euro to Greenpeace and find out that he
-+donated 1.000.000 euro to Bad Inc.
-
- For a hash algorithm to be called cryptographic the following three
- requirements must hold
diff --git a/packages/gnutls/gnutls-1.4.4/gnutls-texinfo-euro.patch b/packages/gnutls/gnutls-1.4.4/gnutls-texinfo-euro.patch
deleted file mode 100644
index e2a2762424..0000000000
--- a/packages/gnutls/gnutls-1.4.4/gnutls-texinfo-euro.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-The version of texinfo in Debian Sarge does not understand the @euro{} command.
-This patch replaces the @euro{} command with the word "euro".
-
---- gnutls-1.3.5/doc/signatures.texi.orig 2006-04-26 08:06:40.918268000 +0930
-+++ gnutls-1.3.5/doc/signatures.texi 2006-04-26 08:06:52.446515440 +0930
-@@ -11,8 +11,8 @@
- long as it is difficult enough to generate two different messages with
- the same hash algorithm output. In that case the same signature could
- be used as a proof for both messages. Nobody wants to sign an innocent
--message of donating 1 @euro{} to Greenpeace and find out that he
--donated 1.000.000 @euro{} to Bad Inc.
-+message of donating 1 euro to Greenpeace and find out that he
-+donated 1.000.000 euro to Bad Inc.
-
- For a hash algorithm to be called cryptographic the following three
- requirements must hold
diff --git a/packages/gnutls/gnutls_1.4.0.bb b/packages/gnutls/gnutls.inc
index 0267684946..0d13d132de 100644
--- a/packages/gnutls/gnutls_1.4.0.bb
+++ b/packages/gnutls/gnutls.inc
@@ -1,37 +1,42 @@
DESCRIPTION = "GNU Transport Layer Security Library"
-DEPENDS = "zlib libgcrypt lzo"
HOMEPAGE = "http://www.gnu.org/software/gnutls/"
+DEPENDS = "zlib libgcrypt lzo"
+
LICENSE = "LGPL"
-PR = "r1"
SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2 \
file://gnutls-openssl.patch;patch=1 \
+ file://onceonly.m4 \
file://gnutls-texinfo-euro.patch;patch=1"
inherit autotools binconfig
-PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
-FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
-FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
-FILES_${PN} = "${libdir}/libgnutls.so.*"
-FILES_${PN}-bin = "${bindir}/gnutls-serv \
- ${bindir}/gnutls-cli \
- ${bindir}/srptool \
- ${bindir}/certtool \
- ${bindir}/gnutls-srpcrypt \
- ${bindir}/psktool"
-
-FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
-
EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
+do_configure_prepend() {
+ cp ${WORKDIR}/onceonly.m4 ${S}/m4/
+}
+
do_stage() {
- oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
- oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
- oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
- autotools_stage_includes
+ oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
+ autotools_stage_includes
- install -d ${STAGING_DATADIR}/aclocal
- cp ${S}/lib/libgnutls.m4 ${STAGING_DATADIR}/aclocal/
+ install -d ${STAGING_DATADIR}/aclocal
+ cp ${S}/lib/libgnutls.m4 ${STAGING_DATADIR}/aclocal/
}
+PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
+
+FILES_${PN} = "${libdir}/libgnutls.so.*"
+FILES_${PN}-bin = "${bindir}/gnutls-serv \
+ ${bindir}/gnutls-cli \
+ ${bindir}/srptool \
+ ${bindir}/psktool \
+ ${bindir}/certtool \
+ ${bindir}/gnutls-srpcrypt"
+
+FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
+FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
+FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
diff --git a/packages/gnutls/gnutls-1.0.23/.mtn2git_empty b/packages/gnutls/gnutls/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/gnutls/gnutls-1.0.23/.mtn2git_empty
+++ b/packages/gnutls/gnutls/.mtn2git_empty
diff --git a/packages/gnutls/gnutls-1.3.5/gnutls-openssl.patch b/packages/gnutls/gnutls/gnutls-openssl.patch
index 6eca97efd7..e2c189592f 100644
--- a/packages/gnutls/gnutls-1.3.5/gnutls-openssl.patch
+++ b/packages/gnutls/gnutls/gnutls-openssl.patch
@@ -1,6 +1,8 @@
---- gnutls-1.3.5/libextra/gnutls_openssl.c.orig 2006-04-28 20:01:40.000000000 +0100
-+++ gnutls-1.3.5/libextra/gnutls_openssl.c 2006-04-28 20:10:33.000000000 +0100
-@@ -252,12 +252,17 @@
+Index: gnutls-1.6.0/libextra/gnutls_openssl.c
+===================================================================
+--- gnutls-1.6.0.orig/libextra/gnutls_openssl.c 2006-08-13 22:34:09.000000000 +0200
++++ gnutls-1.6.0/libextra/gnutls_openssl.c 2006-12-12 15:07:59.002227000 +0100
+@@ -256,12 +256,17 @@
ssl->rfd = (gnutls_transport_ptr_t) - 1;
ssl->wfd = (gnutls_transport_ptr_t) - 1;
@@ -18,15 +20,15 @@
gnutls_certificate_free_credentials (ssl->gnutls_cred);
gnutls_deinit (ssl->gnutls_state);
free (ssl);
-@@ -281,6 +286,7 @@
+@@ -285,6 +290,7 @@
SSL_set_fd (SSL * ssl, int fd)
{
- gnutls_transport_set_ptr (ssl->gnutls_state, (gnutls_transport_ptr_t) fd);
+ gnutls_transport_set_ptr (ssl->gnutls_state, GNUTLS_INT_TO_POINTER (fd));
+ ssl->rfd = ssl->wfd = fd;
return 1;
}
-@@ -306,6 +312,17 @@
+@@ -310,6 +316,17 @@
return 1;
}
@@ -44,7 +46,7 @@
void
SSL_set_bio (SSL * ssl, BIO * rbio, BIO * wbio)
{
-@@ -321,6 +338,8 @@
+@@ -325,6 +342,8 @@
int
SSL_pending (SSL * ssl)
{
@@ -53,7 +55,7 @@
return gnutls_record_check_pending (ssl->gnutls_state);
}
-@@ -476,11 +495,50 @@
+@@ -480,11 +499,50 @@
return 1;
}
@@ -104,8 +106,10 @@
ret = gnutls_record_recv (ssl->gnutls_state, buf, len);
ssl->last_error = ret;
---- gnutls-1.3.5/includes/gnutls/openssl.h.orig 2006-04-28 20:10:55.000000000 +0100
-+++ gnutls-1.3.5/includes/gnutls/openssl.h 2006-04-28 20:11:52.000000000 +0100
+Index: gnutls-1.6.0/includes/gnutls/openssl.h
+===================================================================
+--- gnutls-1.6.0.orig/includes/gnutls/openssl.h 2006-03-08 11:44:58.000000000 +0100
++++ gnutls-1.6.0/includes/gnutls/openssl.h 2006-12-12 15:07:26.032227000 +0100
@@ -164,6 +164,11 @@
gnutls_transport_ptr_t rfd;
diff --git a/packages/gnutls/gnutls-1.3.5/gnutls-texinfo-euro.patch b/packages/gnutls/gnutls/gnutls-texinfo-euro.patch
index e2a2762424..e2a2762424 100644
--- a/packages/gnutls/gnutls-1.3.5/gnutls-texinfo-euro.patch
+++ b/packages/gnutls/gnutls/gnutls-texinfo-euro.patch
diff --git a/packages/gnutls/gnutls-1.4.4/onceonly.m4 b/packages/gnutls/gnutls/onceonly.m4
index f6fec37cbf..f6fec37cbf 100644
--- a/packages/gnutls/gnutls-1.4.4/onceonly.m4
+++ b/packages/gnutls/gnutls/onceonly.m4
diff --git a/packages/gnutls/gnutls_1.0.23.bb b/packages/gnutls/gnutls_1.0.23.bb
deleted file mode 100644
index 76dd844db8..0000000000
--- a/packages/gnutls/gnutls_1.0.23.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-DESCRIPTION = "GNU Transport Layer Security Library"
-DEPENDS = "zlib libgcrypt"
-PR = "r6"
-
-LICENSE = "LGPL"
-
-SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/attic/gnutls-${PV}.tar.gz \
- file://gnutls-openssl.patch;patch=1 \
- file://export-symbols.patch;patch=1"
-
-inherit autotools
-inherit binconfig
-
-PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
-FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
-FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
-FILES_${PN} = "${libdir}/libgnutls.so.*"
-FILES_${PN}-bin = "${bindir}/gnutls-serv ${bindir}/gnutls-cli \
- ${bindir}/srptool ${bindir}/certtool ${bindir}/gnutls-srpcrypt"
-FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
-
-EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
-
-do_stage() {
- oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
- oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
- oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
- autotools_stage_includes
-
- install -d ${STAGING_DATADIR}/aclocal
- cp ${S}/lib/libgnutls.m4 ${STAGING_DATADIR}/aclocal/
-}
-
diff --git a/packages/gnutls/gnutls_1.0.25.bb b/packages/gnutls/gnutls_1.0.25.bb
deleted file mode 100644
index 4b4b63c63c..0000000000
--- a/packages/gnutls/gnutls_1.0.25.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-DESCRIPTION = "GNU Transport Layer Security Library"
-DEPENDS = "zlib libgcrypt"
-PR = "r2"
-
-LICENSE = "LGPL"
-
-SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.gz \
- file://gnutls-openssl.patch;patch=1 \
- file://export-symbols.patch;patch=1"
-
-inherit autotools
-inherit binconfig
-
-PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
-FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
-FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
-FILES_${PN} = "${libdir}/libgnutls.so.*"
-FILES_${PN}-bin = "${bindir}/gnutls-serv ${bindir}/gnutls-cli \
- ${bindir}/srptool ${bindir}/certtool ${bindir}/gnutls-srpcrypt"
-FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
-
-EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
-
-do_stage() {
- oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
- oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
- oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
- autotools_stage_includes
-
- install -d ${STAGING_DATADIR}/aclocal
- cp ${S}/lib/libgnutls.m4 ${STAGING_DATADIR}/aclocal/
-}
-
diff --git a/packages/gnutls/gnutls_1.3.5.bb b/packages/gnutls/gnutls_1.3.5.bb
deleted file mode 100644
index bcadacb41a..0000000000
--- a/packages/gnutls/gnutls_1.3.5.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-DESCRIPTION = "GNU Transport Layer Security Library"
-DEPENDS = "zlib libgcrypt lzo"
-
-LICENSE = "LGPL"
-PR = "r4"
-
-SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/devel/gnutls-${PV}.tar.bz2 \
- file://gnutls-openssl.patch;patch=1 \
- file://gnutls-texinfo-euro.patch;patch=1"
-
-inherit autotools
-inherit binconfig
-
-PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
-FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
-FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
-FILES_${PN} = "${libdir}/libgnutls.so.*"
-FILES_${PN}-bin = "${bindir}/gnutls-serv \
- ${bindir}/gnutls-cli \
- ${bindir}/srptool \
- ${bindir}/certtool \
- ${bindir}/gnutls-srpcrypt \
- ${bindir}/psktool"
-
-FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
-
-EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
-
-do_stage() {
- oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
- oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
- oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
- autotools_stage_includes
-
- install -d ${STAGING_DATADIR}/aclocal
- cp ${S}/lib/libgnutls.m4 ${STAGING_DATADIR}/aclocal/
-}
-
diff --git a/packages/gnutls/gnutls_1.4.4.bb b/packages/gnutls/gnutls_1.4.4.bb
index e80dc3bb2f..3337e0b370 100644
--- a/packages/gnutls/gnutls_1.4.4.bb
+++ b/packages/gnutls/gnutls_1.4.4.bb
@@ -1,41 +1,3 @@
-DESCRIPTION = "GNU Transport Layer Security Library"
-DEPENDS = "zlib libgcrypt lzo"
-HOMEPAGE = "http://www.gnu.org/software/gnutls/"
-LICENSE = "LGPL"
-
-SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2 \
- file://onceonly.m4 \
- file://gnutls-openssl.patch;patch=1 \
- file://gnutls-texinfo-euro.patch;patch=1"
-
-inherit autotools binconfig
-
-do_configure_prepend() {
- cp ${WORKDIR}/onceonly.m4 ${S}/m4/
-}
-
-PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
-FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
-FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
-FILES_${PN} = "${libdir}/libgnutls.so.*"
-FILES_${PN}-bin = "${bindir}/gnutls-serv \
- ${bindir}/gnutls-cli \
- ${bindir}/srptool \
- ${bindir}/certtool \
- ${bindir}/gnutls-srpcrypt \
- ${bindir}/psktool"
-
-FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
-
-EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
-
-do_stage() {
- oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
- oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
- oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
- autotools_stage_includes
-
- install -d ${STAGING_DATADIR}/aclocal
- cp ${S}/lib/libgnutls.m4 ${STAGING_DATADIR}/aclocal/
-}
+require gnutls.inc
+PR = "r1"
diff --git a/packages/gnutls/gnutls_1.6.0.bb b/packages/gnutls/gnutls_1.6.0.bb
new file mode 100644
index 0000000000..c5dffdc05c
--- /dev/null
+++ b/packages/gnutls/gnutls_1.6.0.bb
@@ -0,0 +1,7 @@
+require gnutls.inc
+
+PR = "r1"
+
+do_configure_prepend() {
+ sed -i "s/2.60/2.59/" ${S}/configure.in
+}