summaryrefslogtreecommitdiff
path: root/packages/gnuplot/gnuplot_4.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gnuplot/gnuplot_4.2.0.bb')
-rw-r--r--packages/gnuplot/gnuplot_4.2.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/gnuplot/gnuplot_4.2.0.bb b/packages/gnuplot/gnuplot_4.2.0.bb
new file mode 100644
index 0000000000..c6f51c4f15
--- /dev/null
+++ b/packages/gnuplot/gnuplot_4.2.0.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
+(text or binary) and function plotting utility."
+SECTION = "console/scientific"
+LICENSE = "BSD-4"
+PRIORITY = "optional"
+DEPENDS = "pango cairo virtual/libx11 libpng gd readline"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${PN}-${PV}.tar.gz \
+ file://subdirs.patch;patch=1 \
+ file://matrix.patch;patch=1 \
+ file://gnuplot.desktop \
+ file://gnuplot.png"
+
+inherit autotools
+
+acpaths = ""
+EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
+ --without-plot \
+ --with-png=${STAGING_LIBDIR}/.. \
+ --with-gd=${STAGING_LIBDIR}/.. \
+ --without-lisp-files \
+ --without-tutorial"
+
+do_install_append() {
+ install -d ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
+}
+
+
+PACKAGES =+ "${PN}-x11-dbg ${PN}-x11"
+DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
+SECTION_${PN}-x11 = "x11/scientific"
+FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 "
+
+FILES_${PN} += "${datadir}/texmf"
+FILES_${PN}-x11-dbg += "${libexecdir}/gnuplot/*/.debug"
+
+