summaryrefslogtreecommitdiff
path: root/packages/gnuchess
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gnuchess')
-rw-r--r--packages/gnuchess/fltk-chess_0.51.bb29
-rw-r--r--packages/gnuchess/gnuchess_5.021.bb13
2 files changed, 42 insertions, 0 deletions
diff --git a/packages/gnuchess/fltk-chess_0.51.bb b/packages/gnuchess/fltk-chess_0.51.bb
new file mode 100644
index 0000000000..512e260008
--- /dev/null
+++ b/packages/gnuchess/fltk-chess_0.51.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "fltk-chess is a frontend for the Gnuchess chess playing engine."
+AUTHOR = "Andreas Holzer <a.holzer@cheese.at>"
+SECTION = "x11/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "fltk"
+RDEPENDS = "gnuchess"
+
+
+SRC_URI = "http://members.cheese.at/woody/zaurus/src/fltk-chess-${PV}.tgz"
+S = "${WORKDIR}/fltk-chess/"
+
+
+do_compile() {
+ `fltk-config --cxx --cxxflags --ldflags --use-images` -o fltk-chess \
+ fltk-chess.cxx
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/pixmaps/fltk-chess/
+ install -d ${D}${datadir}/applications/
+ install -m 0755 ${S}/fltk-chess ${D}${bindir}
+ install -m 0644 ${S}/bitmaps/*.pnx ${D}${datadir}/pixmaps/fltk-chess/
+ install -m 0644 ${S}/bitmaps/{user,computer}.png \
+ ${D}${datadir}/pixmaps/fltk-chess/
+ install -m 0644 ${S}/bitmaps/fltk-chess.png ${D}${datadir}/pixmaps/
+ install -m 0644 ${S}/fltk-chess.desktop ${D}${datadir}/applications/
+}
diff --git a/packages/gnuchess/gnuchess_5.021.bb b/packages/gnuchess/gnuchess_5.021.bb
new file mode 100644
index 0000000000..18c94bdab0
--- /dev/null
+++ b/packages/gnuchess/gnuchess_5.021.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Gnuchess is a chess playing engine."
+SECTION = "console"
+PRIORITY = "optional"
+MAINTAINER = "Andreas Holzer <a.holzer@cheese.at>"
+LICENSE = "GPL"
+SRC_URI = "http://members.cheese.at/woody/fltk-chess/gnuchess_5.02.tar.gz"
+S = "${WORKDIR}/chess-5.02/src"
+
+inherit autotools
+
+do_install() {
+ install -D ${S}/gnuchess ${D}${bindir}/gnuchess
+}