summaryrefslogtreecommitdiff
path: root/packages/gnome
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/gnome-menus_2.10.2.bb2
-rw-r--r--packages/gnome/gnome-menus_2.12.0.bb2
-rw-r--r--packages/gnome/gnome-panel_2.10.1.bb2
-rw-r--r--packages/gnome/gnome-vfs-dbus/dbus-api-change.patch78
-rw-r--r--packages/gnome/gnome-vfs-dbus_svn.bb3
5 files changed, 83 insertions, 4 deletions
diff --git a/packages/gnome/gnome-menus_2.10.2.bb b/packages/gnome/gnome-menus_2.10.2.bb
index 9d7bc675f2..53b66a6e9b 100644
--- a/packages/gnome/gnome-menus_2.10.2.bb
+++ b/packages/gnome/gnome-menus_2.10.2.bb
@@ -1,7 +1,7 @@
DEPENDS = "gnome-vfs libxml2 gconf popt gtk+"
LICENSE = "GPL"
-MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+MAINTAINER = "Koen Kooi <koen@linuxtogo.org>"
inherit gnome pkgconfig
diff --git a/packages/gnome/gnome-menus_2.12.0.bb b/packages/gnome/gnome-menus_2.12.0.bb
index 87f5a0d2b9..ff65f1f9ad 100644
--- a/packages/gnome/gnome-menus_2.12.0.bb
+++ b/packages/gnome/gnome-menus_2.12.0.bb
@@ -1,7 +1,7 @@
DEPENDS = "python gnome-vfs libxml2 gconf popt gtk+"
LICENSE = "GPL"
-MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+MAINTAINER = "Koen Kooi <koen@linuxtogo.org>"
inherit gnome pkgconfig
diff --git a/packages/gnome/gnome-panel_2.10.1.bb b/packages/gnome/gnome-panel_2.10.1.bb
index 09e4259fc8..3d7ce2f392 100644
--- a/packages/gnome/gnome-panel_2.10.1.bb
+++ b/packages/gnome/gnome-panel_2.10.1.bb
@@ -1,5 +1,5 @@
LICENSE = "GPL"
-MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+MAINTAINER = "Koen Kooi <koen@linuxtogo.org>"
DEPENDS = "libwnck orbit2 gtk+ libgnome libgnomeui gnome-desktop libglade gnome-menus"
inherit gnome pkgconfig
diff --git a/packages/gnome/gnome-vfs-dbus/dbus-api-change.patch b/packages/gnome/gnome-vfs-dbus/dbus-api-change.patch
new file mode 100644
index 0000000000..38480c21e1
--- /dev/null
+++ b/packages/gnome/gnome-vfs-dbus/dbus-api-change.patch
@@ -0,0 +1,78 @@
+--- trunk/dbus-daemon/vfs-daemon.c.orig 2006-08-09 10:43:26.000000000 +0100
++++ trunk/dbus-daemon/vfs-daemon.c 2006-08-09 10:45:59.000000000 +0100
+@@ -91,7 +91,7 @@
+ g_warning ("Failed to acquire vfs-daemon service: %s", error.message);
+ dbus_error_free (&error);
+
+- dbus_connection_disconnect (conn);
++ dbus_connection_close (conn);
+ dbus_connection_unref (conn);
+ conn = NULL;
+
+@@ -101,7 +101,7 @@
+ if (ret == DBUS_REQUEST_NAME_REPLY_EXISTS) {
+ g_printerr ("VFS daemon already running, exiting.\n");
+
+- dbus_connection_disconnect (conn);
++ dbus_connection_close (conn);
+ dbus_connection_unref (conn);
+ conn = NULL;
+
+@@ -111,7 +111,7 @@
+ if (ret != DBUS_REQUEST_NAME_REPLY_PRIMARY_OWNER) {
+ g_printerr ("Not primary owner of the service, exiting.\n");
+
+- dbus_connection_disconnect (conn);
++ dbus_connection_close (conn);
+ dbus_connection_unref (conn);
+ conn = NULL;
+
+@@ -124,7 +124,7 @@
+ NULL)) {
+ g_printerr ("Failed to register object with D-BUS.\n");
+
+- dbus_connection_disconnect (conn);
++ dbus_connection_close (conn);
+ dbus_connection_unref (conn);
+ conn = NULL;
+
+@@ -152,7 +152,7 @@
+ return;
+ }
+
+- dbus_connection_disconnect (conn);
++ dbus_connection_close (conn);
+ dbus_connection_unref (conn);
+ }
+
+--- trunk/dbus-daemon/daemon-connection.c.orig 2006-08-09 10:43:32.000000000 +0100
++++ trunk/dbus-daemon/daemon-connection.c 2006-08-09 10:46:26.000000000 +0100
+@@ -321,7 +321,7 @@
+ d(g_print ("Last unref\n"));
+
+ if (dbus_connection_get_is_connected (conn->conn)) {
+- dbus_connection_disconnect (conn->conn);
++ dbus_connection_close (conn->conn);
+ }
+ dbus_connection_unref (conn->conn);
+
+--- trunk/dbus-daemon/dbus-method.c.orig 2006-08-09 10:43:38.000000000 +0100
++++ trunk/dbus-daemon/dbus-method.c 2006-08-09 10:46:57.000000000 +0100
+@@ -220,7 +220,7 @@
+ if (!dbus_connection_add_filter (dbus_conn, message_handler,
+ NULL, NULL)) {
+ g_warning ("Failed to add filter to the connection.");
+- dbus_connection_disconnect (dbus_conn);
++ dbus_connection_close (dbus_conn);
+ dbus_connection_unref (dbus_conn);
+
+ dbus_conn = NULL;
+@@ -1666,7 +1666,7 @@
+ vfs_module_shutdown (GnomeVFSMethod* method)
+ {
+ if (dbus_conn) {
+- dbus_connection_disconnect (dbus_conn);
++ dbus_connection_close (dbus_conn);
+ dbus_connection_unref (dbus_conn);
+
+ dbus_conn = NULL;
diff --git a/packages/gnome/gnome-vfs-dbus_svn.bb b/packages/gnome/gnome-vfs-dbus_svn.bb
index 466d52adbe..7a48fb6ca3 100644
--- a/packages/gnome/gnome-vfs-dbus_svn.bb
+++ b/packages/gnome/gnome-vfs-dbus_svn.bb
@@ -18,7 +18,8 @@ SRC_URI = "svn://developer.imendio.com/svn/gnome-vfs-dbus;module=trunk;proto=htt
file://glib-after-nameser.patch;patch=1;pnum=1 \
file://gtk-doc.m4 \
file://gtk-doc.make \
- file://werror_compile.patch;patch=1;pnum=1"
+ file://werror_compile.patch;patch=1;pnum=1 \
+ file://dbus-api-change.patch;patch=1"
EXTRA_OECONF = "--with-ipc=dbus --disable-gtk-doc"
S = "${WORKDIR}/trunk"