summaryrefslogtreecommitdiff
path: root/packages/gnome/gnome-vfs-dbus
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gnome/gnome-vfs-dbus')
-rw-r--r--packages/gnome/gnome-vfs-dbus/.mtn2git_empty0
-rw-r--r--packages/gnome/gnome-vfs-dbus/dbus-api-change.patch78
-rw-r--r--packages/gnome/gnome-vfs-dbus/gconftool-lossage.patch11
-rw-r--r--packages/gnome/gnome-vfs-dbus/glib-after-nameser.patch18
-rw-r--r--packages/gnome/gnome-vfs-dbus/gssapi.patch18
-rw-r--r--packages/gnome/gnome-vfs-dbus/werror_compile.patch11
6 files changed, 0 insertions, 136 deletions
diff --git a/packages/gnome/gnome-vfs-dbus/.mtn2git_empty b/packages/gnome/gnome-vfs-dbus/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/gnome/gnome-vfs-dbus/.mtn2git_empty
+++ /dev/null
diff --git a/packages/gnome/gnome-vfs-dbus/dbus-api-change.patch b/packages/gnome/gnome-vfs-dbus/dbus-api-change.patch
deleted file mode 100644
index 38480c21e1..0000000000
--- a/packages/gnome/gnome-vfs-dbus/dbus-api-change.patch
+++ /dev/null
@@ -1,78 +0,0 @@
---- trunk/dbus-daemon/vfs-daemon.c.orig 2006-08-09 10:43:26.000000000 +0100
-+++ trunk/dbus-daemon/vfs-daemon.c 2006-08-09 10:45:59.000000000 +0100
-@@ -91,7 +91,7 @@
- g_warning ("Failed to acquire vfs-daemon service: %s", error.message);
- dbus_error_free (&error);
-
-- dbus_connection_disconnect (conn);
-+ dbus_connection_close (conn);
- dbus_connection_unref (conn);
- conn = NULL;
-
-@@ -101,7 +101,7 @@
- if (ret == DBUS_REQUEST_NAME_REPLY_EXISTS) {
- g_printerr ("VFS daemon already running, exiting.\n");
-
-- dbus_connection_disconnect (conn);
-+ dbus_connection_close (conn);
- dbus_connection_unref (conn);
- conn = NULL;
-
-@@ -111,7 +111,7 @@
- if (ret != DBUS_REQUEST_NAME_REPLY_PRIMARY_OWNER) {
- g_printerr ("Not primary owner of the service, exiting.\n");
-
-- dbus_connection_disconnect (conn);
-+ dbus_connection_close (conn);
- dbus_connection_unref (conn);
- conn = NULL;
-
-@@ -124,7 +124,7 @@
- NULL)) {
- g_printerr ("Failed to register object with D-BUS.\n");
-
-- dbus_connection_disconnect (conn);
-+ dbus_connection_close (conn);
- dbus_connection_unref (conn);
- conn = NULL;
-
-@@ -152,7 +152,7 @@
- return;
- }
-
-- dbus_connection_disconnect (conn);
-+ dbus_connection_close (conn);
- dbus_connection_unref (conn);
- }
-
---- trunk/dbus-daemon/daemon-connection.c.orig 2006-08-09 10:43:32.000000000 +0100
-+++ trunk/dbus-daemon/daemon-connection.c 2006-08-09 10:46:26.000000000 +0100
-@@ -321,7 +321,7 @@
- d(g_print ("Last unref\n"));
-
- if (dbus_connection_get_is_connected (conn->conn)) {
-- dbus_connection_disconnect (conn->conn);
-+ dbus_connection_close (conn->conn);
- }
- dbus_connection_unref (conn->conn);
-
---- trunk/dbus-daemon/dbus-method.c.orig 2006-08-09 10:43:38.000000000 +0100
-+++ trunk/dbus-daemon/dbus-method.c 2006-08-09 10:46:57.000000000 +0100
-@@ -220,7 +220,7 @@
- if (!dbus_connection_add_filter (dbus_conn, message_handler,
- NULL, NULL)) {
- g_warning ("Failed to add filter to the connection.");
-- dbus_connection_disconnect (dbus_conn);
-+ dbus_connection_close (dbus_conn);
- dbus_connection_unref (dbus_conn);
-
- dbus_conn = NULL;
-@@ -1666,7 +1666,7 @@
- vfs_module_shutdown (GnomeVFSMethod* method)
- {
- if (dbus_conn) {
-- dbus_connection_disconnect (dbus_conn);
-+ dbus_connection_close (dbus_conn);
- dbus_connection_unref (dbus_conn);
-
- dbus_conn = NULL;
diff --git a/packages/gnome/gnome-vfs-dbus/gconftool-lossage.patch b/packages/gnome/gnome-vfs-dbus/gconftool-lossage.patch
deleted file mode 100644
index 3dbc130ddc..0000000000
--- a/packages/gnome/gnome-vfs-dbus/gconftool-lossage.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gnome-vfs-2.6.0/configure.in~ 2004-03-22 12:36:23.000000000 +0000
-+++ gnome-vfs-2.6.0/configure.in 2004-06-07 16:04:34.000000000 +0100
-@@ -154,7 +154,7 @@
- AC_PATH_PROG(GCONFTOOL, gconftool-2, no)
-
- if test x"$GCONFTOOL" = xno; then
-- AC_MSG_ERROR([gconftool-2 executable not found in your path - should be installed with GConf])
-+ AC_MSG_WARN([gconftool-2 executable not found in your path - should be installed with GConf])
- fi
-
- AM_GCONF_SOURCE_2
diff --git a/packages/gnome/gnome-vfs-dbus/glib-after-nameser.patch b/packages/gnome/gnome-vfs-dbus/glib-after-nameser.patch
deleted file mode 100644
index 87bf7c3939..0000000000
--- a/packages/gnome/gnome-vfs-dbus/glib-after-nameser.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- trunk/libgnomevfs/gnome-vfs-resolve.c.orig 2006-02-08 19:18:43.000000000 +0100
-+++ trunk/libgnomevfs/gnome-vfs-resolve.c 2006-02-08 19:21:42.000000000 +0100
-@@ -23,7 +23,6 @@
-
- #include <errno.h>
- #include <string.h>
--#include <glib.h>
- #ifndef G_OS_WIN32
- /* Keep <sys/types.h> above the network includes for FreeBSD. */
- #include <sys/types.h>
-@@ -48,6 +47,7 @@
- #define RELOAD_TIMEVAL 2
- #endif
-
-+#include <glib.h>
- #include <glib-object.h>
-
- #include <libgnomevfs/gnome-vfs-resolve.h>
diff --git a/packages/gnome/gnome-vfs-dbus/gssapi.patch b/packages/gnome/gnome-vfs-dbus/gssapi.patch
deleted file mode 100644
index a4fcd605f2..0000000000
--- a/packages/gnome/gnome-vfs-dbus/gssapi.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- gnome-vfs-dbus-2.8.4.4/configure.in~gssapi
-+++ gnome-vfs-dbus-2.8.4.4/configure.in
-@@ -456,6 +456,10 @@
- ])
- LIBS="$saved_LIBS"
- CPPFLAGS="$saved_CPPFLAGS"
-+ if test "x$have_gssapi" != "xyes"; then
-+ GSSAPI_LIBS=
-+ GSSAPI_CFLAGS=
-+ fi
- fi
- AC_SUBST(GSSAPI_LIBS)
- AC_SUBST(GSSAPI_CFLAGS)
diff --git a/packages/gnome/gnome-vfs-dbus/werror_compile.patch b/packages/gnome/gnome-vfs-dbus/werror_compile.patch
deleted file mode 100644
index f2eba7d712..0000000000
--- a/packages/gnome/gnome-vfs-dbus/werror_compile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gnome-vfs-dbus-2.8.4.4/configure.in.old 2006-01-26 11:56:09.000000000 +0100
-+++ gnome-vfs-dbus-2.8.4.4/configure.in 2006-01-26 11:45:02.000000000 +0100
-@@ -279,7 +279,7 @@
-
- if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
- echo "enable compile warnings = $set_more_warnings"
-- VFS_CFLAGS="-Wall -Werror \
-+ VFS_CFLAGS="-Wall \
- -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes \
- -Wnested-externs -Wpointer-arith"
-