summaryrefslogtreecommitdiff
path: root/packages/gnome/gconf-dbus_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gnome/gconf-dbus_svn.bb')
-rw-r--r--packages/gnome/gconf-dbus_svn.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/packages/gnome/gconf-dbus_svn.bb b/packages/gnome/gconf-dbus_svn.bb
index dcd5209989..d6b79494be 100644
--- a/packages/gnome/gconf-dbus_svn.bb
+++ b/packages/gnome/gconf-dbus_svn.bb
@@ -12,6 +12,8 @@ PR = "r0"
SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http \
file://gconf-dbus-update.patch;patch=1;pnum=0 \
+ file://xml-backend-locks-compile-fix.patch;patch=1 \
+ file://xml-backend-oldxml-Makefile.patch \
file://69gconfd-dbus"
inherit pkgconfig autotools
@@ -25,6 +27,11 @@ EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SY
HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
+do_compile_prepend() {
+ cd ${S}
+ patch -p1 < ../xml-backend-oldxml-Makefile.patch
+}
+
do_stage() {
oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
install -d ${STAGING_INCDIR}/gconf/2/gconf/