summaryrefslogtreecommitdiff
path: root/packages/git
diff options
context:
space:
mode:
Diffstat (limited to 'packages/git')
-rw-r--r--packages/git/files/autotools.patch26
-rw-r--r--packages/git/git-native_1.4.4.2.bb3
-rw-r--r--packages/git/git-native_1.5.2.3.bb6
-rw-r--r--packages/git/git.inc15
-rw-r--r--packages/git/git_1.4.4.2.bb3
-rw-r--r--packages/git/git_1.5.2.3.bb26
6 files changed, 58 insertions, 21 deletions
diff --git a/packages/git/files/autotools.patch b/packages/git/files/autotools.patch
new file mode 100644
index 0000000000..0666118cde
--- /dev/null
+++ b/packages/git/files/autotools.patch
@@ -0,0 +1,26 @@
+Index: git-1.5.2.3/configure.ac
+===================================================================
+--- git-1.5.2.3.orig/configure.ac 2007-07-02 10:11:39.000000000 +0200
++++ git-1.5.2.3/configure.ac 2007-08-04 00:02:13.000000000 +0200
+@@ -235,7 +235,8 @@
+ else if (strcmp(buf, "12345"))
+ exit(2);]])],
+ [ac_cv_c_c99_format=yes],
+- [ac_cv_c_c99_format=no])
++ [ac_cv_c_c99_format=no],
++ [ac_cv_c_c99_format=yes])
+ ])
+ if test $ac_cv_c_c99_format = no; then
+ NO_C99_FORMAT=YesPlease
+Index: git-1.5.2.3/config.mak.in
+===================================================================
+--- git-1.5.2.3.orig/config.mak.in 2007-07-02 10:11:39.000000000 +0200
++++ git-1.5.2.3/config.mak.in 2007-08-04 00:07:04.000000000 +0200
+@@ -3,6 +3,7 @@
+
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ AR = @AR@
+ TAR = @TAR@
+ #INSTALL = @INSTALL@ # needs install-sh or install.sh in sources
diff --git a/packages/git/git-native_1.4.4.2.bb b/packages/git/git-native_1.4.4.2.bb
deleted file mode 100644
index f91fd03ab1..0000000000
--- a/packages/git/git-native_1.4.4.2.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require git.inc
-inherit native
-DEPENDS = "openssl-native curl-native"
diff --git a/packages/git/git-native_1.5.2.3.bb b/packages/git/git-native_1.5.2.3.bb
new file mode 100644
index 0000000000..7ddfee0d08
--- /dev/null
+++ b/packages/git/git-native_1.5.2.3.bb
@@ -0,0 +1,6 @@
+
+inherit native
+require git_${PV}.bb
+
+DEPENDS = "openssl-native curl-native zlib-native expat-native"
+RDEPENDS = ""
diff --git a/packages/git/git.inc b/packages/git/git.inc
deleted file mode 100644
index 384dfaaeec..0000000000
--- a/packages/git/git.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "The git revision control system used by the Linux kernel developers"
-SECTION = "console/utils"
-LICENSE = "GPL"
-
-SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2"
-S = "${WORKDIR}/git-${PV}"
-
-do_install () {
- oe_runmake install prefix=${D} bindir=${D}${bindir} \
- template_dir=${D}${datadir}/git-core/templates \
- GIT_PYTHON_DIR=${D}${datadir}/git-core/python
-}
-
-FILES_${PN} += "${datadir}/git-core"
-
diff --git a/packages/git/git_1.4.4.2.bb b/packages/git/git_1.4.4.2.bb
deleted file mode 100644
index 37f71cfb04..0000000000
--- a/packages/git/git_1.4.4.2.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require git.inc
-DEPENDS = "openssl curl"
-RDEPENDS = "perl perl-module-file-path"
diff --git a/packages/git/git_1.5.2.3.bb b/packages/git/git_1.5.2.3.bb
new file mode 100644
index 0000000000..db43aa71fd
--- /dev/null
+++ b/packages/git/git_1.5.2.3.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+SECTION = "console/utils"
+LICENSE = "GPL"
+PR="r4"
+
+inherit autotools
+
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2 \
+ file://autotools.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/git-${PV}"
+
+DEPENDS = "openssl curl zlib expat"
+RDEPENDS = "perl perl-module-file-path cpio findutils sed"
+
+EXTRA_OEMAKE = "NO_TCLTK=1"
+
+do_install() {
+ oe_runmake install DESTDIR="${D}" bindir="${bindir}" \
+ template_dir="${datadir}/git-core/templates" \
+ GIT_PYTHON_DIR="${datadir}/git-core/python"
+}
+
+FILES_${PN} += "${datadir}/git-core"
+