summaryrefslogtreecommitdiff
path: root/packages/geoclue/geoclue_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/geoclue/geoclue_git.bb')
-rw-r--r--packages/geoclue/geoclue_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/geoclue/geoclue_git.bb b/packages/geoclue/geoclue_git.bb
new file mode 100644
index 0000000000..6ae717e4b6
--- /dev/null
+++ b/packages/geoclue/geoclue_git.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "GeoClue is a project that provide all kinds of geography information to an application"
+HOMEPAGE = "http://live.gnome.org/GeoClue"
+
+DEPENDS = "gpsd ilibxml2 libsoup dbus-glib"
+
+PV = "0.0+git${SRCDATE}"
+PR = "r0"
+PE = "1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "git://anongit.freedesktop.org/git/geoclue;protocol=git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = "--enable-panel-applet=no"
+
+do_install_append() {
+ mkdir -p ${D}/usr/share/
+ cp -pPr ${D}${STAGING_DATADIR}/* ${D}/usr/share
+ rm -rf ${D}${STAGING_DATADIR}/
+}
+
+PACKAGES =+ "geoclue-applet"
+
+FILES_geoclue-applet += " \
+ ${libdir}/bonobo/servers/* \
+ ${libdir}/gnome-panel/*"
+
+
+FILES_${PN} += " \
+ ${libdir}/gnome-panel/* \
+ ${datadir}/dbus-1"