summaryrefslogtreecommitdiff
path: root/packages/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.2.4.inc5
-rw-r--r--packages/gcc/gcc-4.2.4/cppdefault_cross.patch12
-rw-r--r--packages/gcc/gcc-4.2.4/sh_unwind.patch18
-rw-r--r--packages/gcc/gcc-4.3.2.inc3
-rw-r--r--packages/gcc/gcc-4.3.2/gcc-4.2.3-linux-multilib-fix.patch23
-rw-r--r--packages/gcc/gcc-4.3.2/sh_unwind.patch18
-rw-r--r--packages/gcc/gcc-configure-cross.inc1
-rw-r--r--packages/gcc/gcc-cross4.inc2
-rw-r--r--packages/gcc/gcc-cross_4.3.2.bb2
9 files changed, 83 insertions, 1 deletions
diff --git a/packages/gcc/gcc-4.2.4.inc b/packages/gcc/gcc-4.2.4.inc
index ccca7705c1..b21569b270 100644
--- a/packages/gcc/gcc-4.2.4.inc
+++ b/packages/gcc/gcc-4.2.4.inc
@@ -63,6 +63,11 @@ PACKAGE_ARCH_ep93xx = "${MACHINE_ARCH}"
SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
+SRC_URI_append_sh4 = " file://sh_unwind.patch;patch=1 \
+ file://cppdefault_cross.patch;patch=1 \
+ "
+
+
# Language Overrides
FORTRAN = ""
FORTRAN_linux-gnueabi = ",fortran"
diff --git a/packages/gcc/gcc-4.2.4/cppdefault_cross.patch b/packages/gcc/gcc-4.2.4/cppdefault_cross.patch
new file mode 100644
index 0000000000..dfdbeb32cf
--- /dev/null
+++ b/packages/gcc/gcc-4.2.4/cppdefault_cross.patch
@@ -0,0 +1,12 @@
+Index: gcc-4.2.4/gcc/cppdefault.c
+===================================================================
+--- gcc-4.2.4.orig/gcc/cppdefault.c 2008-10-04 00:07:13.161548578 +0200
++++ gcc-4.2.4/gcc/cppdefault.c 2008-10-04 00:07:32.548205652 +0200
+@@ -39,6 +39,7 @@
+ # undef STANDARD_INCLUDE_DIR
+ #else
+ # undef CROSS_INCLUDE_DIR
++# undef STANDARD_INCLUDE_DIR
+ #endif
+
+ const struct default_include cpp_include_defaults[]
diff --git a/packages/gcc/gcc-4.2.4/sh_unwind.patch b/packages/gcc/gcc-4.2.4/sh_unwind.patch
new file mode 100644
index 0000000000..94921636bc
--- /dev/null
+++ b/packages/gcc/gcc-4.2.4/sh_unwind.patch
@@ -0,0 +1,18 @@
+Index: gcc-4.2.4/gcc/config/sh/linux-unwind.h
+===================================================================
+--- gcc-4.2.4.orig/gcc/config/sh/linux-unwind.h 2008-10-04 00:05:29.434889757 +0200
++++ gcc-4.2.4/gcc/config/sh/linux-unwind.h 2008-10-04 00:06:02.594883544 +0200
+@@ -26,6 +26,7 @@
+ the Free Software Foundation, 51 Franklin Street, Fifth Floor,
+ Boston, MA 02110-1301, USA. */
+
++#ifndef inhibit_libc
+ /* Do code reading to identify a signal frame, and set the frame
+ state data appropriately. See unwind-dw2.c for the structs. */
+
+@@ -251,3 +252,5 @@
+ return _URC_NO_REASON;
+ }
+ #endif /* defined (__SH5__) */
++
++#endif /* defined inhibit_libc */
diff --git a/packages/gcc/gcc-4.3.2.inc b/packages/gcc/gcc-4.3.2.inc
index 49b2a63b70..74ed254694 100644
--- a/packages/gcc/gcc-4.3.2.inc
+++ b/packages/gcc/gcc-4.3.2.inc
@@ -59,6 +59,9 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
+SRC_URI_append_sh4 = " file://sh_unwind.patch;patch=1 \
+ file://gcc-4.2.3-linux-multilib-fix.patch;patch=1 \
+ "
# Language Overrides
FORTRAN = ""
JAVA = ""
diff --git a/packages/gcc/gcc-4.3.2/gcc-4.2.3-linux-multilib-fix.patch b/packages/gcc/gcc-4.3.2/gcc-4.2.3-linux-multilib-fix.patch
new file mode 100644
index 0000000000..81522a8f57
--- /dev/null
+++ b/packages/gcc/gcc-4.3.2/gcc-4.2.3-linux-multilib-fix.patch
@@ -0,0 +1,23 @@
+Change gcc build : Enable m4 and m4-nofpu (needed for kernel) for sh4-gnu-linux
+
+Signed-off-by: Carl Shaw <carl.shaw@st.com>
+
+Index: gcc/gcc/config.gcc
+===================================================================
+--- gcc.orig/gcc/config.gcc 2008-07-18 10:37:54.000000000 +0100
++++ gcc/gcc/config.gcc 2008-07-18 11:00:42.000000000 +0100
+@@ -2097,11 +2097,12 @@
+ if test x${sh_multilibs} = x ; then
+ case ${target} in
+ sh64-superh-linux* | \
+- sh[1234]*) sh_multilibs=${sh_cpu_target} ;;
+ sh64* | sh5*) sh_multilibs=m5-32media,m5-32media-nofpu,m5-compact,m5-compact-nofpu,m5-64media,m5-64media-nofpu ;;
+- sh-superh-*) sh_multilibs=m4,m4-single,m4-single-only,m4-nofpu ;;
++ sh-superh-* | \
++ sh4-*-linux*) sh_multilibs=m4,m4-nofpu ;;
+ sh*-*-linux*) sh_multilibs=m1,m3e,m4 ;;
+ sh*-*-netbsd*) sh_multilibs=m3,m3e,m4 ;;
++ sh[1234]*) sh_multilibs=${sh_cpu_target} ;;
+ *) sh_multilibs=m1,m2,m2e,m4,m4-single,m4-single-only,m2a,m2a-single ;;
+ esac
+ if test x$with_fp = xno; then
diff --git a/packages/gcc/gcc-4.3.2/sh_unwind.patch b/packages/gcc/gcc-4.3.2/sh_unwind.patch
new file mode 100644
index 0000000000..94921636bc
--- /dev/null
+++ b/packages/gcc/gcc-4.3.2/sh_unwind.patch
@@ -0,0 +1,18 @@
+Index: gcc-4.2.4/gcc/config/sh/linux-unwind.h
+===================================================================
+--- gcc-4.2.4.orig/gcc/config/sh/linux-unwind.h 2008-10-04 00:05:29.434889757 +0200
++++ gcc-4.2.4/gcc/config/sh/linux-unwind.h 2008-10-04 00:06:02.594883544 +0200
+@@ -26,6 +26,7 @@
+ the Free Software Foundation, 51 Franklin Street, Fifth Floor,
+ Boston, MA 02110-1301, USA. */
+
++#ifndef inhibit_libc
+ /* Do code reading to identify a signal frame, and set the frame
+ state data appropriately. See unwind-dw2.c for the structs. */
+
+@@ -251,3 +252,5 @@
+ return _URC_NO_REASON;
+ }
+ #endif /* defined (__SH5__) */
++
++#endif /* defined inhibit_libc */
diff --git a/packages/gcc/gcc-configure-cross.inc b/packages/gcc/gcc-configure-cross.inc
index d5800c78ff..aa4174edc4 100644
--- a/packages/gcc/gcc-configure-cross.inc
+++ b/packages/gcc/gcc-configure-cross.inc
@@ -27,6 +27,7 @@ do_stage_append () {
# Fix a few include links so cross builds are happier
if [ ! -e ${STAGING_INCDIR}/c++ ]; then
mkdir -p ${STAGING_INCDIR}
+ mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include/c++
ln -sf ${CROSS_DIR}/${TARGET_SYS}/include/c++ \
${STAGING_INCDIR}/
fi
diff --git a/packages/gcc/gcc-cross4.inc b/packages/gcc/gcc-cross4.inc
index 3d3403737a..77a55968fa 100644
--- a/packages/gcc/gcc-cross4.inc
+++ b/packages/gcc/gcc-cross4.inc
@@ -1,3 +1,5 @@
require gcc-cross.inc
DEPENDS += "gmp-native mpfr-native"
+
+EXTRA_OECONF_append_sh4 = " --with-multilib-list=m4,m4-nofpu "
diff --git a/packages/gcc/gcc-cross_4.3.2.bb b/packages/gcc/gcc-cross_4.3.2.bb
index 526ec1508b..18d5abd32e 100644
--- a/packages/gcc/gcc-cross_4.3.2.bb
+++ b/packages/gcc/gcc-cross_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
require gcc-${PV}.inc
require gcc-cross4.inc
require gcc-configure-cross.inc