summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross_4.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gcc/gcc-cross_4.3.2.bb')
-rw-r--r--packages/gcc/gcc-cross_4.3.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_4.3.2.bb b/packages/gcc/gcc-cross_4.3.2.bb
new file mode 100644
index 0000000000..f9ae312513
--- /dev/null
+++ b/packages/gcc/gcc-cross_4.3.2.bb
@@ -0,0 +1,16 @@
+require gcc-${PV}.inc
+require gcc-cross4.inc
+require gcc-configure-cross.inc
+require gcc-package-cross.inc
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
+
+EXTRA_OECONF += " --enable-cheaders=c_std --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+
+# Hack till we fix *libc properly
+do_stage_append() {
+ ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
+}
+
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"