summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross_4.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gcc/gcc-cross_4.3.0.bb')
-rw-r--r--packages/gcc/gcc-cross_4.3.0.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/packages/gcc/gcc-cross_4.3.0.bb b/packages/gcc/gcc-cross_4.3.0.bb
index 72f72835c3..382a234816 100644
--- a/packages/gcc/gcc-cross_4.3.0.bb
+++ b/packages/gcc/gcc-cross_4.3.0.bb
@@ -7,6 +7,12 @@ require gcc-package-cross.inc
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+EXTRA_OECONF += " --enable-cheaders=c_std --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+
+# Hack till we fix *libc properly
+do_stage_append() {
+ ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
+}
+
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"