summaryrefslogtreecommitdiff
path: root/packages/freesmartphone
diff options
context:
space:
mode:
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/frameworkd/frameworkd.conf19
-rw-r--r--packages/freesmartphone/frameworkd_git.bb10
-rw-r--r--packages/freesmartphone/mickeydbus_git.bb18
-rw-r--r--packages/freesmartphone/python-odeviced/.mtn2git_empty0
-rw-r--r--packages/freesmartphone/python-odeviced/odeviced40
-rw-r--r--packages/freesmartphone/python-odeviced/odeviced.conf0
-rw-r--r--packages/freesmartphone/python-odeviced/om-gta02/.mtn2git_empty0
-rw-r--r--packages/freesmartphone/python-odeviced/om-gta02/odeviced.conf8
-rw-r--r--packages/freesmartphone/python-odeviced_git.bb35
-rw-r--r--packages/freesmartphone/python-oeventd/.mtn2git_empty0
-rw-r--r--packages/freesmartphone/python-oeventd/oeventd40
-rw-r--r--packages/freesmartphone/python-oeventd_git.bb34
-rw-r--r--packages/freesmartphone/python-ophoned/.mtn2git_empty0
-rw-r--r--packages/freesmartphone/python-ophoned/ophoned40
-rw-r--r--packages/freesmartphone/python-ophoned_git.bb35
-rw-r--r--packages/freesmartphone/python-ousaged/.mtn2git_empty0
-rw-r--r--packages/freesmartphone/python-ousaged/ousaged40
-rw-r--r--packages/freesmartphone/python-ousaged_git.bb36
-rw-r--r--packages/freesmartphone/zhone/80zhone2
-rw-r--r--packages/freesmartphone/zhone_git.bb9
20 files changed, 47 insertions, 319 deletions
diff --git a/packages/freesmartphone/frameworkd/frameworkd.conf b/packages/freesmartphone/frameworkd/frameworkd.conf
index 8b13789179..36b4f5fc8e 100644
--- a/packages/freesmartphone/frameworkd/frameworkd.conf
+++ b/packages/freesmartphone/frameworkd/frameworkd.conf
@@ -1 +1,20 @@
+[odeviced]
+[kernel26]
+# set 1 to disable the module
+disable = 0
+
+[idlenotifier]
+# set 1 to disable the module
+disable = 0
+# add inut nodes to ignore for idle activity
+ignoreinput = 2,3,4
+
+[powercontrol-neo]
+disable = 0
+
+[ogsmd]
+modemtype = ti_calypso
+
+[opreferencesd]
+rootdir = ../etc/freesmartphone/opreferences:/etc/freesmartphone/opreferences:/usr/etc/freesmartphone/opreferences
diff --git a/packages/freesmartphone/frameworkd_git.bb b/packages/freesmartphone/frameworkd_git.bb
index ea3a4cb652..a6d25f79ec 100644
--- a/packages/freesmartphone/frameworkd_git.bb
+++ b/packages/freesmartphone/frameworkd_git.bb
@@ -1,11 +1,11 @@
-DESCRIPTION = "The freesmartphon.org Framework Daemon"
+DESCRIPTION = "The freesmartphone.org Framework Daemon"
HOMEPAGE = "http://www.freesmartphone.org"
-AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de> et. al."
SECTION = "console/network"
DEPENDS = "python-cython-native python-pyrex-native"
LICENSE = "GPL"
PV = "0.8.0+gitr${SRCREV}"
-PR = "r2"
+PR = "r6"
inherit distutils update-rc.d
@@ -27,12 +27,14 @@ do_install_append() {
RDEPENDS_${PN} += "\
python-dbus \
+ python-datetime \
python-pygobject \
python-pyrtc \
python-pyserial \
+ python-pyyaml \
python-shell \
python-syslog \
"
-FILES_${PN} += "${sysconfdir}"
+FILES_${PN} += "${sysconfdir} ${datadir}"
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/framework/subsystems/*/.debug"
diff --git a/packages/freesmartphone/mickeydbus_git.bb b/packages/freesmartphone/mickeydbus_git.bb
new file mode 100644
index 0000000000..cbd90e5030
--- /dev/null
+++ b/packages/freesmartphone/mickeydbus_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Mickey's DBus introspection and calling Program"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PV = "0.9.0+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 mickeydbus/mdbus ${D}${bindir}
+}
+
+RDEPENDS_${PN} = "\
+ python-dbus \
+"
diff --git a/packages/freesmartphone/python-odeviced/.mtn2git_empty b/packages/freesmartphone/python-odeviced/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/freesmartphone/python-odeviced/.mtn2git_empty
+++ /dev/null
diff --git a/packages/freesmartphone/python-odeviced/odeviced b/packages/freesmartphone/python-odeviced/odeviced
deleted file mode 100644
index 52d3a1d196..0000000000
--- a/packages/freesmartphone/python-odeviced/odeviced
+++ /dev/null
@@ -1,40 +0,0 @@
-#! /bin/sh
-#
-# odeviced This shell script starts and stops the open device daemon.
-#
-# chkconfig: 345 90 20
-# description: py-odeviced is the open device daemon
-# processname: python
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-NAME=odeviced
-
-[ -f /etc/default/rcS ] && . /etc/default/rcS
-
-case "$1" in
- start)
- echo -n "Starting open device daemon: "
- start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/odeviced
- if [ $? = 0 ]; then
- echo "(ok)"
- else
- echo "(failed)"
- fi
- ;;
- stop)
- echo -n "Stopping open device daemon: "
- start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
- rm -f /var/run/${NAME}.pid
- echo "(done)"
- ;;
- restart|force-reload)
- $0 stop
- $0 start
- ;;
- *)
- echo "Usage: /etc/init.d/odeviced {start|stop|restart|force-reload}"
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/freesmartphone/python-odeviced/odeviced.conf b/packages/freesmartphone/python-odeviced/odeviced.conf
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/freesmartphone/python-odeviced/odeviced.conf
+++ /dev/null
diff --git a/packages/freesmartphone/python-odeviced/om-gta02/.mtn2git_empty b/packages/freesmartphone/python-odeviced/om-gta02/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/freesmartphone/python-odeviced/om-gta02/.mtn2git_empty
+++ /dev/null
diff --git a/packages/freesmartphone/python-odeviced/om-gta02/odeviced.conf b/packages/freesmartphone/python-odeviced/om-gta02/odeviced.conf
deleted file mode 100644
index 0076639f98..0000000000
--- a/packages/freesmartphone/python-odeviced/om-gta02/odeviced.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-[idlenotifier]
-# don't read from accellerometers for now
-ignoreinput=2,3
-
-[input]
-# don't read from accellerometers for now
-ignoreinput=2,3
-
diff --git a/packages/freesmartphone/python-odeviced_git.bb b/packages/freesmartphone/python-odeviced_git.bb
deleted file mode 100644
index 121a434585..0000000000
--- a/packages/freesmartphone/python-odeviced_git.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-DESCRIPTION = "The Open Device Daemon Prototype in Python"
-HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenDeviceDaemon"
-AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-SECTION = "console/network"
-DEPENDS = "python-cython-native python-pyrex-native"
-LICENSE = "GPLv2"
-PV = "0.7.9+gitr${SRCREV}"
-PR = "r2"
-
-inherit distutils update-rc.d
-
-INITSCRIPT_NAME = "odeviced"
-INITSCRIPT_PARAMS = "defaults 21"
-
-SRC_URI = "${FREESMARTPHONE_GIT}/python-odeviced.git;protocol=git;branch=master \
- file://odeviced \
- file://odeviced.conf"
-S = "${WORKDIR}/git"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/odeviced ${D}${sysconfdir}/init.d/
- install -m 0644 ${WORKDIR}/odeviced.conf ${D}${sysconfdir}
- install -d ${D}${sysconfdir}/dbus-1/system.d/
- mv -f ${D}${datadir}/etc/dbus-1/system.d/odeviced.conf ${D}${sysconfdir}/dbus-1/system.d/
-}
-
-RDEPENDS_${PN} += "\
- python-dbus \
- python-pygobject \
- python-pyrtc \
- python-syslog \
-"
-
-FILES_${PN} += "${sysconfdir}"
diff --git a/packages/freesmartphone/python-oeventd/.mtn2git_empty b/packages/freesmartphone/python-oeventd/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/freesmartphone/python-oeventd/.mtn2git_empty
+++ /dev/null
diff --git a/packages/freesmartphone/python-oeventd/oeventd b/packages/freesmartphone/python-oeventd/oeventd
deleted file mode 100644
index 8ed467b079..0000000000
--- a/packages/freesmartphone/python-oeventd/oeventd
+++ /dev/null
@@ -1,40 +0,0 @@
-#! /bin/sh
-#
-# odeviced This shell script starts and stops the open event daemon.
-#
-# chkconfig: 345 90 20
-# description: py-oeventd is the open evend daemon
-# processname: python
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-NAME=oeventd
-
-[ -f /etc/default/rcS ] && . /etc/default/rcS
-
-case "$1" in
- start)
- echo -n "Starting open event daemon: "
- start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/oeventd
- if [ $? = 0 ]; then
- echo "(ok)"
- else
- echo "(failed)"
- fi
- ;;
- stop)
- echo -n "Stopping open event daemon: "
- start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
- rm -f /var/run/${NAME}.pid
- echo "(done)"
- ;;
- restart|force-reload)
- $0 stop
- $0 start
- ;;
- *)
- echo "Usage: /etc/init.d/oeventd {start|stop|restart|force-reload}"
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/freesmartphone/python-oeventd_git.bb b/packages/freesmartphone/python-oeventd_git.bb
deleted file mode 100644
index c08e1af3b7..0000000000
--- a/packages/freesmartphone/python-oeventd_git.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-DESCRIPTION = "The Open Event Daemon Prototype in Python"
-HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenEventDaemon"
-AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-SECTION = "console/network"
-DEPENDS = "python-cython-native python-pyrex-native"
-LICENSE = "GPLv2"
-PV = "0.0.0+gitr${SRCREV}"
-PR = "r1"
-
-inherit distutils update-rc.d
-
-INITSCRIPT_NAME = "oeventd"
-INITSCRIPT_PARAMS = "defaults 21"
-
-SRC_URI = "\
- ${FREESMARTPHONE_GIT}/eventd.git;protocol=git;branch=master \
- file://oeventd \
-"
-S = "${WORKDIR}/git"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/oeventd ${D}${sysconfdir}/init.d/
- install -d ${D}${sysconfdir}/dbus-1/system.d/
- mv -f ${D}${datadir}/etc/dbus-1/system.d/oeventd.conf ${D}${sysconfdir}/dbus-1/system.d/
-}
-
-RDEPENDS_${PN} += "\
- python-dbus \
- python-pygobject \
- python-syslog \
-"
-
-FILES_${PN} += "${sysconfdir}"
diff --git a/packages/freesmartphone/python-ophoned/.mtn2git_empty b/packages/freesmartphone/python-ophoned/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/freesmartphone/python-ophoned/.mtn2git_empty
+++ /dev/null
diff --git a/packages/freesmartphone/python-ophoned/ophoned b/packages/freesmartphone/python-ophoned/ophoned
deleted file mode 100644
index edc800711a..0000000000
--- a/packages/freesmartphone/python-ophoned/ophoned
+++ /dev/null
@@ -1,40 +0,0 @@
-#! /bin/sh
-#
-# ophoned This shell script starts and stops the open phone daemon.
-#
-# chkconfig: 345 90 20
-# description: py-ophoned is the open phone daemon
-# processname: python
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-NAME=ophoned
-
-[ -f /etc/default/rcS ] && . /etc/default/rcS
-
-case "$1" in
- start)
- echo -n "Starting open phone daemon: "
- start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/ophoned
- if [ $? = 0 ]; then
- echo "(ok)"
- else
- echo "(failed)"
- fi
- ;;
- stop)
- echo -n "Stopping open phone daemon: "
- start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
- rm -f /var/run/${NAME}.pid
- echo "(done)"
- ;;
- restart|force-reload)
- $0 stop
- $0 start
- ;;
- *)
- echo "Usage: /etc/init.d/ophoned {start|stop|restart|force-reload}"
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/freesmartphone/python-ophoned_git.bb b/packages/freesmartphone/python-ophoned_git.bb
deleted file mode 100644
index 7f30f4c24a..0000000000
--- a/packages/freesmartphone/python-ophoned_git.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-DESCRIPTION = "The Open Phone Daemon (Python Implementation)"
-HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenPhoneServer"
-AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-SECTION = "console/network"
-DEPENDS = "python-cython-native python-pyrex-native"
-LICENSE = "GPLv2"
-PV = "0.0.0+gitr${SRCREV}"
-PR = "r1"
-
-inherit distutils update-rc.d
-
-INITSCRIPT_NAME = "ophoned"
-INITSCRIPT_PARAMS = "defaults 21"
-
-SRC_URI = "${FREESMARTPHONE_GIT}/python-ophoned.git;protocol=git;branch=master \
- file://ophoned"
-S = "${WORKDIR}/git"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/ophoned ${D}${sysconfdir}/init.d/
-# install -m 0644 ${WORKDIR}/ophoned.conf ${D}${sysconfdir}
- install -d ${D}${sysconfdir}/dbus-1/system.d/
- mv -f ${D}${datadir}/etc/dbus-1/system.d/ophoned.conf ${D}${sysconfdir}/dbus-1/system.d/
-}
-
-RDEPENDS_${PN} += "\
- python-dbus \
- python-pygobject \
- python-pyrtc \
- python-pyserial \
- python-syslog \
-"
-
-FILES_${PN} += "${sysconfdir}"
diff --git a/packages/freesmartphone/python-ousaged/.mtn2git_empty b/packages/freesmartphone/python-ousaged/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/freesmartphone/python-ousaged/.mtn2git_empty
+++ /dev/null
diff --git a/packages/freesmartphone/python-ousaged/ousaged b/packages/freesmartphone/python-ousaged/ousaged
deleted file mode 100644
index 7b62d7f93c..0000000000
--- a/packages/freesmartphone/python-ousaged/ousaged
+++ /dev/null
@@ -1,40 +0,0 @@
-#! /bin/sh
-#
-# odeviced This shell script starts and stops the open device daemon.
-#
-# chkconfig: 345 90 20
-# description: py-ousaged is the open usage daemon
-# processname: python
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-NAME=odeviced
-
-[ -f /etc/default/rcS ] && . /etc/default/rcS
-
-case "$1" in
- start)
- echo -n "Starting open usage daemon: "
- start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/ousaged
- if [ $? = 0 ]; then
- echo "(ok)"
- else
- echo "(failed)"
- fi
- ;;
- stop)
- echo -n "Stopping open usage daemon: "
- start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
- rm -f /var/run/${NAME}.pid
- echo "(done)"
- ;;
- restart|force-reload)
- $0 stop
- $0 start
- ;;
- *)
- echo "Usage: /etc/init.d/ousaged {start|stop|restart|force-reload}"
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/freesmartphone/python-ousaged_git.bb b/packages/freesmartphone/python-ousaged_git.bb
deleted file mode 100644
index 1188da34a3..0000000000
--- a/packages/freesmartphone/python-ousaged_git.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-DESCRIPTION = "The Open Usage Daemon Prototype in Python"
-HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenUsageDaemon"
-AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-SECTION = "console/network"
-DEPENDS = "python-cython-native python-pyrex-native"
-LICENSE = "GPLv2"
-PV = "0.7.9+gitr${SRCREV}"
-PR = "r1"
-
-inherit distutils update-rc.d
-
-INITSCRIPT_NAME = "ousaged"
-INITSCRIPT_PARAMS = "defaults 21"
-
-SRC_URI = "\
- ${FREESMARTPHONE_GIT}/usaged.git;protocol=git;branch=master \
- file://ousaged \
-"
-S = "${WORKDIR}/git"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/ousaged ${D}${sysconfdir}/init.d/
- install -d ${D}${sysconfdir}/dbus-1/system.d/
- mv -f ${D}${datadir}/etc/dbus-1/system.d/ousaged.conf ${D}${sysconfdir}/dbus-1/system.d/
-}
-
-RDEPENDS_${PN} += "\
- python-dbus \
- python-pygobject \
- python-pyrtc \
- python-syslog \
- python-odeviced \
-"
-
-FILES_${PN} += "${sysconfdir}"
diff --git a/packages/freesmartphone/zhone/80zhone b/packages/freesmartphone/zhone/80zhone
index 90a1e95b39..5a36e873f4 100644
--- a/packages/freesmartphone/zhone/80zhone
+++ b/packages/freesmartphone/zhone/80zhone
@@ -1,4 +1,4 @@
#!/bin/sh -e
-zhone --fullscreen > /tmp/zhone.log 2>&1 &
+zhone > /tmp/zhone.log 2>&1 &
renice -3 $!
exit 0
diff --git a/packages/freesmartphone/zhone_git.bb b/packages/freesmartphone/zhone_git.bb
index c9411a58c3..8a4a21bbed 100644
--- a/packages/freesmartphone/zhone_git.bb
+++ b/packages/freesmartphone/zhone_git.bb
@@ -1,16 +1,16 @@
DESCRIPTION = "Zhone: Zen Phone"
LICENSE = "GPL"
SECTION = "x11"
-DEPENDS = "edje-native"
+DEPENDS = "edje-native python-pyrex-native python-cython-native"
RDEPENDS = "task-python-efl python-textutils python-dbus"
PV = "0.0.0+gitr${SRCREV}"
-PR = "r5"
+PR = "r7"
SRC_URI = "${FREESMARTPHONE_GIT}/zhone.git;protocol=git;branch=master \
file://80zhone"
S = "${WORKDIR}/git"
-inherit autotools
+inherit distutils
do_install_append() {
install -d ${D}${sysconfdir}/X11/Xsession.d/
@@ -18,6 +18,3 @@ do_install_append() {
}
FILES_${PN} += "${datadir} ${sysconfdir}"
-
-PACKAGE_ARCH = "all"
-