summaryrefslogtreecommitdiff
path: root/packages/freesmartphone
diff options
context:
space:
mode:
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/frameworkd/frameworkd.conf19
-rw-r--r--packages/freesmartphone/frameworkd_git.bb10
-rw-r--r--packages/freesmartphone/zhone_git.bb9
3 files changed, 28 insertions, 10 deletions
diff --git a/packages/freesmartphone/frameworkd/frameworkd.conf b/packages/freesmartphone/frameworkd/frameworkd.conf
index 8b13789179..36b4f5fc8e 100644
--- a/packages/freesmartphone/frameworkd/frameworkd.conf
+++ b/packages/freesmartphone/frameworkd/frameworkd.conf
@@ -1 +1,20 @@
+[odeviced]
+[kernel26]
+# set 1 to disable the module
+disable = 0
+
+[idlenotifier]
+# set 1 to disable the module
+disable = 0
+# add inut nodes to ignore for idle activity
+ignoreinput = 2,3,4
+
+[powercontrol-neo]
+disable = 0
+
+[ogsmd]
+modemtype = ti_calypso
+
+[opreferencesd]
+rootdir = ../etc/freesmartphone/opreferences:/etc/freesmartphone/opreferences:/usr/etc/freesmartphone/opreferences
diff --git a/packages/freesmartphone/frameworkd_git.bb b/packages/freesmartphone/frameworkd_git.bb
index ea3a4cb652..a6d25f79ec 100644
--- a/packages/freesmartphone/frameworkd_git.bb
+++ b/packages/freesmartphone/frameworkd_git.bb
@@ -1,11 +1,11 @@
-DESCRIPTION = "The freesmartphon.org Framework Daemon"
+DESCRIPTION = "The freesmartphone.org Framework Daemon"
HOMEPAGE = "http://www.freesmartphone.org"
-AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de> et. al."
SECTION = "console/network"
DEPENDS = "python-cython-native python-pyrex-native"
LICENSE = "GPL"
PV = "0.8.0+gitr${SRCREV}"
-PR = "r2"
+PR = "r6"
inherit distutils update-rc.d
@@ -27,12 +27,14 @@ do_install_append() {
RDEPENDS_${PN} += "\
python-dbus \
+ python-datetime \
python-pygobject \
python-pyrtc \
python-pyserial \
+ python-pyyaml \
python-shell \
python-syslog \
"
-FILES_${PN} += "${sysconfdir}"
+FILES_${PN} += "${sysconfdir} ${datadir}"
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/framework/subsystems/*/.debug"
diff --git a/packages/freesmartphone/zhone_git.bb b/packages/freesmartphone/zhone_git.bb
index c9411a58c3..a766eb1ab5 100644
--- a/packages/freesmartphone/zhone_git.bb
+++ b/packages/freesmartphone/zhone_git.bb
@@ -1,16 +1,16 @@
DESCRIPTION = "Zhone: Zen Phone"
LICENSE = "GPL"
SECTION = "x11"
-DEPENDS = "edje-native"
+DEPENDS = "edje-native python-pyrex-native python-cython-native"
RDEPENDS = "task-python-efl python-textutils python-dbus"
PV = "0.0.0+gitr${SRCREV}"
-PR = "r5"
+PR = "r6"
SRC_URI = "${FREESMARTPHONE_GIT}/zhone.git;protocol=git;branch=master \
file://80zhone"
S = "${WORKDIR}/git"
-inherit autotools
+inherit distutils
do_install_append() {
install -d ${D}${sysconfdir}/X11/Xsession.d/
@@ -18,6 +18,3 @@ do_install_append() {
}
FILES_${PN} += "${datadir} ${sysconfdir}"
-
-PACKAGE_ARCH = "all"
-