summaryrefslogtreecommitdiff
path: root/packages/freesmartphone
diff options
context:
space:
mode:
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/frameworkd/.mtn2git_empty (renamed from packages/freesmartphone/python-odeviced/.mtn2git_empty)0
-rw-r--r--packages/freesmartphone/frameworkd/a780/.mtn2git_empty (renamed from packages/freesmartphone/python-odeviced/om-gta02/.mtn2git_empty)0
-rw-r--r--packages/freesmartphone/frameworkd/a780/frameworkd.conf15
-rw-r--r--packages/freesmartphone/frameworkd/frameworkd (renamed from packages/freesmartphone/python-odeviced/odeviced)12
-rw-r--r--packages/freesmartphone/frameworkd/frameworkd.conf21
-rw-r--r--packages/freesmartphone/frameworkd/magician/.mtn2git_empty (renamed from packages/freesmartphone/python-oeventd/.mtn2git_empty)0
-rw-r--r--packages/freesmartphone/frameworkd/magician/frameworkd.conf17
-rw-r--r--packages/freesmartphone/frameworkd/om-gta01/.mtn2git_empty (renamed from packages/freesmartphone/python-ophoned/.mtn2git_empty)0
-rw-r--r--packages/freesmartphone/frameworkd/om-gta01/frameworkd.conf15
-rw-r--r--packages/freesmartphone/frameworkd/om-gta02/.mtn2git_empty (renamed from packages/freesmartphone/python-ousaged/.mtn2git_empty)0
-rw-r--r--packages/freesmartphone/frameworkd/om-gta02/frameworkd.conf24
-rw-r--r--packages/freesmartphone/frameworkd_git.bb40
-rw-r--r--packages/freesmartphone/gsmd2_git.bb7
-rw-r--r--packages/freesmartphone/mickeydbus_git.bb18
-rw-r--r--packages/freesmartphone/python-odeviced/odeviced.conf0
-rw-r--r--packages/freesmartphone/python-odeviced/om-gta02/odeviced.conf8
-rw-r--r--packages/freesmartphone/python-odeviced_git.bb35
-rw-r--r--packages/freesmartphone/python-oeventd/oeventd40
-rw-r--r--packages/freesmartphone/python-oeventd_git.bb34
-rw-r--r--packages/freesmartphone/python-ophoned/ophoned40
-rw-r--r--packages/freesmartphone/python-ophoned_git.bb35
-rw-r--r--packages/freesmartphone/python-ousaged/ousaged40
-rw-r--r--packages/freesmartphone/python-ousaged_git.bb36
-rw-r--r--packages/freesmartphone/zhone/80zhone2
-rw-r--r--packages/freesmartphone/zhone_git.bb9
25 files changed, 165 insertions, 283 deletions
diff --git a/packages/freesmartphone/python-odeviced/.mtn2git_empty b/packages/freesmartphone/frameworkd/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/freesmartphone/python-odeviced/.mtn2git_empty
+++ b/packages/freesmartphone/frameworkd/.mtn2git_empty
diff --git a/packages/freesmartphone/python-odeviced/om-gta02/.mtn2git_empty b/packages/freesmartphone/frameworkd/a780/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/freesmartphone/python-odeviced/om-gta02/.mtn2git_empty
+++ b/packages/freesmartphone/frameworkd/a780/.mtn2git_empty
diff --git a/packages/freesmartphone/frameworkd/a780/frameworkd.conf b/packages/freesmartphone/frameworkd/a780/frameworkd.conf
new file mode 100644
index 0000000000..4499acc47e
--- /dev/null
+++ b/packages/freesmartphone/frameworkd/a780/frameworkd.conf
@@ -0,0 +1,15 @@
+[idlenotifier]
+
+[input]
+# keys (copied from Openmoko, need to adjust)
+report1 = AUX,key,169,1
+report2 = POWER,key,116,1
+report3 = CHARGER,key,356,0
+report4 = HEADSET,switch,2,0
+
+[ogsmd]
+# A780 has Freescale Neptune LTE
+modemtype = freescale_neptune
+
+[opreferencesd]
+rootdir = ../etc/freesmartphone/opreferences:/etc/freesmartphone/opreferences:/usr/etc/freesmartphone/opreferences
diff --git a/packages/freesmartphone/python-odeviced/odeviced b/packages/freesmartphone/frameworkd/frameworkd
index 52d3a1d196..08b782e402 100644
--- a/packages/freesmartphone/python-odeviced/odeviced
+++ b/packages/freesmartphone/frameworkd/frameworkd
@@ -1,20 +1,20 @@
#! /bin/sh
#
-# odeviced This shell script starts and stops the open device daemon.
+# frameworkd -- This shell script starts and stops the freemsmartphone.org framework daemon.
#
# chkconfig: 345 90 20
-# description: py-odeviced is the open device daemon
+# description: frameworkd is the freesmartphone.org framework daemon
# processname: python
PATH=/bin:/usr/bin:/sbin:/usr/sbin
-NAME=odeviced
+NAME=frameworkd
[ -f /etc/default/rcS ] && . /etc/default/rcS
case "$1" in
start)
- echo -n "Starting open device daemon: "
- start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/odeviced
+ echo -n "Starting freesmartphone.org framework daemon: "
+ start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/frameworkd
if [ $? = 0 ]; then
echo "(ok)"
else
@@ -22,7 +22,7 @@ case "$1" in
fi
;;
stop)
- echo -n "Stopping open device daemon: "
+ echo -n "Stopping freesmartphone.org framework daemon: "
start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
rm -f /var/run/${NAME}.pid
echo "(done)"
diff --git a/packages/freesmartphone/frameworkd/frameworkd.conf b/packages/freesmartphone/frameworkd/frameworkd.conf
new file mode 100644
index 0000000000..3d0bbc3c1c
--- /dev/null
+++ b/packages/freesmartphone/frameworkd/frameworkd.conf
@@ -0,0 +1,21 @@
+[odeviced]
+
+[kernel26]
+# set 1 to disable the module
+disable = 0
+
+[idlenotifier]
+# set 1 to disable the module
+disable = 0
+# add inut nodes to ignore for idle activity
+ignoreinput = 2,3,4
+
+[powercontrol-neo]
+disable = 0
+
+[ogsmd]
+# specify your modemtype here
+modemtype = ti_calypso
+
+[opreferencesd]
+rootdir = ../etc/freesmartphone/opreferences:/etc/freesmartphone/opreferences:/usr/etc/freesmartphone/opreferences
diff --git a/packages/freesmartphone/python-oeventd/.mtn2git_empty b/packages/freesmartphone/frameworkd/magician/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/freesmartphone/python-oeventd/.mtn2git_empty
+++ b/packages/freesmartphone/frameworkd/magician/.mtn2git_empty
diff --git a/packages/freesmartphone/frameworkd/magician/frameworkd.conf b/packages/freesmartphone/frameworkd/magician/frameworkd.conf
new file mode 100644
index 0000000000..cbafb1925f
--- /dev/null
+++ b/packages/freesmartphone/frameworkd/magician/frameworkd.conf
@@ -0,0 +1,17 @@
+[idlenotifier]
+
+[input]
+# magician doesn't have AUX, use the CAMERA key for now
+# (it's in about the same place as AUX on gta01/02)
+report1 = AUX,key,212,1
+report2 = POWER,key,116,1
+# magician doesn't use KEY_POWER2 for the charger, need to fix
+report3 = CHARGER,key,356,0
+report4 = HEADSET,switch,2,0
+
+[ophoned]
+# Magician has TI Calypso
+modemtype = ti_calypso
+
+[opreferencesd]
+rootdir = ../etc/freesmartphone/opreferences:/etc/freesmartphone/opreferences:/usr/etc/freesmartphone/opreferences
diff --git a/packages/freesmartphone/python-ophoned/.mtn2git_empty b/packages/freesmartphone/frameworkd/om-gta01/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/freesmartphone/python-ophoned/.mtn2git_empty
+++ b/packages/freesmartphone/frameworkd/om-gta01/.mtn2git_empty
diff --git a/packages/freesmartphone/frameworkd/om-gta01/frameworkd.conf b/packages/freesmartphone/frameworkd/om-gta01/frameworkd.conf
new file mode 100644
index 0000000000..64c00a4a92
--- /dev/null
+++ b/packages/freesmartphone/frameworkd/om-gta01/frameworkd.conf
@@ -0,0 +1,15 @@
+[idlenotifier]
+
+[input]
+# Keys
+report1 = AUX,key,169,1
+report2 = POWER,key,116,1
+report3 = CHARGER,key,356,0
+report4 = HEADSET,switch,2,0
+
+[ogsmd]
+# GTA01 has TI Calypso
+modemtype = ti_calypso
+
+[opreferencesd]
+rootdir = ../etc/freesmartphone/opreferences:/etc/freesmartphone/opreferences:/usr/etc/freesmartphone/opreferences
diff --git a/packages/freesmartphone/python-ousaged/.mtn2git_empty b/packages/freesmartphone/frameworkd/om-gta02/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/freesmartphone/python-ousaged/.mtn2git_empty
+++ b/packages/freesmartphone/frameworkd/om-gta02/.mtn2git_empty
diff --git a/packages/freesmartphone/frameworkd/om-gta02/frameworkd.conf b/packages/freesmartphone/frameworkd/om-gta02/frameworkd.conf
new file mode 100644
index 0000000000..79c06edff2
--- /dev/null
+++ b/packages/freesmartphone/frameworkd/om-gta02/frameworkd.conf
@@ -0,0 +1,24 @@
+[idlenotifier]
+# don't read from accellerometers for GTA02
+ignoreinput=2,3
+
+[input]
+# don't read from accellerometers for GTA02
+ignoreinput=2,3
+# keys
+report1 = AUX,key,169,1
+report2 = POWER,key,116,1
+report3 = CHARGER,key,356,0
+report4 = HEADSET,switch,2,0
+
+[ogsmd]
+# GTA02 has TI Calypso
+modemtype = ti_calypso
+
+[ogpsd]
+device = GTA02Device
+channel = SerialChannel
+path = /dev/ttySAC1
+
+[opreferencesd]
+rootdir = ../etc/freesmartphone/opreferences:/etc/freesmartphone/opreferences:/usr/etc/freesmartphone/opreferences
diff --git a/packages/freesmartphone/frameworkd_git.bb b/packages/freesmartphone/frameworkd_git.bb
new file mode 100644
index 0000000000..20c655e98d
--- /dev/null
+++ b/packages/freesmartphone/frameworkd_git.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "The freesmartphone.org Framework Daemon"
+HOMEPAGE = "http://www.freesmartphone.org"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de> et. al."
+SECTION = "console/network"
+DEPENDS = "python-cython-native python-pyrex-native"
+LICENSE = "GPL"
+PV = "0.8.1+gitr${SRCREV}"
+PR = "r9"
+
+inherit distutils update-rc.d
+
+INITSCRIPT_NAME = "frameworkd"
+INITSCRIPT_PARAMS = "defaults 29"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/framework.git;protocol=git;branch=master \
+ file://frameworkd \
+ file://frameworkd.conf"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/frameworkd ${D}${sysconfdir}/init.d/
+ install -m 0644 ${WORKDIR}/frameworkd.conf ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ mv -f ${D}${datadir}/etc/dbus-1/system.d/frameworkd.conf ${D}${sysconfdir}/dbus-1/system.d/
+}
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-datetime \
+ python-pygobject \
+ python-pyrtc \
+ python-pyserial \
+ python-pyyaml \
+ python-shell \
+ python-syslog \
+"
+
+FILES_${PN} += "${sysconfdir} ${datadir}"
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/framework/subsystems/*/.debug"
diff --git a/packages/freesmartphone/gsmd2_git.bb b/packages/freesmartphone/gsmd2_git.bb
index 6c2f1a4d21..6c327ede30 100644
--- a/packages/freesmartphone/gsmd2_git.bb
+++ b/packages/freesmartphone/gsmd2_git.bb
@@ -1,14 +1,17 @@
DESCRIPTION = "GSM 07.07 phone server"
HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/gsm0710muxd"
-AUTHOR = "Ixonos"
+AUTHOR = "Ixonos Team"
SECTION = "console/network"
DEPENDS = "dbus dbus-glib"
RDEPENDS = "gsm0710muxd"
LICENSE = "GPL"
-PV = "0.0.0+gitr${SRCREV}"
+PV = "0.1.0+gitr${SRCREV}"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/gsmd2.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
inherit autotools
+
+EXTRA_OECONF = "--disable-tests"
+
diff --git a/packages/freesmartphone/mickeydbus_git.bb b/packages/freesmartphone/mickeydbus_git.bb
new file mode 100644
index 0000000000..cbd90e5030
--- /dev/null
+++ b/packages/freesmartphone/mickeydbus_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Mickey's DBus introspection and calling Program"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PV = "0.9.0+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 mickeydbus/mdbus ${D}${bindir}
+}
+
+RDEPENDS_${PN} = "\
+ python-dbus \
+"
diff --git a/packages/freesmartphone/python-odeviced/odeviced.conf b/packages/freesmartphone/python-odeviced/odeviced.conf
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/freesmartphone/python-odeviced/odeviced.conf
+++ /dev/null
diff --git a/packages/freesmartphone/python-odeviced/om-gta02/odeviced.conf b/packages/freesmartphone/python-odeviced/om-gta02/odeviced.conf
deleted file mode 100644
index 0076639f98..0000000000
--- a/packages/freesmartphone/python-odeviced/om-gta02/odeviced.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-[idlenotifier]
-# don't read from accellerometers for now
-ignoreinput=2,3
-
-[input]
-# don't read from accellerometers for now
-ignoreinput=2,3
-
diff --git a/packages/freesmartphone/python-odeviced_git.bb b/packages/freesmartphone/python-odeviced_git.bb
deleted file mode 100644
index 121a434585..0000000000
--- a/packages/freesmartphone/python-odeviced_git.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-DESCRIPTION = "The Open Device Daemon Prototype in Python"
-HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenDeviceDaemon"
-AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-SECTION = "console/network"
-DEPENDS = "python-cython-native python-pyrex-native"
-LICENSE = "GPLv2"
-PV = "0.7.9+gitr${SRCREV}"
-PR = "r2"
-
-inherit distutils update-rc.d
-
-INITSCRIPT_NAME = "odeviced"
-INITSCRIPT_PARAMS = "defaults 21"
-
-SRC_URI = "${FREESMARTPHONE_GIT}/python-odeviced.git;protocol=git;branch=master \
- file://odeviced \
- file://odeviced.conf"
-S = "${WORKDIR}/git"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/odeviced ${D}${sysconfdir}/init.d/
- install -m 0644 ${WORKDIR}/odeviced.conf ${D}${sysconfdir}
- install -d ${D}${sysconfdir}/dbus-1/system.d/
- mv -f ${D}${datadir}/etc/dbus-1/system.d/odeviced.conf ${D}${sysconfdir}/dbus-1/system.d/
-}
-
-RDEPENDS_${PN} += "\
- python-dbus \
- python-pygobject \
- python-pyrtc \
- python-syslog \
-"
-
-FILES_${PN} += "${sysconfdir}"
diff --git a/packages/freesmartphone/python-oeventd/oeventd b/packages/freesmartphone/python-oeventd/oeventd
deleted file mode 100644
index 8ed467b079..0000000000
--- a/packages/freesmartphone/python-oeventd/oeventd
+++ /dev/null
@@ -1,40 +0,0 @@
-#! /bin/sh
-#
-# odeviced This shell script starts and stops the open event daemon.
-#
-# chkconfig: 345 90 20
-# description: py-oeventd is the open evend daemon
-# processname: python
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-NAME=oeventd
-
-[ -f /etc/default/rcS ] && . /etc/default/rcS
-
-case "$1" in
- start)
- echo -n "Starting open event daemon: "
- start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/oeventd
- if [ $? = 0 ]; then
- echo "(ok)"
- else
- echo "(failed)"
- fi
- ;;
- stop)
- echo -n "Stopping open event daemon: "
- start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
- rm -f /var/run/${NAME}.pid
- echo "(done)"
- ;;
- restart|force-reload)
- $0 stop
- $0 start
- ;;
- *)
- echo "Usage: /etc/init.d/oeventd {start|stop|restart|force-reload}"
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/freesmartphone/python-oeventd_git.bb b/packages/freesmartphone/python-oeventd_git.bb
deleted file mode 100644
index c08e1af3b7..0000000000
--- a/packages/freesmartphone/python-oeventd_git.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-DESCRIPTION = "The Open Event Daemon Prototype in Python"
-HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenEventDaemon"
-AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-SECTION = "console/network"
-DEPENDS = "python-cython-native python-pyrex-native"
-LICENSE = "GPLv2"
-PV = "0.0.0+gitr${SRCREV}"
-PR = "r1"
-
-inherit distutils update-rc.d
-
-INITSCRIPT_NAME = "oeventd"
-INITSCRIPT_PARAMS = "defaults 21"
-
-SRC_URI = "\
- ${FREESMARTPHONE_GIT}/eventd.git;protocol=git;branch=master \
- file://oeventd \
-"
-S = "${WORKDIR}/git"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/oeventd ${D}${sysconfdir}/init.d/
- install -d ${D}${sysconfdir}/dbus-1/system.d/
- mv -f ${D}${datadir}/etc/dbus-1/system.d/oeventd.conf ${D}${sysconfdir}/dbus-1/system.d/
-}
-
-RDEPENDS_${PN} += "\
- python-dbus \
- python-pygobject \
- python-syslog \
-"
-
-FILES_${PN} += "${sysconfdir}"
diff --git a/packages/freesmartphone/python-ophoned/ophoned b/packages/freesmartphone/python-ophoned/ophoned
deleted file mode 100644
index edc800711a..0000000000
--- a/packages/freesmartphone/python-ophoned/ophoned
+++ /dev/null
@@ -1,40 +0,0 @@
-#! /bin/sh
-#
-# ophoned This shell script starts and stops the open phone daemon.
-#
-# chkconfig: 345 90 20
-# description: py-ophoned is the open phone daemon
-# processname: python
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-NAME=ophoned
-
-[ -f /etc/default/rcS ] && . /etc/default/rcS
-
-case "$1" in
- start)
- echo -n "Starting open phone daemon: "
- start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/ophoned
- if [ $? = 0 ]; then
- echo "(ok)"
- else
- echo "(failed)"
- fi
- ;;
- stop)
- echo -n "Stopping open phone daemon: "
- start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
- rm -f /var/run/${NAME}.pid
- echo "(done)"
- ;;
- restart|force-reload)
- $0 stop
- $0 start
- ;;
- *)
- echo "Usage: /etc/init.d/ophoned {start|stop|restart|force-reload}"
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/freesmartphone/python-ophoned_git.bb b/packages/freesmartphone/python-ophoned_git.bb
deleted file mode 100644
index 7f30f4c24a..0000000000
--- a/packages/freesmartphone/python-ophoned_git.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-DESCRIPTION = "The Open Phone Daemon (Python Implementation)"
-HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenPhoneServer"
-AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-SECTION = "console/network"
-DEPENDS = "python-cython-native python-pyrex-native"
-LICENSE = "GPLv2"
-PV = "0.0.0+gitr${SRCREV}"
-PR = "r1"
-
-inherit distutils update-rc.d
-
-INITSCRIPT_NAME = "ophoned"
-INITSCRIPT_PARAMS = "defaults 21"
-
-SRC_URI = "${FREESMARTPHONE_GIT}/python-ophoned.git;protocol=git;branch=master \
- file://ophoned"
-S = "${WORKDIR}/git"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/ophoned ${D}${sysconfdir}/init.d/
-# install -m 0644 ${WORKDIR}/ophoned.conf ${D}${sysconfdir}
- install -d ${D}${sysconfdir}/dbus-1/system.d/
- mv -f ${D}${datadir}/etc/dbus-1/system.d/ophoned.conf ${D}${sysconfdir}/dbus-1/system.d/
-}
-
-RDEPENDS_${PN} += "\
- python-dbus \
- python-pygobject \
- python-pyrtc \
- python-pyserial \
- python-syslog \
-"
-
-FILES_${PN} += "${sysconfdir}"
diff --git a/packages/freesmartphone/python-ousaged/ousaged b/packages/freesmartphone/python-ousaged/ousaged
deleted file mode 100644
index 7b62d7f93c..0000000000
--- a/packages/freesmartphone/python-ousaged/ousaged
+++ /dev/null
@@ -1,40 +0,0 @@
-#! /bin/sh
-#
-# odeviced This shell script starts and stops the open device daemon.
-#
-# chkconfig: 345 90 20
-# description: py-ousaged is the open usage daemon
-# processname: python
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-NAME=odeviced
-
-[ -f /etc/default/rcS ] && . /etc/default/rcS
-
-case "$1" in
- start)
- echo -n "Starting open usage daemon: "
- start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/ousaged
- if [ $? = 0 ]; then
- echo "(ok)"
- else
- echo "(failed)"
- fi
- ;;
- stop)
- echo -n "Stopping open usage daemon: "
- start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
- rm -f /var/run/${NAME}.pid
- echo "(done)"
- ;;
- restart|force-reload)
- $0 stop
- $0 start
- ;;
- *)
- echo "Usage: /etc/init.d/ousaged {start|stop|restart|force-reload}"
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/freesmartphone/python-ousaged_git.bb b/packages/freesmartphone/python-ousaged_git.bb
deleted file mode 100644
index 1188da34a3..0000000000
--- a/packages/freesmartphone/python-ousaged_git.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-DESCRIPTION = "The Open Usage Daemon Prototype in Python"
-HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenUsageDaemon"
-AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-SECTION = "console/network"
-DEPENDS = "python-cython-native python-pyrex-native"
-LICENSE = "GPLv2"
-PV = "0.7.9+gitr${SRCREV}"
-PR = "r1"
-
-inherit distutils update-rc.d
-
-INITSCRIPT_NAME = "ousaged"
-INITSCRIPT_PARAMS = "defaults 21"
-
-SRC_URI = "\
- ${FREESMARTPHONE_GIT}/usaged.git;protocol=git;branch=master \
- file://ousaged \
-"
-S = "${WORKDIR}/git"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/ousaged ${D}${sysconfdir}/init.d/
- install -d ${D}${sysconfdir}/dbus-1/system.d/
- mv -f ${D}${datadir}/etc/dbus-1/system.d/ousaged.conf ${D}${sysconfdir}/dbus-1/system.d/
-}
-
-RDEPENDS_${PN} += "\
- python-dbus \
- python-pygobject \
- python-pyrtc \
- python-syslog \
- python-odeviced \
-"
-
-FILES_${PN} += "${sysconfdir}"
diff --git a/packages/freesmartphone/zhone/80zhone b/packages/freesmartphone/zhone/80zhone
index 4a698007b8..5a36e873f4 100644
--- a/packages/freesmartphone/zhone/80zhone
+++ b/packages/freesmartphone/zhone/80zhone
@@ -1,4 +1,4 @@
#!/bin/sh -e
-zhone --fullscreen > /dev/null 2>&1 &
+zhone > /tmp/zhone.log 2>&1 &
renice -3 $!
exit 0
diff --git a/packages/freesmartphone/zhone_git.bb b/packages/freesmartphone/zhone_git.bb
index 513b06f35a..8a4a21bbed 100644
--- a/packages/freesmartphone/zhone_git.bb
+++ b/packages/freesmartphone/zhone_git.bb
@@ -1,16 +1,16 @@
DESCRIPTION = "Zhone: Zen Phone"
LICENSE = "GPL"
SECTION = "x11"
-DEPENDS = "edje-native"
+DEPENDS = "edje-native python-pyrex-native python-cython-native"
RDEPENDS = "task-python-efl python-textutils python-dbus"
PV = "0.0.0+gitr${SRCREV}"
-PR = "r4"
+PR = "r7"
SRC_URI = "${FREESMARTPHONE_GIT}/zhone.git;protocol=git;branch=master \
file://80zhone"
S = "${WORKDIR}/git"
-inherit autotools
+inherit distutils
do_install_append() {
install -d ${D}${sysconfdir}/X11/Xsession.d/
@@ -18,6 +18,3 @@ do_install_append() {
}
FILES_${PN} += "${datadir} ${sysconfdir}"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-