summaryrefslogtreecommitdiff
path: root/packages/freesmartphone/fsod_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/freesmartphone/fsod_git.bb')
-rw-r--r--packages/freesmartphone/fsod_git.bb21
1 files changed, 13 insertions, 8 deletions
diff --git a/packages/freesmartphone/fsod_git.bb b/packages/freesmartphone/fsod_git.bb
index 278331326e..c0af2cace3 100644
--- a/packages/freesmartphone/fsod_git.bb
+++ b/packages/freesmartphone/fsod_git.bb
@@ -3,21 +3,26 @@ HOMEPAGE = "http://www.freesmartphone.org/"
AUTHOR = "Sudharshan S"
SECTION = "console/network"
DEPENDS = "dbus dbus-glib libnl vala-native"
+# for pygobject-codegen
+DEPENDS += "python-pygtk"
LICENSE = "LGPL"
PV = "0.1+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
+
+inherit autotools pkgconfig update-rc.d distutils-base
+
+EXTRA_OECONF = "--enable-python --with-python-includes=${STAGING_INCDIR}/.."
+
+INITSCRIPT_NAME = "fsod"
+INITSCRIPT_PARAMS = "defaults 21"
SRC_URI = "\
${FREESMARTPHONE_GIT}/openmoko-gsoc2008.git;protocol=git;branch=master \
+ file://autofoo.patch;patch=1 \
# file://fsod \
"
S = "${WORKDIR}/git/fsod"
-inherit autotools pkgconfig update-rc.d
-
-INITSCRIPT_NAME = "fsod"
-INITSCRIPT_PARAMS = "defaults 21"
-
do_install_append() {
# install -d ${D}${sysconfdir}/init.d
# install -m 0755 ${WORKDIR}/fsod ${D}${sysconfdir}/init.d/
@@ -26,9 +31,9 @@ do_install_append() {
RCONFLICTS_${PN} = "frameworkd"
RREPLACES_${PN} = "frameworkd"
-FILES_${PN} += "${sysconfdir}"
+FILES_${PN} += "${sysconfdir} ${datadir}"
FILES_${PN}-dbg += "\
+ ${bindir}/.debug \
${libdir}/fsod/subsystems/.debug \
${libdir}/fsod/subsystems/*/.debug \
"
-