summaryrefslogtreecommitdiff
path: root/packages/fontconfig
diff options
context:
space:
mode:
Diffstat (limited to 'packages/fontconfig')
-rw-r--r--packages/fontconfig/fontconfig.inc37
-rw-r--r--packages/fontconfig/fontconfig_2.2.95.bb41
-rw-r--r--packages/fontconfig/fontconfig_2.3.91.bb41
-rw-r--r--packages/fontconfig/fontconfig_2.3.95.bb39
-rw-r--r--packages/fontconfig/fontconfig_2.4.1.bb38
5 files changed, 50 insertions, 146 deletions
diff --git a/packages/fontconfig/fontconfig.inc b/packages/fontconfig/fontconfig.inc
new file mode 100644
index 0000000000..2b3dc39c36
--- /dev/null
+++ b/packages/fontconfig/fontconfig.inc
@@ -0,0 +1,37 @@
+DESCRIPTION = "A library for configuring and customizing font access."
+SECTION = "libs"
+LICENSE = "BSD"
+DEPENDS = "expat freetype freetype-native zlib"
+
+# Work around past breakage in debian.bbclass
+RPROVIDES_fontconfig-utils = "libfontconfig-utils"
+RREPLACES_fontconfig-utils = "libfontconfig-utils"
+RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
+DEBIAN_NOAUTONAME_fontconfig-utils = "1"
+
+SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz"
+
+S = "${WORKDIR}/fontconfig-${PV}"
+
+inherit autotools pkgconfig
+
+export HASDOCBOOK="no"
+
+EXTRA_OECONF = " --disable-docs"
+EXTRA_OEMAKE = "FC_LANG=fc-lang FC_GLYPHNAME=fc-glyphname"
+
+# The tarball has some of the patched files as read only, which
+# patch doesn't like at all
+
+fontconfig_do_unpack() {
+ chmod -R u+rw ${S}
+}
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ bb.build.exec_func('fontconfig_do_unpack', d)
+}
+
+PACKAGES =+ "fontconfig-utils-dbg fontconfig-utils "
+FILES_fontconfig-utils-dbg = "${bindir}/*.dbg"
+FILES_fontconfig-utils = "${bindir}/*"
diff --git a/packages/fontconfig/fontconfig_2.2.95.bb b/packages/fontconfig/fontconfig_2.2.95.bb
index e1cc319f16..d1aab24951 100644
--- a/packages/fontconfig/fontconfig_2.2.95.bb
+++ b/packages/fontconfig/fontconfig_2.2.95.bb
@@ -1,45 +1,12 @@
-SECTION = "libs"
-LICENSE = "BSD"
-DESCRIPTION = "A library for configuring and customizing font access."
-DEPENDS = "expat freetype freetype-native zlib fontconfig-native"
+require fontconfig.inc
-SRC_URI = "http://freedesktop.org/fontconfig/release/fontconfig-${PV}.tar.gz \
- file://fc-glyphname.patch;patch=1 \
+DEPENDS += "fontconfig-native"
+
+SRC_URI += "file://fc-glyphname.patch;patch=1 \
file://fc-lang.patch;patch=1 \
file://local.conf"
PR = "r8"
-PACKAGES =+ "fontconfig-utils-dbg fontconfig-utils "
-FILES_fontconfig-utils-dbg = "${bindir}/*.dbg"
-FILES_fontconfig-utils = "${bindir}/*"
-
-# Work around past breakage in debian.bbclass
-RPROVIDES_fontconfig-utils = "libfontconfig-utils"
-RREPLACES_fontconfig-utils = "libfontconfig-utils"
-RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
-DEBIAN_NOAUTONAME_fontconfig-utils = "1"
-
-S = "${WORKDIR}/fontconfig-${PV}"
-
-inherit autotools pkgconfig
-
-export HASDOCBOOK="no"
-
-EXTRA_OECONF = " --disable-docs "
-EXTRA_OEMAKE = "FC_LANG=fc-lang FC_GLYPHNAME=fc-glyphname"
-
-# The tarball has some of the patched files as read only, which
-# patch doesn't like at all
-
-fontconfig_do_unpack() {
- chmod -R u+rw ${S}
-}
-
-python do_unpack () {
- bb.build.exec_func('base_do_unpack', d)
- bb.build.exec_func('fontconfig_do_unpack', d)
-}
-
do_stage () {
oe_libinstall -so -a -C src libfontconfig ${STAGING_LIBDIR}
install -d ${STAGING_INCDIR}/fontconfig
diff --git a/packages/fontconfig/fontconfig_2.3.91.bb b/packages/fontconfig/fontconfig_2.3.91.bb
index 220f11d1c9..ec6ef8e037 100644
--- a/packages/fontconfig/fontconfig_2.3.91.bb
+++ b/packages/fontconfig/fontconfig_2.3.91.bb
@@ -1,47 +1,14 @@
-SECTION = "libs"
-LICENSE = "BSD"
-DESCRIPTION = "A library for configuring and customizing font access."
-DEPENDS = "expat freetype freetype-native zlib fontconfig-native"
+require fontconfig.inc
-SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
- file://fc-glyphname.patch;patch=1 \
+DEPENDS += "fontconfig-native"
+
+SRC_URI += "file://fc-glyphname.patch;patch=1 \
file://fc-lang.patch;patch=1 \
file://one-j-too-many.patch;patch=1 \
file://local.conf"
PR = "r3"
-PACKAGES =+ "fontconfig-utils-dbg fontconfig-utils "
-FILES_fontconfig-utils-dbg = "${bindir}/*.dbg"
-FILES_fontconfig-utils = "${bindir}/*"
-
-# Work around past breakage in debian.bbclass
-RPROVIDES_fontconfig-utils = "libfontconfig-utils"
-RREPLACES_fontconfig-utils = "libfontconfig-utils"
-RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
-DEBIAN_NOAUTONAME_fontconfig-utils = "1"
-
-S = "${WORKDIR}/fontconfig-${PV}"
-
-inherit autotools pkgconfig
-
-export HASDOCBOOK="no"
-
-EXTRA_OECONF = " --disable-docs "
-EXTRA_OEMAKE = "FC_LANG=fc-lang FC_GLYPHNAME=fc-glyphname"
-
-# The tarball has some of the patched files as read only, which
-# patch doesn't like at all
-
-fontconfig_do_unpack() {
- chmod -R u+rw ${S}
-}
-
-python do_unpack () {
- bb.build.exec_func('base_do_unpack', d)
- bb.build.exec_func('fontconfig_do_unpack', d)
-}
-
do_stage () {
oe_libinstall -so -a -C src libfontconfig ${STAGING_LIBDIR}
install -d ${STAGING_INCDIR}/fontconfig
diff --git a/packages/fontconfig/fontconfig_2.3.95.bb b/packages/fontconfig/fontconfig_2.3.95.bb
index adbd0ad558..035f8467ed 100644
--- a/packages/fontconfig/fontconfig_2.3.95.bb
+++ b/packages/fontconfig/fontconfig_2.3.95.bb
@@ -1,44 +1,9 @@
-SECTION = "libs"
-LICENSE = "BSD"
-DESCRIPTION = "A library for configuring and customizing font access."
-DEPENDS = "expat freetype freetype-native zlib"
+require fontconfig.inc
-SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
- file://one-j-too-many.patch;patch=1"
+SRC_URI += "file://one-j-too-many.patch;patch=1"
PR = "r2"
-PACKAGES =+ "fontconfig-utils-dbg fontconfig-utils "
-FILES_fontconfig-utils-dbg = "${bindir}/*.dbg"
-FILES_fontconfig-utils = "${bindir}/*"
-
-# Work around past breakage in debian.bbclass
-RPROVIDES_fontconfig-utils = "libfontconfig-utils"
-RREPLACES_fontconfig-utils = "libfontconfig-utils"
-RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
-DEBIAN_NOAUTONAME_fontconfig-utils = "1"
-
-S = "${WORKDIR}/fontconfig-${PV}"
-
-inherit autotools pkgconfig
-
-export HASDOCBOOK="no"
-
-EXTRA_OECONF = " --disable-docs "
-EXTRA_OEMAKE = "FC_LANG=fc-lang FC_GLYPHNAME=fc-glyphname"
-
-# The tarball has some of the patched files as read only, which
-# patch doesn't like at all
-
-fontconfig_do_unpack() {
- chmod -R u+rw ${S}
-}
-
-python do_unpack () {
- bb.build.exec_func('base_do_unpack', d)
- bb.build.exec_func('fontconfig_do_unpack', d)
-}
-
do_stage () {
oe_libinstall -so -a -C src libfontconfig ${STAGING_LIBDIR}
install -d ${STAGING_INCDIR}/fontconfig
diff --git a/packages/fontconfig/fontconfig_2.4.1.bb b/packages/fontconfig/fontconfig_2.4.1.bb
index cc64f9ec4c..0e6e008f42 100644
--- a/packages/fontconfig/fontconfig_2.4.1.bb
+++ b/packages/fontconfig/fontconfig_2.4.1.bb
@@ -1,42 +1,10 @@
-SECTION = "libs"
-LICENSE = "BSD"
-DESCRIPTION = "A library for configuring and customizing font access."
-DEPENDS = "expat freetype freetype-native zlib"
+require fontconfig.inc
-SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
- https://stage.maemo.org/svn/maemo/projects/haf/trunk/fontconfig/device_symbols.h"
PR = "r2"
-PACKAGES =+ "fontconfig-utils-dbg fontconfig-utils "
-FILES_fontconfig-utils-dbg = "${bindir}/*.dbg"
-FILES_fontconfig-utils = "${bindir}/*"
+SRC_URI += "https://stage.maemo.org/svn/maemo/projects/haf/trunk/fontconfig/device_symbols.h"
-# Work around past breakage in debian.bbclass
-RPROVIDES_fontconfig-utils = "libfontconfig-utils"
-RREPLACES_fontconfig-utils = "libfontconfig-utils"
-RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
-DEBIAN_NOAUTONAME_fontconfig-utils = "1"
-
-S = "${WORKDIR}/fontconfig-${PV}"
-
-inherit autotools pkgconfig
-
-export HASDOCBOOK="no"
-
-EXTRA_OECONF = " --disable-docs --with-arch=${HOST_ARCH}"
-EXTRA_OEMAKE = "FC_LANG=fc-lang FC_GLYPHNAME=fc-glyphname"
-
-# The tarball has some of the patched files as read only, which
-# patch doesn't like at all
-
-fontconfig_do_unpack() {
- chmod -R u+rw ${S}
-}
-
-python do_unpack () {
- bb.build.exec_func('base_do_unpack', d)
- bb.build.exec_func('fontconfig_do_unpack', d)
-}
+EXTRA_OECONF += " --with-arch=${HOST_ARCH}"
do_stage () {
cp ${WORKDIR}/device_symbols.h ${S}/fontconfig/