summaryrefslogtreecommitdiff
path: root/packages/flnx/flnx_0.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/flnx/flnx_0.17.bb')
-rw-r--r--packages/flnx/flnx_0.17.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/flnx/flnx_0.17.bb b/packages/flnx/flnx_0.17.bb
index e69de29bb2..b453ad24b1 100644
--- a/packages/flnx/flnx_0.17.bb
+++ b/packages/flnx/flnx_0.17.bb
@@ -0,0 +1,16 @@
+SECTION = "x11/libs"
+LICENSE = "LGPL"
+DEPENDS = "microwindows"
+RDEPENDS = "microwindows"
+SRC_URI = "ftp://ftp.microwindows.org/pub/microwindows/flnx/flnx-${PV}.tar.gz"
+DESCRIPTION = "fltk library for microwindows."
+
+inherit autotools
+
+EXTRA_OECONF = "--with-microwin=${STAGING_LIBDIR}/.."
+
+do_install () {
+ oe_runmake "bindir=${D}/${bindir}" \
+ "libdir=${D}/${libdir}" \
+ "includedir=${D}/${includedir}" install
+}