summaryrefslogtreecommitdiff
path: root/packages/fakeroot/fakeroot-native_1.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/fakeroot/fakeroot-native_1.7.1.bb')
-rw-r--r--packages/fakeroot/fakeroot-native_1.7.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/fakeroot/fakeroot-native_1.7.1.bb b/packages/fakeroot/fakeroot-native_1.7.1.bb
new file mode 100644
index 0000000000..6f2969e181
--- /dev/null
+++ b/packages/fakeroot/fakeroot-native_1.7.1.bb
@@ -0,0 +1,21 @@
+SECTION = "base"
+require fakeroot_${PV}.bb
+inherit native
+RDEPENDS="util-linux-native"
+
+SRC_URI += "file://fix-prefix.patch;patch=1 \
+ file://work-with-older-libtool.patch;patch=1"
+S = "${WORKDIR}/fakeroot-${PV}"
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+