summaryrefslogtreecommitdiff
path: root/packages/ez-ipupdate
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ez-ipupdate')
-rw-r--r--packages/ez-ipupdate/ez-ipupdate_3.0.10.bb31
-rw-r--r--packages/ez-ipupdate/files/conffile.patch10
-rw-r--r--packages/ez-ipupdate/files/configure.patch11
-rw-r--r--packages/ez-ipupdate/files/init44
-rw-r--r--packages/ez-ipupdate/files/ipupdate.conf36
-rw-r--r--packages/ez-ipupdate/files/zoneedit.patch11
6 files changed, 0 insertions, 143 deletions
diff --git a/packages/ez-ipupdate/ez-ipupdate_3.0.10.bb b/packages/ez-ipupdate/ez-ipupdate_3.0.10.bb
deleted file mode 100644
index fbf5f61a39..0000000000
--- a/packages/ez-ipupdate/ez-ipupdate_3.0.10.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-# Angus Mackay's ez-ipupdate from www.ez-ipupdate.com
-DESCRIPTION = "A client for automatically updating your EZ-IP.net, justlinux.com, dhs.org, dyndns.org, ods.org, gnudip.cheapnet.net, tzo.com, easydns.com dynamic hostname parameters. Includes daemon support that only sends updates if your IP address changes."
-HOMEPAGE = "http://www.ez-ipupdate.com/"
-SECTION = "console/network"
-PRIORITY = "optional"
-LICENSE = "GPL"
-PR = "r0"
-
-SRC_URI = "http://www.ez-ipupdate.com/dist/ez-ipupdate-${PV}.tar.gz"
-SRC_URI += "file://configure.patch;patch=1"
-SRC_URI += "file://conffile.patch;patch=1"
-SRC_URI += "file://zoneedit.patch;patch=1"
-SRC_URI += "file://init"
-SRC_URI += "file://ipupdate.conf"
-
-INITSCRIPT_NAME = "ipupdate"
-# No dependencies, so just go in at the standard level (20)
-INITSCRIPT_PARAMS = "defaults"
-
-# The configuration file must be editted...
-CONFFILES_${PN} = "${sysconfdir}/ipupdate.conf"
-
-inherit autotools update-rc.d
-
-PACKAGES += "ez-ipupdate"
-
-do_install_append() {
- install -d "${D}${sysconfdir}/init.d"
- install -c -m 755 ${WORKDIR}/init "${D}${sysconfdir}/init.d/ipupdate"
- install -c -m 644 ${WORKDIR}/ipupdate.conf "${D}${sysconfdir}/ipupdate.conf"
-}
diff --git a/packages/ez-ipupdate/files/conffile.patch b/packages/ez-ipupdate/files/conffile.patch
deleted file mode 100644
index 41f8a0e73b..0000000000
--- a/packages/ez-ipupdate/files/conffile.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ez-ipupdate-3.0.10/conf_file.c.orig 2005-11-27 20:03:46.557322517 -0800
-+++ ez-ipupdate-3.0.10/conf_file.c 2005-11-27 20:03:15.519369422 -0800
-@@ -34,6 +34,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <errno.h>
-
- #include <conf_file.h>
-
diff --git a/packages/ez-ipupdate/files/configure.patch b/packages/ez-ipupdate/files/configure.patch
deleted file mode 100644
index e6a945e4b2..0000000000
--- a/packages/ez-ipupdate/files/configure.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ez-ipupdate-3.0.10/Makefile.am.orig 2005-11-27 15:24:05.857379643 -0800
-+++ ez-ipupdate-3.0.10/Makefile.am 2005-11-27 19:35:58.832379202 -0800
-@@ -1,7 +1,6 @@
-
- bin_PROGRAMS = ez-ipupdate
--ez_ipupdate_SOURCES = ez-ipupdate.c conf_file.c conf_file.h md5.c md5.h cache_file.c cache_file.h error.h pid_file.c pid_file.h dprintf.h @EXTRASRC@
--ez_ipupdate_LDADD = @EXTRAOBJ@
-+ez_ipupdate_SOURCES = ez-ipupdate.c conf_file.c conf_file.h md5.c md5.h cache_file.c cache_file.h error.h pid_file.c pid_file.h dprintf.h
-
- EXTRA_DIST = getpass.c ez-ipupdate.lsm example.conf example-pgpow.conf example-dhs.conf example-dyndns.conf example-ods.conf example-tzo.conf example-gnudip.conf example-easydns.conf example-justlinux.conf example-dyns.conf CHANGELOG mkbinary
-
diff --git a/packages/ez-ipupdate/files/init b/packages/ez-ipupdate/files/init
deleted file mode 100644
index 031c33c79b..0000000000
--- a/packages/ez-ipupdate/files/init
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/bin/sh
-#
-# ipupdate init.d script for ez-ipupdate
-#
-# You *must* create or update the /etc/ipupdate.conf file for
-# this to work
-CONF=/etc/ipupdate.conf
-PIDFILE=/var/run/ipupdate.pid
-test -x /usr/bin/ez-ipupdate -a -r "${CONF}" || exit 0
-if egrep '^service-type=<type of service>$' "${CONF}" >/dev/null
-then
- # conf file not editted
- exit 0
-fi
-
-case "$1" in
- start)
- echo -n "Starting ez-ipupdate: "
- start-stop-daemon --start -x /usr/bin/ez-ipupdate -- -c "${CONF}" -d -F "${PIDFILE}" "$@"
- echo "done"
- ;;
- stop)
- echo -n "Stopping ez-ipupdate: "
- start-stop-daemon --stop -s 3 -p "${PIDFILE}"
- echo "done"
- ;;
- restart)
- echo -n "Restarting ez-ipupdate: "
- start-stop-daemon --stop -s 3 -p "${PIDFILE}"
- start-stop-daemon --start -x /usr/bin/ez-ipupdate -- -c "${CONF}" -d -F "${PIDFILE}" "$@"
- echo "done"
- ;;
- force-reload|reload)
- # HUP causes a reload, a simple TERM causes the daemon
- # to wake up and re-update the IP address
- start-stop-daemon --stop -s 1 -p "${PIDFILE}"
- ;;
- *)
- echo "Usage: ipupdate { start | stop | restart | reload }" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/ez-ipupdate/files/ipupdate.conf b/packages/ez-ipupdate/files/ipupdate.conf
deleted file mode 100644
index cbba491ef6..0000000000
--- a/packages/ez-ipupdate/files/ipupdate.conf
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/usr/bin/ez-ipupdate -c
-#
-# example config file for ez-ipupdate
-#
-# this file is actually executable!
-#
-#CHANGE this to the service name (ez-ipupdate --help for the list)
-service-type=<type of service>
-#CHANGE this to the user name and password on the service
-user=myuserid:mypassword
-#CHANGE this to the domain name to update
-host=mydomain.whatever.com
-#
-interface=eth0
-quiet
-#
-# other options:
-#address=<ip address>
-#cache-file=/etc/ez-ipupdate.cache.eth1
-#daemon
-#debug
-#foreground
-#host=<host>
-#interface=<interface>
-#mx=<mail exchanger>
-#retrys=<number of trys>
-#run-as-user=<user>
-#server=<server name>
-#timeout=<sec.millisec>
-#max-interval=<time in seconds>
-#notify-email=<email address>
-#period=<time between update attempts>
-#url=<url>
-#user=<user name>[:password]
-#wildcard
-#quiet
diff --git a/packages/ez-ipupdate/files/zoneedit.patch b/packages/ez-ipupdate/files/zoneedit.patch
deleted file mode 100644
index c9d4e4a2c1..0000000000
--- a/packages/ez-ipupdate/files/zoneedit.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ez-ipupdate-3.0.10/ez-ipupdate.c.orig 2005-11-27 22:59:39.149355269 -0800
-+++ ez-ipupdate-3.0.10/ez-ipupdate.c 2005-11-27 22:59:46.705830768 -0800
-@@ -3806,7 +3806,7 @@ int ZONEEDIT_update_entry(void)
- break;
-
- case 200:
-- if(strstr(buf, "<SUCCESS\n") != NULL)
-+ if(strstr(buf, "<SUCCESS ") != NULL)
- {
- if(!(options & OPT_QUIET))
- {