summaryrefslogtreecommitdiff
path: root/packages/enca/enca_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/enca/enca_1.9.bb')
-rw-r--r--packages/enca/enca_1.9.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/packages/enca/enca_1.9.bb b/packages/enca/enca_1.9.bb
index 8151c86865..7f84ebe4fe 100644
--- a/packages/enca/enca_1.9.bb
+++ b/packages/enca/enca_1.9.bb
@@ -3,21 +3,26 @@ LICENSE = "GPL2"
SECTION = "libs"
PRIORITY = "optional"
HOMEPAGE = "http://trific.ath.cx/software/enca/"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://trific.ath.cx/Ftp//enca/enca-${PV}.tar.bz2 \
file://configure-hack.patch;patch=1 \
- file://dont-run-tests.patch;patch=1 "
+ file://dont-run-tests.patch;patch=1 \
+ file://configure-remove-dumbness.patch;patch=1 \
+ file://makefile-remove-tools.patch;patch=1 "
inherit autotools
+EXTRA_OECONF="--with-libiconv-prefix=${STAGING_DIR}"
+
do_configure_append() {
sed -i s:-I/usr/include::g Makefile
sed -i s:-I/usr/include::g */Makefile
}
do_compile() {
- cd ${S}/tools && make CC="${BUILD_CC}" CFLAGS="-O2" CPPFLAGS=""
+ cd ${S}/tools && ${BUILD_CC} -o make_hash make_hash.c
+ cd ..
oe_runmake
}