summaryrefslogtreecommitdiff
path: root/packages/efl
diff options
context:
space:
mode:
Diffstat (limited to 'packages/efl')
-rw-r--r--packages/efl/e_20050810.bb2
-rw-r--r--packages/efl/ecore-native_0.9.9.013.bb2
-rw-r--r--packages/efl/ecore.inc3
-rw-r--r--packages/efl/edb-native_1.0.5.004.bb2
-rw-r--r--packages/efl/edb_1.0.5.004.bb4
-rw-r--r--packages/efl/edje-native_0.5.0.013.bb10
-rw-r--r--packages/efl/edje_0.5.0.013.bb8
-rw-r--r--packages/efl/embryo-native_0.9.1.013.bb5
-rw-r--r--packages/efl/embryo_0.9.1.013.bb1
-rw-r--r--packages/efl/emotion_0.0.1.004.bb2
-rw-r--r--packages/efl/engrave_20050810.bb3
-rw-r--r--packages/efl/epsilon_0.3.0.004.bb2
-rw-r--r--packages/efl/esmart_0.9.0.004.bb2
-rw-r--r--packages/efl/evas-native_0.9.9.013.bb2
-rw-r--r--packages/efl/evas.inc3
-rw-r--r--packages/efl/ewl_0.0.4.004.bb2
-rw-r--r--packages/efl/imlib2.inc1
17 files changed, 29 insertions, 25 deletions
diff --git a/packages/efl/e_20050810.bb b/packages/efl/e_20050810.bb
index 3451bd8d64..be10a5553a 100644
--- a/packages/efl/e_20050810.bb
+++ b/packages/efl/e_20050810.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Enlightenment Window Mananger Library"
-DEPENDS = "freetype eet evas-x11 ecore-x11 embryo imlib2-x11 edje-native edje"
+DEPENDS = "virtual/evas virtual/ecore edje eet embryo"
LICENSE = "MIT"
CVSDATE = "${PV}"
PR = "r0"
diff --git a/packages/efl/ecore-native_0.9.9.013.bb b/packages/efl/ecore-native_0.9.9.013.bb
index 30b6f78370..6968415d34 100644
--- a/packages/efl/ecore-native_0.9.9.013.bb
+++ b/packages/efl/ecore-native_0.9.9.013.bb
@@ -1,3 +1,3 @@
include ecore-fb_${PV}.bb
inherit native
-DEPENDS = "curl-native edb-native eet-native evas-native freetype-native"
+DEPENDS = "curl-native eet-native evas-native"
diff --git a/packages/efl/ecore.inc b/packages/efl/ecore.inc
index 38c64e4615..ecd5fef642 100644
--- a/packages/efl/ecore.inc
+++ b/packages/efl/ecore.inc
@@ -3,7 +3,8 @@ foundation libraries. It makes makes doing selections, drag and drop, event loop
timeouts and idle handlers fast, optimized, and convenient."
LEAD_SONAME = "libecore.so"
LICENSE = "MIT"
-DEPENDS = "curl edb eet virtual/evas freetype edb-native"
+# can also have openssl, dbus
+DEPENDS = "virtual/evas curl eet"
inherit efl
diff --git a/packages/efl/edb-native_1.0.5.004.bb b/packages/efl/edb-native_1.0.5.004.bb
index 234b0e05e5..d83a3b77c6 100644
--- a/packages/efl/edb-native_1.0.5.004.bb
+++ b/packages/efl/edb-native_1.0.5.004.bb
@@ -2,6 +2,8 @@ include edb_${PV}.bb
inherit native
DEPENDS = "zlib-native"
+EXTRA_OECONF += "--disable-gtk --disable-ncurses"
+
do_stage_append () {
install -m 0755 tools/.libs/edb_ed ${STAGING_BINDIR}
}
diff --git a/packages/efl/edb_1.0.5.004.bb b/packages/efl/edb_1.0.5.004.bb
index 2dace0cb07..0a04a42844 100644
--- a/packages/efl/edb_1.0.5.004.bb
+++ b/packages/efl/edb_1.0.5.004.bb
@@ -1,12 +1,10 @@
DESCRIPTION = "EDB is a database convenience library wrapped around the \
Berkeley DB 2.7.7 by Sleepycat Software."
-DEPENDS = "zlib"
+DEPENDS = "zlib ncurses gtk+"
LICENSE = "BSD"
PR = "r0"
inherit efl
-EXTRA_OECONF = "--disable-gtk --disable-ncurses"
-
libdirectory = "src"
diff --git a/packages/efl/edje-native_0.5.0.013.bb b/packages/efl/edje-native_0.5.0.013.bb
index 8f15b4edab..d09bc2aaf0 100644
--- a/packages/efl/edje-native_0.5.0.013.bb
+++ b/packages/efl/edje-native_0.5.0.013.bb
@@ -1,6 +1,6 @@
include edje_${PV}.bb
inherit native
-DEPENDS = "freetype-native evas-native ecore-native embryo-native eet-native edb-native imlib2-native"
+DEPENDS = "evas-native ecore-native eet-native embryo-native imlib2-native"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/edje"
EXTRA_OECONF = "--with-fb-only \
@@ -15,8 +15,8 @@ do_configure_prepend() {
}
do_stage_append() {
- for i in ${BINARIES}
- do
- ${HOST_SYS}-libtool --mode=install install -m 0755 src/bin/$i ${STAGING_BINDIR}
- done
+ edje_data_dir=`${STAGING_BINDIR}/edje-config-native --datadir`
+ # could also use ${STAGING_DATADIR}/edje/include
+ install -d $edje_data_dir/include
+ install -m 0644 data/include/edje.inc $edje_data_dir/include
}
diff --git a/packages/efl/edje_0.5.0.013.bb b/packages/efl/edje_0.5.0.013.bb
index 40c2002860..5cab345943 100644
--- a/packages/efl/edje_0.5.0.013.bb
+++ b/packages/efl/edje_0.5.0.013.bb
@@ -1,13 +1,13 @@
DESCRIPTION = "Edje is a complex graphical design & layout library."
-DEPENDS = "freetype virtual/evas virtual/ecore embryo eet edb edje-native"
+# can also install vim data files
+DEPENDS = "virtual/evas virtual/ecore eet embryo edje-native virtual/imlib2"
LICENSE = "MIT"
PR = "r0"
inherit efl
-EXTRA_OECONF = "--disable-edje-cc --enable-fb-only"
LEAD_SONAME = "libedje.so"
-libraries += "libedje_edit"
+FILES_${PN}-dev += "${bindir}"
-BINARIES = "edje edje_ls edje_test edje_cc edje_decc edje_thumb"
+RDEPENDS_${PN}-dev += "cpp" \ No newline at end of file
diff --git a/packages/efl/embryo-native_0.9.1.013.bb b/packages/efl/embryo-native_0.9.1.013.bb
index ba24e954bc..a33adb7bd2 100644
--- a/packages/efl/embryo-native_0.9.1.013.bb
+++ b/packages/efl/embryo-native_0.9.1.013.bb
@@ -2,5 +2,6 @@ include embryo_${PV}.bb
inherit native
do_stage_append() {
- ${HOST_SYS}-libtool --mode=install install -m 0755 src/bin/embryo_cc ${STAGING_BINDIR}
-}
+ install -d ${STAGING_DATADIR}/embryo/include
+ install -m 0644 include/default.inc ${STAGING_DATADIR}/embryo/include
+} \ No newline at end of file
diff --git a/packages/efl/embryo_0.9.1.013.bb b/packages/efl/embryo_0.9.1.013.bb
index ee193e5c4d..54f3ddabad 100644
--- a/packages/efl/embryo_0.9.1.013.bb
+++ b/packages/efl/embryo_0.9.1.013.bb
@@ -7,4 +7,3 @@ LICENSE = "MIT"
PR = "r0"
inherit efl
-
diff --git a/packages/efl/emotion_0.0.1.004.bb b/packages/efl/emotion_0.0.1.004.bb
index 9fe32ce26b..5ca5214b94 100644
--- a/packages/efl/emotion_0.0.1.004.bb
+++ b/packages/efl/emotion_0.0.1.004.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Emotion is a multimedia library based on libxine"
LICENSE = "MIT"
-DEPENDS = "libxine"
+DEPENDS = "eet virtual/evas edje virtual/ecore embryo libxine"
inherit efl
diff --git a/packages/efl/engrave_20050810.bb b/packages/efl/engrave_20050810.bb
index 13e68259a9..8ee284fb19 100644
--- a/packages/efl/engrave_20050810.bb
+++ b/packages/efl/engrave_20050810.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Engrave is an Edje Editing Library"
LICENSE = "MIT"
-DEPENDS = "jpeg edb ecore-x11 evas-x11 edje imlib2-x11"
+# also requires yacc and lex on host
+DEPENDS = "virtual/evas virtual/ecore"
inherit efl
diff --git a/packages/efl/epsilon_0.3.0.004.bb b/packages/efl/epsilon_0.3.0.004.bb
index d8dc08e11f..ab19043550 100644
--- a/packages/efl/epsilon_0.3.0.004.bb
+++ b/packages/efl/epsilon_0.3.0.004.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Epsilon is a flexable and powerful image thumbnailing library \
that is complient with the freedesktop.org Thumbnail Managing Standard."
LICENSE = "GPL"
-DEPENDS = "edje epeg libpng virtual/imlib2"
+DEPENDS = "virtual/imlib2 epeg libpng virtual/evas virtual/ecore perl-native edje"
inherit efl
diff --git a/packages/efl/esmart_0.9.0.004.bb b/packages/efl/esmart_0.9.0.004.bb
index 90b8aca6f9..beb936e37b 100644
--- a/packages/efl/esmart_0.9.0.004.bb
+++ b/packages/efl/esmart_0.9.0.004.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "ESmart is a collection of smart Evas objects"
LICENSE = "MIT"
-DEPENDS = "edje-native eet evas-x11 ecore-x11 epsilon embryo imlib2-x11 jpeg libtool"
+DEPENDS = "virtual/evas virtual/ecore virtual/imlib2 epsilon edje libtool"
PR = "r1"
inherit efl
diff --git a/packages/efl/evas-native_0.9.9.013.bb b/packages/efl/evas-native_0.9.9.013.bb
index a29967a051..3eaa12cf9e 100644
--- a/packages/efl/evas-native_0.9.9.013.bb
+++ b/packages/efl/evas-native_0.9.9.013.bb
@@ -1,3 +1,3 @@
include evas-fb_${PV}.bb
inherit native
-DEPENDS = "freetype-native"
+DEPENDS = "freetype-native libpng-native jpeg-native eet-native edb-native"
diff --git a/packages/efl/evas.inc b/packages/efl/evas.inc
index 0588d8e28c..60f60f3c82 100644
--- a/packages/efl/evas.inc
+++ b/packages/efl/evas.inc
@@ -3,7 +3,8 @@ anti-aliased text, smooth super and sub-images, alpha-blend, as well as drop \
down to using normal X11 primitives such as pixmaps, lines and rectangles if \
your CPU or graphics hardware are too slow."
LICENSE = "MIT"
-DEPENDS = "libpng jpeg edb eet freetype"
+# can also depend on valgrind (?)
+DEPENDS = "freetype libpng jpeg eet edb"
inherit efl
diff --git a/packages/efl/ewl_0.0.4.004.bb b/packages/efl/ewl_0.0.4.004.bb
index 36d8c5c860..92db160a25 100644
--- a/packages/efl/ewl_0.0.4.004.bb
+++ b/packages/efl/ewl_0.0.4.004.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "The Enlightened Widget Library, \
a simple-to-use general purpose widget library based on the enlightenment foundation libraries."
-DEPENDS = "edb eet virtual/evas virtual/ecore etox edje"
+DEPENDS = "edb virtual/evas virtual/ecore edje emotion"
LICENSE = "MIT"
PR = "r0"
diff --git a/packages/efl/imlib2.inc b/packages/efl/imlib2.inc
index b4a2f267fc..a6982e21c7 100644
--- a/packages/efl/imlib2.inc
+++ b/packages/efl/imlib2.inc
@@ -1,5 +1,6 @@
DESCRIPTION = "A graphic library for file loading, saving, rendering, and manipulation."
LICENSE = "BSD"
+# can also depend on tiff34, ungif or gif, z, bz2, id3tag
DEPENDS = "freetype libpng jpeg"
inherit efl