summaryrefslogtreecommitdiff
path: root/packages/efl1/epdf/fix-plugin-path-check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/efl1/epdf/fix-plugin-path-check.patch')
-rw-r--r--packages/efl1/epdf/fix-plugin-path-check.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/efl1/epdf/fix-plugin-path-check.patch b/packages/efl1/epdf/fix-plugin-path-check.patch
new file mode 100644
index 0000000000..dd5469c286
--- /dev/null
+++ b/packages/efl1/epdf/fix-plugin-path-check.patch
@@ -0,0 +1,24 @@
+Index: epdf/configure.in
+===================================================================
+--- epdf.orig/configure.in
++++ epdf/configure.in
+@@ -27,8 +27,8 @@ PKG_CHECK_MODULES(EWL,
+ [
+ have_ewl="yes"
+ requirements="$requirements ewl"
+- EWL_TEST_LIBS_DIR="`$PKG_CONFIG --variable=testsdir ewl`"
+- EWL_TEST_SOURCE_DIR="`$PKG_CONFIG --variable=testssrcdir ewl`"
++ EWL_TEST_LIBS_DIR="/usr/lib/ewl/tests/"
++ EWL_TEST_SOURCE_DIR="/usr/share/ewl/examples/"
+ AC_SUBST(EWL_TEST_LIBS_DIR)
+ AC_SUBST(EWL_TEST_SOURCE_DIR)
+ ],
+@@ -55,7 +55,7 @@ PKG_CHECK_MODULES(EPSILON,
+ [
+ have_epsilon="yes"
+ requirements="$requirements epsilon imlib2"
+- EPSILON_PLUGINS_DIR="`$PKG_CONFIG --variable=pluginsdir epsilon`"
++ EPSILON_PLUGINS_DIR="/usr/lib/epsilon/plugins/"
+ AC_SUBST(EPSILON_PLUGINS_DIR)
+ ],
+ [