summaryrefslogtreecommitdiff
path: root/packages/efl/ewl_0.0.4.007.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/efl/ewl_0.0.4.007.bb')
-rw-r--r--packages/efl/ewl_0.0.4.007.bb19
1 files changed, 13 insertions, 6 deletions
diff --git a/packages/efl/ewl_0.0.4.007.bb b/packages/efl/ewl_0.0.4.007.bb
index 85b85e0c05..e89b668b93 100644
--- a/packages/efl/ewl_0.0.4.007.bb
+++ b/packages/efl/ewl_0.0.4.007.bb
@@ -1,18 +1,26 @@
DESCRIPTION = "The Enlightened Widget Library, \
a simple-to-use general purpose widget library based on the enlightenment foundation libraries."
# as of recent CVS HEAD, ewl no longer needs etox and no longer needs edb
-DEPENDS = "edb virtual/evas virtual/ecore edje emotion"
-RDEPENDS += "libewl-themes"
+DEPENDS = "edb virtual/evas virtual/ecore edje"
+# emotion
+RDEPENDS += "ewl-themes"
LICENSE = "MIT"
PR = "r1"
inherit efl
SRC_URI += "file://ewl-configure.patch;patch=1 \
- file://fix-ecore.patch;patch=1 \
- file://ecore-flags.patch;patch=1 \
file://no-examples.patch;patch=1 \
- file://minmax.patch;patch=1"
+ file://minmax.patch;patch=1 \
+ ${E_CVS};module=e17/libs/evas/m4;date=20060501"
+
+do_configure_prepend() {
+ if [ -e "${WORKDIR}/m4" ]; then
+ install -d "${S}/m4"
+ install "${WORKDIR}/m4/"*.m4 "${S}/m4"
+ aclocal -I m4
+ fi
+}
do_stage_append() {
for i in src/lib/ewl_*.h
@@ -20,4 +28,3 @@ do_stage_append() {
install -m 0644 $i ${STAGING_INCDIR}
done
}
-