summaryrefslogtreecommitdiff
path: root/packages/efl/ewl_0.0.4.007.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/efl/ewl_0.0.4.007.bb')
-rw-r--r--packages/efl/ewl_0.0.4.007.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/efl/ewl_0.0.4.007.bb b/packages/efl/ewl_0.0.4.007.bb
new file mode 100644
index 0000000000..e89b668b93
--- /dev/null
+++ b/packages/efl/ewl_0.0.4.007.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "The Enlightened Widget Library, \
+a simple-to-use general purpose widget library based on the enlightenment foundation libraries."
+# as of recent CVS HEAD, ewl no longer needs etox and no longer needs edb
+DEPENDS = "edb virtual/evas virtual/ecore edje"
+# emotion
+RDEPENDS += "ewl-themes"
+LICENSE = "MIT"
+PR = "r1"
+
+inherit efl
+
+SRC_URI += "file://ewl-configure.patch;patch=1 \
+ file://no-examples.patch;patch=1 \
+ file://minmax.patch;patch=1 \
+ ${E_CVS};module=e17/libs/evas/m4;date=20060501"
+
+do_configure_prepend() {
+ if [ -e "${WORKDIR}/m4" ]; then
+ install -d "${S}/m4"
+ install "${WORKDIR}/m4/"*.m4 "${S}/m4"
+ aclocal -I m4
+ fi
+}
+
+do_stage_append() {
+ for i in src/lib/ewl_*.h
+ do
+ install -m 0644 $i ${STAGING_INCDIR}
+ done
+}