summaryrefslogtreecommitdiff
path: root/packages/e17
diff options
context:
space:
mode:
Diffstat (limited to 'packages/e17')
-rw-r--r--packages/e17/eclair_20050810.bb4
-rw-r--r--packages/e17/entice_20050810.bb4
-rw-r--r--packages/e17/entrance/Sessions/.mtn2git_empty0
-rw-r--r--packages/e17/entrance/Sessions/Enlightenment4
-rw-r--r--packages/e17/entrance/Xinit.d/.mtn2git_empty0
-rw-r--r--packages/e17/entrance/Xinit.d/50-calibrate7
-rw-r--r--packages/e17/entrance/Xinit.d/99-Entrance4
-rw-r--r--packages/e17/entrance/config-db.patch15
-rw-r--r--packages/e17/entrance_20050810.bb23
-rw-r--r--packages/e17/examine_20050810.bb2
10 files changed, 48 insertions, 15 deletions
diff --git a/packages/e17/eclair_20050810.bb b/packages/e17/eclair_20050810.bb
index ba1e8fb10d..62385e141c 100644
--- a/packages/e17/eclair_20050810.bb
+++ b/packages/e17/eclair_20050810.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Eclair is the E17 multi media player"
SECTION = "e/apps"
-DEPENDS = "freetype eet virtual/evas virtual/ecore embryo virtual/imlib2 edje-native edje emotion libxml2 sqlite3 taglibc"
+DEPENDS = "evas-x11 ecore-x11 embryo imlib2-x11 edje-native edje libxine-x11 emotion esmart libxml2 sqlite3 taglibc"
LICENSE = "MIT"
HOMEPAGE = "http://www.enlightenment.org"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
@@ -12,8 +12,6 @@ S = "${WORKDIR}/eclair"
inherit autotools
-BROKEN = "1"
-
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc"
FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir} ${sbindir}"
diff --git a/packages/e17/entice_20050810.bb b/packages/e17/entice_20050810.bb
index 667d3f4da8..094944ead4 100644
--- a/packages/e17/entice_20050810.bb
+++ b/packages/e17/entice_20050810.bb
@@ -1,12 +1,12 @@
DESCRIPTION = "Entice is the E17 picture viewer"
SECTION = "e/apps"
# can also depend on GIMP for editing
-DEPENDS = "virtual/evas edb virtual/ecore edje"
+DEPENDS = "edb evas-x11 ecore-x11 edje epsilon esmart"
LICENSE = "MIT"
HOMEPAGE = "http://www.enlightenment.org"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
CVSDATE = "${PV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/entice"
S = "${WORKDIR}/entice"
diff --git a/packages/e17/entrance/Sessions/.mtn2git_empty b/packages/e17/entrance/Sessions/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/e17/entrance/Sessions/.mtn2git_empty
diff --git a/packages/e17/entrance/Sessions/Enlightenment b/packages/e17/entrance/Sessions/Enlightenment
new file mode 100644
index 0000000000..4d33bbb2e9
--- /dev/null
+++ b/packages/e17/entrance/Sessions/Enlightenment
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+enlightenment
+
diff --git a/packages/e17/entrance/Xinit.d/.mtn2git_empty b/packages/e17/entrance/Xinit.d/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/e17/entrance/Xinit.d/.mtn2git_empty
diff --git a/packages/e17/entrance/Xinit.d/50-calibrate b/packages/e17/entrance/Xinit.d/50-calibrate
new file mode 100644
index 0000000000..922b335c85
--- /dev/null
+++ b/packages/e17/entrance/Xinit.d/50-calibrate
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if ! test -e /etc/pointercal
+then
+ xtscal
+fi
+
diff --git a/packages/e17/entrance/Xinit.d/99-Entrance b/packages/e17/entrance/Xinit.d/99-Entrance
new file mode 100644
index 0000000000..297cc909fe
--- /dev/null
+++ b/packages/e17/entrance/Xinit.d/99-Entrance
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+entrance
+
diff --git a/packages/e17/entrance/config-db.patch b/packages/e17/entrance/config-db.patch
index 5e965057ba..f326ac50c9 100644
--- a/packages/e17/entrance/config-db.patch
+++ b/packages/e17/entrance/config-db.patch
@@ -1,15 +1,22 @@
---- entrance/data/config/build_config.sh.in~ 2005-08-13 02:56:11.000000000 -0700
-+++ entrance/data/config/build_config.sh.in 2005-08-13 02:56:35.000000000 -0700
+--- entrance/data/config/build_config.sh.in.orig 2005-08-14 18:19:30.912299673 +0200
++++ entrance/data/config/build_config.sh.in 2005-08-14 18:21:36.309692562 +0200
@@ -3,7 +3,7 @@
rm -f $DB
# set auth to 1 for pam, 2 for shadow
-edb_ed $DB add /entrance/auth int @auth_mode@
-+edb_ed $DB add /entrance/auth int 0
++edb_ed $DB add /entrance/auth int 2
# uncomment the below to enable experimental OpenGL hardware acceleration
#edb_ed $DB add /entrance/engine int 1
-@@ -25,25 +25,25 @@
+@@ -19,31 +19,31 @@
+ #edb_ed $DB add /entrance/fonts/1/str str "/usr/X11R6/lib/X11/fonts/Truetype/"
+ edb_ed $DB add /entrance/greeting/before str "Welcome to "
+ edb_ed $DB add /entrance/greeting/after str ""
+-edb_ed $DB add /entrance/session/count int 8
++edb_ed $DB add /entrance/session/count int 4
+ edb_ed $DB add /entrance/session/0/session str "default"
+ edb_ed $DB add /entrance/session/0/title str "Default"
edb_ed $DB add /entrance/session/0/icon str "default.png"
edb_ed $DB add /entrance/session/1/icon str "enlightenment.png"
edb_ed $DB add /entrance/session/1/title str "Enlightenment"
diff --git a/packages/e17/entrance_20050810.bb b/packages/e17/entrance_20050810.bb
index 251698c233..de00734985 100644
--- a/packages/e17/entrance_20050810.bb
+++ b/packages/e17/entrance_20050810.bb
@@ -2,18 +2,21 @@ DESCRIPTION = "Entrace is the Enlightenment login manager"
SECTION = "e/apps"
LICENSE = "MIT"
# can also use pam and crypt
-DEPENDS = "edb evas-x11 ecore-x11 edje esmart"
-RDEPENDS += "bash"
+DEPENDS = "edb evas-x11 ecore-x11 edje esmart gpe-dm"
+RDEPENDS += "bash gpe-dm"
HOMEPAGE = "http://www.enlightenment.org"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
CVSDATE = "${PV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/entrance \
file://longer-sleep.patch;patch=1 \
file://Xserver.patch;patch=1 \
file://config-db.patch;patch=1 \
- file://allow-missing-xsession.patch;patch=1"
+ file://allow-missing-xsession.patch;patch=1 \
+ file://Xinit.d \
+ file://Sessions"
+
S = "${WORKDIR}/entrance"
inherit autotools
@@ -21,4 +24,14 @@ inherit autotools
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
--with-xsession=/etc/X11/Xsession"
-FILES += "${datadir}" \ No newline at end of file
+FILES += "${datadir}"
+
+do_install_append() {
+ install -d ${D}/etc/X11/Xinit.d
+ install -d ${D}/etc/X11/Xsession.d
+ install -d ${D}/etc/X11/Sessions
+
+ install -m 755 ${WORKDIR}/Xinit.d/* ${D}/etc/X11/Xinit.d
+ install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
+
+}
diff --git a/packages/e17/examine_20050810.bb b/packages/e17/examine_20050810.bb
index 6e79fd946f..244bf2bcaf 100644
--- a/packages/e17/examine_20050810.bb
+++ b/packages/e17/examine_20050810.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "examine, the program configurator"
DEPENDS = "virtual/ecore ewl"
LICENSE = "MIT"
-SECTION = "e"
+SECTION = "e/apps"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
PR = "r0"
CVSDATE = "${PV}"