summaryrefslogtreecommitdiff
path: root/packages/e17
diff options
context:
space:
mode:
Diffstat (limited to 'packages/e17')
-rw-r--r--packages/e17/e-wm/Xsession.d/.mtn2git_empty0
-rw-r--r--packages/e17/e-wm/Xsession.d/98enlightenment3
-rw-r--r--packages/e17/e-wm/add-menu-autoscroll-options.patch207
-rw-r--r--packages/e17/e-wm/fudge-menu-autoscroll.patch63
-rw-r--r--packages/e17/e-wm_20050810.bb12
-rw-r--r--packages/e17/e17genmenu_2.0.2.bb23
-rw-r--r--packages/e17/entrance/Xinit.d/50-calibrate7
-rw-r--r--packages/e17/entrance/Xinit.d/99entrance (renamed from packages/e17/entrance/Xinit.d/99-Entrance)0
-rw-r--r--packages/e17/entrance_20050810.bb11
-rw-r--r--packages/e17/evidence_20050810.bb42
10 files changed, 291 insertions, 77 deletions
diff --git a/packages/e17/e-wm/Xsession.d/.mtn2git_empty b/packages/e17/e-wm/Xsession.d/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/e17/e-wm/Xsession.d/.mtn2git_empty
diff --git a/packages/e17/e-wm/Xsession.d/98enlightenment b/packages/e17/e-wm/Xsession.d/98enlightenment
new file mode 100644
index 0000000000..65f46284a9
--- /dev/null
+++ b/packages/e17/e-wm/Xsession.d/98enlightenment
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec enlightenment \ No newline at end of file
diff --git a/packages/e17/e-wm/add-menu-autoscroll-options.patch b/packages/e17/e-wm/add-menu-autoscroll-options.patch
new file mode 100644
index 0000000000..79bcad8e44
--- /dev/null
+++ b/packages/e17/e-wm/add-menu-autoscroll-options.patch
@@ -0,0 +1,207 @@
+diff -Nur e~/src/bin/e_config.c e/src/bin/e_config.c
+--- e~/src/bin/e_config.c 2005-08-05 21:12:17.000000000 -0700
++++ e/src/bin/e_config.c 2005-08-16 13:55:06.000000000 -0700
+@@ -298,6 +298,8 @@
+ E_CONFIG_VAL(D, T, resize_info_follows, INT); /**/
+ E_CONFIG_VAL(D, T, focus_last_focused_per_desktop, INT); /**/
+ E_CONFIG_VAL(D, T, focus_revert_on_hide_or_close, INT); /**/
++ E_CONFIG_VAL(D, T, menu_autoscroll_margin, INT); /**/
++ E_CONFIG_VAL(D, T, menu_autoscroll_cursor_margin, INT); /**/
+
+ e_config = e_config_domain_load("e", _e_config_edd);
+ if (e_config)
+@@ -403,6 +405,8 @@
+ e_config->resize_info_follows = 1;
+ e_config->focus_last_focused_per_desktop = 1;
+ e_config->focus_revert_on_hide_or_close = 1;
++ e_config->menu_autoscroll_margin = 10;
++ e_config->menu_autoscroll_cursor_margin = 15;
+
+ {
+ E_Config_Module *em;
+@@ -959,6 +963,8 @@
+ E_CONFIG_LIMIT(e_config->resize_info_follows, 0, 1);
+ E_CONFIG_LIMIT(e_config->focus_last_focused_per_desktop, 0, 1);
+ E_CONFIG_LIMIT(e_config->focus_revert_on_hide_or_close, 0, 1);
++ E_CONFIG_LIMIT(e_config->menu_autoscroll_margin, 0, 50);
++ E_CONFIG_LIMIT(e_config->menu_autoscroll_cursor_margin, 0, 50);
+
+ /* apply lang config - exception because config is loaded after intl setup */
+
+diff -Nur e~/src/bin/e_config.h e/src/bin/e_config.h
+--- e~/src/bin/e_config.h 2005-08-05 21:12:18.000000000 -0700
++++ e/src/bin/e_config.h 2005-08-16 13:55:06.000000000 -0700
+@@ -142,6 +142,8 @@
+ int resize_info_follows;
+ int focus_last_focused_per_desktop;
+ int focus_revert_on_hide_or_close;
++ int menu_autoscroll_margin;
++ int menu_autoscroll_cursor_margin;
+ };
+
+ struct _E_Config_Module
+diff -Nur e~/src/bin/e_ipc_handlers.h e/src/bin/e_ipc_handlers.h
+--- e~/src/bin/e_ipc_handlers.h 2005-08-09 21:52:07.000000000 -0700
++++ e/src/bin/e_ipc_handlers.h 2005-08-16 14:01:38.000000000 -0700
+@@ -4592,3 +4592,84 @@
+ #if 0
+ }
+ #endif
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_MARGIN_SET
++#if (TYPE == E_REMOTE_OPTIONS)
++ OP("-menu-autoscroll-margin-set", 1, "Set the distance from the edge of the screen the menu will autoscroll to", 0, HDL)
++#elif (TYPE == E_REMOTE_OUT)
++ REQ_INT(atoi(params[0]), HDL);
++#elif (TYPE == E_WM_IN)
++ START_INT(value, HDL);
++ e_config->menu_autoscroll_margin = value;
++ E_CONFIG_LIMIT(e_config->menu_autoscroll_margin, 0, 50);
++ SAVE;
++ END_INT;
++#elif (TYPE == E_REMOTE_IN)
++#endif
++#undef HDL
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_MARGIN_GET
++#if (TYPE == E_REMOTE_OPTIONS)
++ OP("-menu-autoscroll-margin-get", 0, "Get the distance from the edge of the screen the menu will autoscroll to", 1, HDL)
++#elif (TYPE == E_REMOTE_OUT)
++ REQ_NULL(HDL)
++#elif (TYPE == E_WM_IN)
++ SEND_INT(e_config->menu_autoscroll_margin, E_IPC_OP_MENU_AUTOSCROLL_MARGIN_GET_REPLY, HDL);
++#elif (TYPE == E_REMOTE_IN)
++#endif
++#undef HDL
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_MARGIN_GET_REPLY
++#if (TYPE == E_REMOTE_OPTIONS)
++#elif (TYPE == E_REMOTE_OUT)
++#elif (TYPE == E_WM_IN)
++#elif (TYPE == E_REMOTE_IN)
++ START_INT(val, HDL)
++ printf("REPLY: %i\n", val);
++ END_INT;
++#endif
++#undef HDL
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_SET
++#if (TYPE == E_REMOTE_OPTIONS)
++ OP("-menu-autoscroll-cursor-margin-set", 1, "Set the distance from the edge of the screen the cursor needs to be to start menu autoscrolling", 0, HDL)
++#elif (TYPE == E_REMOTE_OUT)
++ REQ_INT(atoi(params[0]), HDL);
++#elif (TYPE == E_WM_IN)
++ START_INT(value, HDL);
++ e_config->menu_autoscroll_cursor_margin = value;
++ E_CONFIG_LIMIT(e_config->menu_autoscroll_cursor_margin, 0, 50);
++ // e_zone_update_flip_all();
++ SAVE;
++ END_INT;
++#elif (TYPE == E_REMOTE_IN)
++#endif
++#undef HDL
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_GET
++#if (TYPE == E_REMOTE_OPTIONS)
++ OP("-menu-autoscroll-cursor-margin-get", 0, "Get the distance from the edge of the screen the cursor needs to be to start menu autoscrolling", 1, HDL)
++#elif (TYPE == E_REMOTE_OUT)
++ REQ_NULL(HDL)
++#elif (TYPE == E_WM_IN)
++ SEND_INT(e_config->menu_autoscroll_cursor_margin, E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_GET_REPLY, HDL);
++#elif (TYPE == E_REMOTE_IN)
++#endif
++#undef HDL
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_GET_REPLY
++#if (TYPE == E_REMOTE_OPTIONS)
++#elif (TYPE == E_REMOTE_OUT)
++#elif (TYPE == E_WM_IN)
++#elif (TYPE == E_REMOTE_IN)
++ START_INT(val, HDL)
++ printf("REPLY: %i\n", val);
++ END_INT;
++#endif
++#undef HDL
+diff -Nur e~/src/bin/e_ipc_handlers_list.h e/src/bin/e_ipc_handlers_list.h
+--- e~/src/bin/e_ipc_handlers_list.h 2005-08-05 21:00:03.000000000 -0700
++++ e/src/bin/e_ipc_handlers_list.h 2005-08-16 13:55:06.000000000 -0700
+@@ -222,3 +222,9 @@
+ #define E_IPC_OP_DESKTOP_NAME_DEL 222
+ #define E_IPC_OP_DESKTOP_NAME_LIST 223
+ #define E_IPC_OP_DESKTOP_NAME_LIST_REPLY 224
++#define E_IPC_OP_MENU_AUTOSCROLL_MARGIN_SET 225
++#define E_IPC_OP_MENU_AUTOSCROLL_MARGIN_GET 226
++#define E_IPC_OP_MENU_AUTOSCROLL_MARGIN_GET_REPLY 227
++#define E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_SET 228
++#define E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_GET 229
++#define E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_GET_REPLY 230
+diff -Nur e~/src/bin/e_menu.c e/src/bin/e_menu.c
+--- e~/src/bin/e_menu.c 2005-07-25 02:55:44.000000000 -0700
++++ e/src/bin/e_menu.c 2005-08-16 13:55:06.000000000 -0700
+@@ -1968,24 +1968,24 @@
+ E_Menu *m;
+
+ m = l->data;
+- if (m->cur.x < m->zone->x)
++ if (m->cur.x < m->zone->x + e_config->menu_autoscroll_margin)
+ {
+- i = m->zone->x - m->cur.x;
++ i = m->zone->x - m->cur.x + e_config->menu_autoscroll_margin;
+ if (i > outl) outl = i;
+ }
+- if (m->cur.y < m->zone->y)
++ if (m->cur.y < m->zone->y + e_config->menu_autoscroll_margin)
+ {
+- i = m->zone->y - m->cur.y;
++ i = m->zone->y - m->cur.y + e_config->menu_autoscroll_margin;
+ if (i > outt) outt = i;
+ }
+- if ((m->cur.x + m->cur.w) > (m->zone->w))
++ if ((m->cur.x + m->cur.w) > (m->zone->w - e_config->menu_autoscroll_margin))
+ {
+- i = m->cur.x + m->cur.w - (m->zone->x + m->zone->w);
++ i = m->cur.x + m->cur.w - (m->zone->x + m->zone->w - e_config->menu_autoscroll_margin);
+ if (i > outr) outr = i;
+ }
+- if ((m->cur.y + m->cur.h) > (m->zone->h))
++ if ((m->cur.y + m->cur.h) > (m->zone->h - e_config->menu_autoscroll_margin))
+ {
+- i = m->cur.y + m->cur.h - (m->zone->y + m->zone->h);
++ i = m->cur.y + m->cur.h - (m->zone->y + m->zone->h - e_config->menu_autoscroll_margin);
+ if (i > outb) outb = i;
+ }
+ }
+@@ -2029,11 +2029,11 @@
+ int autoscroll_x = 0;
+ int autoscroll_y = 0;
+
+- if (_e_menu_x == 0)
++ if (_e_menu_x - e_config->menu_autoscroll_cursor_margin <= 0)
+ {
+ if (_e_menu_outside_bounds_get(-1, 0)) autoscroll_x = -1;
+ }
+- if (_e_menu_y == 0)
++ if (_e_menu_y - e_config->menu_autoscroll_cursor_margin <= 0)
+ {
+ if (_e_menu_outside_bounds_get(0, -1)) autoscroll_y = -1;
+ }
+@@ -2044,11 +2044,11 @@
+ E_Menu *m;
+
+ m = _e_active_menus->data;
+- if (_e_menu_x == (m->zone->w - 1))
++ if (_e_menu_x + e_config->menu_autoscroll_cursor_margin >= (m->zone->w - 1))
+ {
+ if (_e_menu_outside_bounds_get(1, 0)) autoscroll_x = 1;
+ }
+- if (_e_menu_y == (m->zone->h - 1))
++ if (_e_menu_y + e_config->menu_autoscroll_cursor_margin >= (m->zone->h - 1))
+ {
+ if (_e_menu_outside_bounds_get(0, 1)) autoscroll_y = 1;
+ }
diff --git a/packages/e17/e-wm/fudge-menu-autoscroll.patch b/packages/e17/e-wm/fudge-menu-autoscroll.patch
deleted file mode 100644
index e2216986e2..0000000000
--- a/packages/e17/e-wm/fudge-menu-autoscroll.patch
+++ /dev/null
@@ -1,63 +0,0 @@
---- e/src/bin/e_menu.c~ 2005-08-15 23:09:53.000000000 -0700
-+++ e/src/bin/e_menu.c 2005-08-15 23:10:07.000000000 -0700
-@@ -1968,24 +1968,24 @@
- E_Menu *m;
-
- m = l->data;
-- if (m->cur.x < m->zone->x)
-+ if (m->cur.x < m->zone->x + 10)
- {
-- i = m->zone->x - m->cur.x;
-+ i = m->zone->x - m->cur.x + 10;
- if (i > outl) outl = i;
- }
-- if (m->cur.y < m->zone->y)
-+ if (m->cur.y < m->zone->y + 10)
- {
-- i = m->zone->y - m->cur.y;
-+ i = m->zone->y - m->cur.y + 10;
- if (i > outt) outt = i;
- }
-- if ((m->cur.x + m->cur.w) > (m->zone->w))
-+ if ((m->cur.x + m->cur.w) > (m->zone->w - 10))
- {
-- i = m->cur.x + m->cur.w - (m->zone->x + m->zone->w);
-+ i = m->cur.x + m->cur.w - (m->zone->x + m->zone->w - 10);
- if (i > outr) outr = i;
- }
-- if ((m->cur.y + m->cur.h) > (m->zone->h))
-+ if ((m->cur.y + m->cur.h) > (m->zone->h - 10))
- {
-- i = m->cur.y + m->cur.h - (m->zone->y + m->zone->h);
-+ i = m->cur.y + m->cur.h - (m->zone->y + m->zone->h - 10);
- if (i > outb) outb = i;
- }
- }
-@@ -2029,11 +2029,11 @@
- int autoscroll_x = 0;
- int autoscroll_y = 0;
-
-- if (_e_menu_x == 0)
-+ if (_e_menu_x - 10 <= 0)
- {
- if (_e_menu_outside_bounds_get(-1, 0)) autoscroll_x = -1;
- }
-- if (_e_menu_y == 0)
-+ if (_e_menu_y - 10 <= 0)
- {
- if (_e_menu_outside_bounds_get(0, -1)) autoscroll_y = -1;
- }
-@@ -2044,11 +2044,11 @@
- E_Menu *m;
-
- m = _e_active_menus->data;
-- if (_e_menu_x == (m->zone->w - 1))
-+ if (_e_menu_x + 10 >= (m->zone->w - 1))
- {
- if (_e_menu_outside_bounds_get(1, 0)) autoscroll_x = 1;
- }
-- if (_e_menu_y == (m->zone->h - 1))
-+ if (_e_menu_y + 10 >= (m->zone->h - 1))
- {
- if (_e_menu_outside_bounds_get(0, 1)) autoscroll_y = 1;
- }
diff --git a/packages/e17/e-wm_20050810.bb b/packages/e17/e-wm_20050810.bb
index b931751ec4..e0fa41311c 100644
--- a/packages/e17/e-wm_20050810.bb
+++ b/packages/e17/e-wm_20050810.bb
@@ -4,11 +4,12 @@ LICENSE = "MIT"
SECTION = "e/apps"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
CVSDATE = "${PV}"
-PR = "r0"
+PR = "r2"
SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/e \
+ file://Xsession.d/98enlightenment \
file://fix-configure.patch;patch=1 \
- file://fudge-menu-autoscroll.patch;patch=1"
+ file://add-menu-autoscroll-options.patch;patch=1"
S = "${WORKDIR}/e"
inherit autotools
@@ -24,4 +25,9 @@ EXTRA_OECONF = "--with-profile=${PROFILE} \
--x-includes=${STAGING_INCDIR}/X11 \
--x-libraries=${STAGING_LIBDIR}"
-FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir}"
+FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir}"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d
+ install -m 755 ${WORKDIR}/Xsession.d/98enlightenment ${D}/${sysconfdir}/X11/Xsession.d
+}
diff --git a/packages/e17/e17genmenu_2.0.2.bb b/packages/e17/e17genmenu_2.0.2.bb
new file mode 100644
index 0000000000..8b43e5995a
--- /dev/null
+++ b/packages/e17/e17genmenu_2.0.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Convert Gnome or KDE menus to e17 menus"
+SECTION = "e/utils"
+DEPENDS = "e virtual/ecore virtual/evas eet engrave"
+LICENSE = "GPL"
+HOMEPAGE = "http://sourceforge.net/projects/e17genmenu"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+PR = "r0"
+
+export EET_CONFIG = "${STAGING_BINDIR}/eet-config"
+export EVAS_CONFIG = "${STAGING_BINDIR}/evas-config"
+export ECORE_CONFIG = "${STAGING_BINDIR}/ecore-config"
+export ENGRAVE_CONFIG = "${STAGING_BINDIR}/engrave-config"
+export ENLIGHTENMENT_CONFIG = "${STAGING_BINDIR}/enlightenment-config"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/e17genmenu/e17genmenu-2.0.2.tar.gz"
+
+do_configure_prepend() {
+ find -type f | xargs sed -i 's:share/icons/%s/48x48/apps:share/pixmaps:'
+ find -type f | xargs sed -i 's:share/icons/hicolor/48x48/apps:share/pixmaps:'
+ find -type f | xargs sed -i 's:%s/share/pixmaps", GNOME_PREFIX, theme:%s/share/pixmaps", GNOME_PREFIX:'
+}
+
+inherit autotools
diff --git a/packages/e17/entrance/Xinit.d/50-calibrate b/packages/e17/entrance/Xinit.d/50-calibrate
deleted file mode 100644
index 922b335c85..0000000000
--- a/packages/e17/entrance/Xinit.d/50-calibrate
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-if ! test -e /etc/pointercal
-then
- xtscal
-fi
-
diff --git a/packages/e17/entrance/Xinit.d/99-Entrance b/packages/e17/entrance/Xinit.d/99entrance
index 297cc909fe..297cc909fe 100644
--- a/packages/e17/entrance/Xinit.d/99-Entrance
+++ b/packages/e17/entrance/Xinit.d/99entrance
diff --git a/packages/e17/entrance_20050810.bb b/packages/e17/entrance_20050810.bb
index af11e07fd5..e43fe9aff8 100644
--- a/packages/e17/entrance_20050810.bb
+++ b/packages/e17/entrance_20050810.bb
@@ -2,12 +2,12 @@ DESCRIPTION = "Entrace is the Enlightenment login manager"
SECTION = "e/apps"
LICENSE = "MIT"
# can also use pam and crypt
-DEPENDS = "edb evas-x11 ecore-x11 edje esmart gpe-dm"
-RDEPENDS += "bash gpe-dm"
+DEPENDS = "edb evas-x11 ecore-x11 edje esmart bash keylaunch detect-stylus x11-common"
+RDEPENDS += "bash keylaunch detect-stylus x11-common"
HOMEPAGE = "http://www.enlightenment.org"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
CVSDATE = "${PV}"
-PR = "r2"
+PR = "r3"
SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/entrance \
file://Xserver.patch;patch=1 \
@@ -20,7 +20,10 @@ SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/
S = "${WORKDIR}/entrance"
-inherit autotools
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "entrance"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
--with-xsession=/etc/X11/Xsession"
diff --git a/packages/e17/evidence_20050810.bb b/packages/e17/evidence_20050810.bb
new file mode 100644
index 0000000000..0950b590c6
--- /dev/null
+++ b/packages/e17/evidence_20050810.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "evidence, an enlightenemt file manager"
+LICENSE = "GPL"
+SECTION = "e"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+# can support dbus, avifile, libmpeg3
+DEPENDS = "pkgconfig gtk+ glib-2.0 ecore-x11 evas-x11 edb eet edje imlib2-x11 libpng epeg jpeg pcre curl taglib libvorbis libogg libxine-x11 emotion freetype"
+RDEPENDS += "examine"
+PR = "r0"
+CVSDATE = "${PV}"
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/evidence;module=evidence"
+S = "${WORKDIR}/evidence"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --enable-ecore \
+ --enable-ecore-ipc \
+ --enable-canvas-evas2 \
+ --enable-edje \
+ --enable-x \
+ --enable-tree-view \
+ --enable-icon-view \
+ --enable-browser-view \
+ --with-libxine=${STAGING_LIBDIR}"
+
+do_prepsources () {
+ make clean distclean || true
+}
+addtask prepsources after do_fetch before do_unpack
+
+do_compile_prepend() {
+ sed -i 's:LDFLAGS = :LDFLAGS = -L${STAGING_LIBDIR} :' ${S}/src/providers/vorbis/Makefile
+}
+
+export EET_CONFIG = "${STAGING_BINDIR}/eet-config"
+export EVAS_CONFIG = "${STAGING_BINDIR}/evas-config"
+export ECORE_CONFIG = "${STAGING_BINDIR}/ecore-config"
+export EMBRYO_CONFIG = "${STAGING_BINDIR}/embryo-config"
+export EDJE_CONFIG = "${STAGING_BINDIR}/edje-config"
+
+FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} /etc/* /usr/sbin/*"
+
+inherit autotools pkgconfig binconfig