summaryrefslogtreecommitdiff
path: root/packages/e17/engage_20050926.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/e17/engage_20050926.bb')
-rw-r--r--packages/e17/engage_20050926.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/e17/engage_20050926.bb b/packages/e17/engage_20050926.bb
new file mode 100644
index 0000000000..077858d8eb
--- /dev/null
+++ b/packages/e17/engage_20050926.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Engage is the E17 icon dock"
+DEPENDS = "evas-x11 ecore-x11 esmart-x11 imlib2-x11 edje ewl e"
+LICENSE = "MIT"
+SECTION = "e/apps"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+PR = "r2"
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=misc/engage \
+ file://no-local-includes.patch;patch=1"
+S = "${WORKDIR}/engage"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc"
+
+do_prepsources () {
+ make clean distclean || true
+}
+addtask prepsources after do_fetch before do_unpack
+
+FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir} ${sbindir}"
+