summaryrefslogtreecommitdiff
path: root/packages/dsplink/dsplink_1.50.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/dsplink/dsplink_1.50.bb')
-rw-r--r--packages/dsplink/dsplink_1.50.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/dsplink/dsplink_1.50.bb b/packages/dsplink/dsplink_1.50.bb
new file mode 100644
index 0000000000..a822cf1be4
--- /dev/null
+++ b/packages/dsplink/dsplink_1.50.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "DSP Link for TI ARM/DSP processors"
+
+DEPENDS = "virtual/kernel"
+
+PR = "r0"
+
+# Get dsplink tarball from TI website, place in sources and calculate
+# md5sum
+# https://www-a.ti.com/downloads/sds_support/targetcontent/link/index.html
+SRC_URI ="http://install.tarball.in.source.dir/dsplink_1_50.tar.gz \
+"
+
+S = "${WORKDIR}/dsplink_1_50/dsplink"
+
+# Needed for buildscripts
+export DSPLINK = "${S}"
+
+do_configure () {
+}
+
+do_compile () {
+sh ${S}/etc/host/scripts/Linux/buildmodule.sh
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+