summaryrefslogtreecommitdiff
path: root/packages/dsplink/dmai_1.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/dsplink/dmai_1.20.bb')
-rw-r--r--packages/dsplink/dmai_1.20.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/packages/dsplink/dmai_1.20.bb b/packages/dsplink/dmai_1.20.bb
new file mode 100644
index 0000000000..ea0ecca3ef
--- /dev/null
+++ b/packages/dsplink/dmai_1.20.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Davinci (and OMAP) Multimedia Application Interface"
+DEPENDS = "virtual/kernel codec-engine"
+LICENCE = "unknown"
+
+require ti-paths.inc
+
+# https://www-a.ti.com/downloads/sds_support/applications_packages/dmai/dmai_1_20_00_06/dmai_setuplinux_1_20_00_06.bin
+# Install the above link and put the dmai_1_20_00_06.tar.gz file in the same directory as this recipe
+SRC_URI = "file://dmai_1_20_00_06.tar.gz \
+ file://update-cpu-name.patch \
+ file://update-fb-display.patch \
+ file://update-v4l2-display.patch \
+ file://do-not-panic-on-mixer-failure.patch \
+ file://support-32bit-align.patch \
+ file://resizer-fix.patch \
+ file://built-with-angstrom.patch \
+ "
+
+S = "${WORKDIR}/dmai_1_20_00_06"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+TARGET = "all"
+TARGET_neuros-osd2 = " dm6446_al dm6446_db"
+TARGET_beagleboard = " o3530_al o3530_db"
+
+export CE_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine/cetools"
+
+do_compile() {
+ cd packages/ti/sdo/dmai
+ oe_runmake clean
+ oe_runmake ${TARGET}
+ cd packages/ti/sdo/dmai/apps
+ oe_runmake clean
+ oe_runmake ${TARGET}
+}
+
+do_install () {
+ oe_runmake install
+}
+
+do_stage () {
+ :
+}