summaryrefslogtreecommitdiff
path: root/packages/dsplink/codec-engine_2.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/dsplink/codec-engine_2.21.bb')
-rw-r--r--packages/dsplink/codec-engine_2.21.bb79
1 files changed, 9 insertions, 70 deletions
diff --git a/packages/dsplink/codec-engine_2.21.bb b/packages/dsplink/codec-engine_2.21.bb
index b300256a3a..7c81704604 100644
--- a/packages/dsplink/codec-engine_2.21.bb
+++ b/packages/dsplink/codec-engine_2.21.bb
@@ -1,3 +1,7 @@
+require dsplink.inc
+require lpm.inc
+require cmemk.inc
+
DESCRIPTION = "Codec Engine for TI ARM/DSP processors"
DEPENDS = "virtual/kernel perl-native"
@@ -6,19 +10,18 @@ RDEPENDS = "update-modules"
inherit module
# tconf from xdctools dislikes '.' in pwd :/
-PR = "r1"
+PR = "r2"
PV = "221"
# Get CE tarball from TI website, place in sources and calculate
# md5sum
# Look for tarball at https://www-a.ti.com/downloads/sds_support/targetcontent/CE/index.html
-SRC_URI = "http://install.tarball.in.source.dir/codec_engine_2_21_00_06.tar.gz \
+SRC_URI = "http://install.tarball.in.source.dir/codec_engine_2_21.tar.gz \
file://Makefile.dsplink \
- file://cmemk-fix-class-device-api.diff;patch=1 \
"
-S = "${WORKDIR}/codec_engine_2_21_00_06"
+S = "${WORKDIR}/codec_engine_2_21"
require ti-paths.inc
@@ -26,72 +29,8 @@ export DSPLINK="${S}/cetools/packages/dsplink"
PARALLEL_MAKE = ""
-do_configure () {
- # Run perl script to create appropriate makefiles (v1.60 and up)
- perl ${S}/cetools/packages/dsplink/config/bin/dsplinkcfg.pl --platform=${DSPLINKPLATFORM} --nodsp=1 --dspcfg_0=${DSPCFG} --dspos_0=DSPBIOS5XX --gppos=${GPPOS} --comps=ponslrm
-}
-
-do_compile() {
- unset DISPLAY
- sed -i -e s:armv7a:armv7-a:g make/Linux/omap3530_2.6.mk || true
-
- # export various settings to override the defaults in the makefiles
- export DSP_BASE_CGTOOLS=${TITOOLSDIR}/${TICGTOOLSDIR}
- export DSP_BASE_BIOS=${TITOOLSDIR}/${TIBIOSDIR}
- export DSP_BASE_RTDX=${TITOOLSDIR}/${TIBIOSDIR}/packages/ti/rtdx
- export GPPTOOL_DIR=${CROSS_DIR}
- export LINUXKERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR}
- export LINK_INSTALL_DIR=${DSPLINK}
- export VARIANT=${DSPLINKSOC}
- export PLATFORM=${DSPLINKPLATFORM}
- export BASE_TOOLCHAIN=${CROSS_DIR}
- export BASE_CGTOOLS=${BASE_TOOLCHAIN}/bin
- # 'OSINC_PLATFORM' is used in both the dsp and gpp sides...
- export OSINC_PLATFORM1=${CROSS_DIR}/lib/gcc/${TARGET_SYS}/$(${TARGET_PREFIX}gcc -dumpversion)/include
- export OSINC_TARGET=${BASE_TOOLCHAIN}/target/usr/include
-
- # 'ARCHIVER' is being used in the dsp side of the build as well as gpp
- export ARCHIVER_AR=${TARGET_PREFIX}ar
- export BASE_SABIOS=${DSP_BASE_BIOS}
-
- make -e -f ${WORKDIR}/Makefile.dsplink
-
- echo "MVTOOL_PREFIX=${TARGET_PREFIX}" > ${S}/Rules.make
- echo "UCTOOL_PREFIX=${TARGET_PREFIX}" >> ${S}/Rules.make
- echo "LINUXKERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR}" >> ${S}/Rules.make
-
- # Build the cmem kernel module
- # We unset CFLAGS because kernel modules need different ones, this is basically a verbatim copy of kernel.bbclass and module-base.bbclass
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- cd ${S}/cetools/packages/ti/sdo/linuxutils/cmem
-
- oe_runmake clean
- oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
- KERNEL_SRC=${STAGING_KERNEL_DIR} \
- KERNEL_VERSION=${KERNEL_VERSION} \
- CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
- AR="${KERNEL_AR}"
-
- # Build the DSP power manager kernel module
- cd ${S}/cetools/packages/ti/bios/power
-
- # Unpack all kernel sources for the DSP power manager module
- for dsp in $(ls | grep bld | awk -F, '{print $2}' | awk -F_ '{print $1}') ; do
- if ! [ -e $dsp ] ; then tar xf ti_bios_power,${dsp}_bld.tar ; fi
- done
-
- cd ${DSPPOWERSOC}/lpm
-
- unset LDFLAGS CFLAGS
- make KERNEL_PATH=${STAGING_KERNEL_DIR} \
- KERNEL_SRC=${STAGING_KERNEL_DIR} \
- KERNEL_DIR=${STAGING_KERNEL_DIR} \
- KERNEL_VERSION=${KERNEL_VERSION} \
- TOOL_PREFIX=${TARGET_PREFIX} \
- DSPLINK_REPO=${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ \
- CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
- AR="${KERNEL_AR}"
-
+# the include files on top define do_compile for the submodules
+do_compile_append() {
cd ${S}/examples
# export some more variable to point to external TI tools
# information is duplicated between the js and make based tools