summaryrefslogtreecommitdiff
path: root/packages/dnsmasq/dnsmasq_2.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/dnsmasq/dnsmasq_2.15.bb')
-rw-r--r--packages/dnsmasq/dnsmasq_2.15.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/dnsmasq/dnsmasq_2.15.bb b/packages/dnsmasq/dnsmasq_2.15.bb
index e69de29bb2..f349810eaa 100644
--- a/packages/dnsmasq/dnsmasq_2.15.bb
+++ b/packages/dnsmasq/dnsmasq_2.15.bb
@@ -0,0 +1,29 @@
+SECTION = "console/network"
+DESCRIPTION = "Dnsmasq is a lightweight, easy to configure DNS forwarder and DHCP server."
+HOMEPAGE = "http://www.thekelleys.org.uk/dnsmasq/doc.html"
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+PR = "r2"
+
+SRC_URI = "http://www.thekelleys.org.uk/dnsmasq/dnsmasq-${PV}.tar.gz \
+ file://init \
+ file://dnsmasq.conf"
+
+S = "${WORKDIR}/dnsmasq-${PV}"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "dnsmasq"
+INITSCRIPT_PARAMS = "defaults"
+
+do_install () {
+ oe_runmake "PREFIX=${D}/${prefix}" \
+ "BINDIR=${D}/${bindir}" \
+ "MANDIR=${D}/${mandir}" \
+ install
+ install -d ${D}/${sysconfdir}/ ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/dnsmasq.conf ${D}/${sysconfdir}/
+ install -m 755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/dnsmasq
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/dnsmasq.conf"