summaryrefslogtreecommitdiff
path: root/packages/dbus
diff options
context:
space:
mode:
Diffstat (limited to 'packages/dbus')
-rw-r--r--packages/dbus/dbus-1.0.3/fedora-compile-fix.patch18
-rw-r--r--packages/dbus/dbus-native_1.0.3.bb2
2 files changed, 20 insertions, 0 deletions
diff --git a/packages/dbus/dbus-1.0.3/fedora-compile-fix.patch b/packages/dbus/dbus-1.0.3/fedora-compile-fix.patch
new file mode 100644
index 0000000000..eac37f04dd
--- /dev/null
+++ b/packages/dbus/dbus-1.0.3/fedora-compile-fix.patch
@@ -0,0 +1,18 @@
+Do not fail with udrec being unknown and say we are using
+_GNU_SOURCE. This is needed for the libc/header/gcc combo
+fedora 9 is using. bits/socket.h has struct udrec #ifdefed
+with _GNU.
+
+Index: dbus-1.0.3/dbus/dbus-sysdeps-unix.c
+===================================================================
+--- dbus-1.0.3.orig/dbus/dbus-sysdeps-unix.c
++++ dbus-1.0.3/dbus/dbus-sysdeps-unix.c
+@@ -22,6 +22,8 @@
+ *
+ */
+
++#define _GNU_SOURCE
++
+ #include "dbus-internals.h"
+ #include "dbus-sysdeps.h"
+ #include "dbus-sysdeps-unix.h"
diff --git a/packages/dbus/dbus-native_1.0.3.bb b/packages/dbus/dbus-native_1.0.3.bb
index 195557b35b..8a4c6fee7d 100644
--- a/packages/dbus/dbus-native_1.0.3.bb
+++ b/packages/dbus/dbus-native_1.0.3.bb
@@ -1,5 +1,6 @@
require dbus.inc
+PR = "r1"
DEFAULT_PREFERENCE = "-1"
inherit native
@@ -11,6 +12,7 @@ SRC_URI = "\
http://freedesktop.org/software/dbus/releases/dbus/dbus-${PV}.tar.gz \
file://cross.patch;patch=1 \
file://tmpdir.patch;patch=1 \
+ file://fedora-compile-fix.patch;patch=1 \
file://dbus-1.init \
"