summaryrefslogtreecommitdiff
path: root/packages/cyrus-sasl/cyrus-sasl_2.1.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/cyrus-sasl/cyrus-sasl_2.1.19.bb')
-rw-r--r--packages/cyrus-sasl/cyrus-sasl_2.1.19.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/packages/cyrus-sasl/cyrus-sasl_2.1.19.bb b/packages/cyrus-sasl/cyrus-sasl_2.1.19.bb
index 37c8292595..19f1206f18 100644
--- a/packages/cyrus-sasl/cyrus-sasl_2.1.19.bb
+++ b/packages/cyrus-sasl/cyrus-sasl_2.1.19.bb
@@ -1,9 +1,11 @@
SECTION = "console/network"
-DEPENDS = "db3"
+DEPENDS = "db openssl"
DESCRIPTION = "Generic client/server library for SASL authentication."
LICENSE = "BSD"
+PR = "r2"
-SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-${PV}.tar.gz"
+SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-${PV}.tar.gz \
+ file://berkdb.m4.patch;patch=1"
inherit autotools
@@ -11,9 +13,13 @@ acpaths = "-I ${S}/cmulocal -I ${S}/config -I ."
CFLAGS_append = " -I${S}/include -I${S}/saslauthd/include"
EXTRA_OECONF = "--enable-shared --enable-static --with-dblib=berkeley \
--with-bdb-libdir=${STAGING_LIBDIR} \
- --with-bdb-incdir=${STAGING_INCDIR} \
+ --with-bdb-incdir=${STAGING_INCDIR}/db4 \
+ --without-pam \
--without-opie --without-des"
+FILES_${PN} += "${prefix}/lib/sasl2/*.so*"
+FILES_${PN}-dev += "${libdir}/sasl2/*.la ${libdir}/sasl2/*.a"
+
do_configure_prepend () {
rm -f acinclude.m4 config/libtool.m4
}
@@ -27,7 +33,7 @@ do_compile_prepend () {
do_stage () {
oe_libinstall -so -a -C lib libsasl2 ${STAGING_LIBDIR}
- install -d ${STAGING_LIBDIR}/sasl
+ install -d ${STAGING_LIBDIR}/sasl2
install -d ${STAGING_INCDIR}/sasl
install -m 0644 ${S}/include/hmac-md5.h ${STAGING_INCDIR}/sasl/
install -m 0644 ${S}/include/md5.h ${STAGING_INCDIR}/sasl/