summaryrefslogtreecommitdiff
path: root/packages/cpuburn/cpuburn_1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/cpuburn/cpuburn_1.4.bb')
-rw-r--r--packages/cpuburn/cpuburn_1.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/cpuburn/cpuburn_1.4.bb b/packages/cpuburn/cpuburn_1.4.bb
new file mode 100644
index 0000000000..cd43004aa7
--- /dev/null
+++ b/packages/cpuburn/cpuburn_1.4.bb
@@ -0,0 +1,26 @@
+# cpuburn OE build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="CPU testing utilities in optimized assembler for maximum loading P6, K7, K6, P5 chips"
+MAINTAINER = "Raymond Danks <raymondd@ia.amd.com>"
+HOMEPAGE="http://pages.sbcglobal.net/redelm/"
+LICENSE="GNU"
+
+SRC_URI="http://pages.sbcglobal.net/redelm/${PN}_1_4_tar.gz \
+ file://gcc_CC.patch;patch=1"
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ bb.build.exec_func('cpuburn_do_unpack', d)
+}
+
+cpuburn_do_unpack () {
+ tar xvf ${PN}_1_4_tar
+}
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+