summaryrefslogtreecommitdiff
path: root/packages/classpath
diff options
context:
space:
mode:
Diffstat (limited to 'packages/classpath')
-rw-r--r--packages/classpath/classpath-gtk_0.93.bb11
-rw-r--r--packages/classpath/classpath-gtk_cvs.bb26
-rw-r--r--packages/classpath/classpath-minimal-native_0.93.bb2
-rw-r--r--packages/classpath/classpath-minimal_0.90.bb11
-rw-r--r--packages/classpath/classpath.inc2
5 files changed, 11 insertions, 41 deletions
diff --git a/packages/classpath/classpath-gtk_0.93.bb b/packages/classpath/classpath-gtk_0.93.bb
index 137ee8ffb2..a3b39d92f8 100644
--- a/packages/classpath/classpath-gtk_0.93.bb
+++ b/packages/classpath/classpath-gtk_0.93.bb
@@ -4,15 +4,6 @@ DEPENDS = "glib-2.0 gtk+ cairo gconf libart-lgpl pango libxtst jikes-native zip-
RDEPENDS_${PN} = "classpath-common (>= ${PV})"
RCONFLICTS_${PN} = "classpath-minimal"
-SRC_URI += "file://gconf_version.patch;patch=1"
+SRC_URI += "file://disable-automake-checks-v2.patch;patch=1"
EXTRA_OECONF = "--with-jikes --disable-plugin --disable-dssi"
-
-PACKAGES = "classpath-dev classpath-doc classpath-common classpath-examples classpath-tools ${PN}"
-
-FILES_classpath-doc = "${datadir}/info"
-FILES_classpath-dev = "${includedir}"
-FILES_${PN} = "${libdir} ${bindir}"
-FILES_classpath-common = "${datadir}/classpath/glibj.zip"
-FILES_classpath-examples = "${datadir}/classpath/examples"
-FILES_classpath-tools = "${datadir}/classpath/tools.zip"
diff --git a/packages/classpath/classpath-gtk_cvs.bb b/packages/classpath/classpath-gtk_cvs.bb
index 53f494ab15..18d79decae 100644
--- a/packages/classpath/classpath-gtk_cvs.bb
+++ b/packages/classpath/classpath-gtk_cvs.bb
@@ -1,14 +1,12 @@
-DESCRIPTION = "GNU Classpath standard Java libraries"
-HOMEPAGE = "http://www.gnu.org/software/classpath/"
-LICENSE = "Classpath"
-PRIORITY = "optional"
-SECTION = "libs"
-PR = "r1"
+require classpath.inc
+
+PR = "r2"
SRCDATE_${PN} ?= "20070501"
PV = "0.93+cvs${SRCDATE}"
-DEPENDS = "glib-2.0 gtk+ cairo gconf ecj-native zip-native"
+### note from Laibsch: bug 2523 has information on how to build this package
+DEPENDS = "glib-2.0 gtk+ cairo gconf ecj-native zip-native virtual/java-native libxtst"
RDEPENDS_${PN} = "classpath-common (>= ${PV})"
RCONFLICTS_${PN} = "classpath-minimal"
@@ -17,19 +15,8 @@ SRC_URI = "cvs://anonymous@cvs.savannah.gnu.org/sources/classpath;module=classpa
S = "${WORKDIR}/classpath"
-inherit autotools
-
EXTRA_OECONF = "--with-ecj=${STAGING_BINDIR_NATIVE}/ecj --with-ecj-jar=${STAGING_BINDIR_NATIVE}/ecj.jar --disable-plugin --disable-dssi --disable-alsa"
-PACKAGES = "classpath-dev classpath-doc classpath-common classpath-examples classpath-tools ${PN}"
-
-FILES_classpath-doc = "${datadir}/info ${datadir}/man"
-FILES_classpath-dev = "${includedir}"
-FILES_${PN} = "${libdir} ${bindir}"
-FILES_classpath-common = "${datadir}/classpath/glibj.zip"
-FILES_classpath-examples = "${datadir}/classpath/examples"
-FILES_classpath-tools = "${datadir}/classpath/tools.zip"
-
do_stage() {
install -d ${STAGING_INCDIR}/classpath
install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
@@ -41,6 +28,3 @@ do_install() {
autotools_do_install
mv ${D}${libdir}/security ${D}${libdir}/${PN}
}
-
-PROVIDES = "classpath"
-RPROVIDES = "classpath"
diff --git a/packages/classpath/classpath-minimal-native_0.93.bb b/packages/classpath/classpath-minimal-native_0.93.bb
index f8e88a0217..83cb60142c 100644
--- a/packages/classpath/classpath-minimal-native_0.93.bb
+++ b/packages/classpath/classpath-minimal-native_0.93.bb
@@ -3,6 +3,8 @@ require classpath.inc
DEPENDS = "glib-2.0 libart-lgpl pango libxtst jikes-native zip-native"
PR = "r1"
+SRC_URI += "file://disable-automake-checks-v2.patch;patch=1"
+
S = "${WORKDIR}/classpath-${PV}"
inherit native
diff --git a/packages/classpath/classpath-minimal_0.90.bb b/packages/classpath/classpath-minimal_0.90.bb
index 1339b2dbc8..8d9554c999 100644
--- a/packages/classpath/classpath-minimal_0.90.bb
+++ b/packages/classpath/classpath-minimal_0.90.bb
@@ -4,13 +4,6 @@ DEPENDS = "jikes-native zip-native"
RDEPENDS_${PBN}-minimal = "${PBN}-common (>= ${PV})"
RCONFLICTS_${PBN}-minimal = "${PBN}-gtk"
-EXTRA_OECONF = "--with-jikes --without-x --with-glibj --disable-gtk-peer --disable-alsa"
-
-PACKAGES = "${PBN}-dev ${PBN}-doc ${PBN}-common ${PBN}-examples ${PBN}-tools ${PN}"
+SRC_URI += "file://disable-automake-checks.patch;patch=1"
-FILES_${PBN}-doc = "${datadir}/info"
-FILES_${PBN}-dev = "${includedir}"
-FILES_${PN} = "${libdir}"
-FILES_${PBN}-common = "${datadir}/${PBN}/glibj.zip"
-FILES_${PBN}-examples = "${datadir}/${PBN}/examples"
-FILES_${PBN}-tools = "${datadir}/${PBN}/tools"
+EXTRA_OECONF = "--with-jikes --without-x --with-glibj --disable-gtk-peer --disable-alsa"
diff --git a/packages/classpath/classpath.inc b/packages/classpath/classpath.inc
index 1d684c0557..d9498c99d5 100644
--- a/packages/classpath/classpath.inc
+++ b/packages/classpath/classpath.inc
@@ -7,7 +7,6 @@ PROVIDES = "classpath"
RPROVIDES = "classpath"
SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz \
- file://disable-automake-checks.patch;patch=1 \
file://gconf_version.patch;patch=1 \
file://fix-endian-arm-floats.patch;patch=1"
@@ -28,3 +27,4 @@ FILES_classpath-common += "${datadir}/classpath/glibj.zip"
FILES_classpath-examples += "${datadir}/classpath/examples"
FILES_classpath-tools += "${datadir}/classpath/tools.zip ${datadir}/classpath/tools"
FILES_classpath-dev += "${libdir}/*.so"
+FILES_classpath-dbg += "${libdir}/classpath/.debug"