summaryrefslogtreecommitdiff
path: root/packages/classpath/files
diff options
context:
space:
mode:
Diffstat (limited to 'packages/classpath/files')
-rw-r--r--packages/classpath/files/autotools.patch13
-rw-r--r--packages/classpath/files/cp-byte-loophelper.patch68
-rw-r--r--packages/classpath/files/decimalformat.patch31
3 files changed, 99 insertions, 13 deletions
diff --git a/packages/classpath/files/autotools.patch b/packages/classpath/files/autotools.patch
index baae366d5f..663c0340cd 100644
--- a/packages/classpath/files/autotools.patch
+++ b/packages/classpath/files/autotools.patch
@@ -22,16 +22,3 @@ Index: classpath-0.93/configure.ac
# Handle -Werror default case.
if test "$ENABLE_WERROR" = default; then
-Index: classpath-0.93/Makefile.am
-===================================================================
---- classpath-0.93.orig/Makefile.am 2006-02-08 08:35:30.000000000 +0100
-+++ classpath-0.93/Makefile.am 2008-08-24 21:45:42.405241264 +0200
-@@ -4,7 +4,7 @@
- SUBDIRS = lib doc external include native resource scripts tools $(EXAMPLESDIR)
- DIST_SUBDIRS = lib doc external include native resource scripts tools examples
-
--ACLOCAL_AMFLAGS = -I m4
-+ACLOCAL_AMFLAGS = -I m4 --install
-
- native: lib
-
diff --git a/packages/classpath/files/cp-byte-loophelper.patch b/packages/classpath/files/cp-byte-loophelper.patch
new file mode 100644
index 0000000000..4fac362cba
--- /dev/null
+++ b/packages/classpath/files/cp-byte-loophelper.patch
@@ -0,0 +1,68 @@
+Index: gnu/java/nio/charset/ByteDecodeLoopHelper.java
+===================================================================
+RCS file: /sources/classpath/classpath/gnu/java/nio/charset/ByteDecodeLoopHelper.java,v
+retrieving revision 1.1
+diff -u -r1.1 ByteDecodeLoopHelper.java
+--- gnu/java/nio/charset/ByteDecodeLoopHelper.java 23 Nov 2007 16:11:17 -0000 1.1
++++ gnu/java/nio/charset/ByteDecodeLoopHelper.java 3 Sep 2008 23:11:29 -0000
+@@ -119,6 +119,8 @@
+ int inRemaining = in.remaining();
+ int outRemaining = out.remaining();
+ CoderResult result;
++
++ bailOut:
+ if (inRemaining <= outRemaining)
+ {
+ for (int i = 0; i < inRemaining; i++)
+@@ -129,7 +131,7 @@
+ {
+ inPos--;
+ result = CoderResult.unmappableForLength(1);
+- break;
++ break bailOut;
+ }
+ char c = mapToChar(b);
+ outArray[outPos] = c;
+@@ -147,7 +149,7 @@
+ {
+ inPos--;
+ result = CoderResult.unmappableForLength(1);
+- break;
++ break bailOut;
+ }
+ char c = mapToChar(b);
+ outArray[outPos] = c;
+Index: gnu/java/nio/charset/ByteEncodeLoopHelper.java
+===================================================================
+RCS file: /sources/classpath/classpath/gnu/java/nio/charset/ByteEncodeLoopHelper.java,v
+retrieving revision 1.1
+diff -u -r1.1 ByteEncodeLoopHelper.java
+--- gnu/java/nio/charset/ByteEncodeLoopHelper.java 23 Nov 2007 16:11:17 -0000 1.1
++++ gnu/java/nio/charset/ByteEncodeLoopHelper.java 3 Sep 2008 23:11:29 -0000
+@@ -120,6 +120,8 @@
+ int inRemaining = in.remaining();
+ int outRemaining = out.remaining();
+ CoderResult result;
++
++ bailOut:
+ if (inRemaining <= outRemaining)
+ {
+ for (int i = 0; i < inRemaining; i++)
+@@ -130,7 +132,7 @@
+ {
+ inPos--;
+ result = CoderResult.unmappableForLength(1);
+- break;
++ break bailOut;
+ }
+ byte b = mapToByte(inChar);
+ outArray[outPos] = b;
+@@ -148,7 +150,7 @@
+ {
+ inPos--;
+ result = CoderResult.unmappableForLength(1);
+- break;
++ break bailOut;
+ }
+ byte b = mapToByte(inChar);
+ outArray[outPos] = b;
diff --git a/packages/classpath/files/decimalformat.patch b/packages/classpath/files/decimalformat.patch
new file mode 100644
index 0000000000..4997523830
--- /dev/null
+++ b/packages/classpath/files/decimalformat.patch
@@ -0,0 +1,31 @@
+Index: classpath-0.97.2/java/text/DecimalFormat.java
+===================================================================
+--- classpath-0.97.2.orig/java/text/DecimalFormat.java
++++ classpath-0.97.2/java/text/DecimalFormat.java
+@@ -1296,7 +1296,7 @@ public class DecimalFormat extends Numbe
+ currencySymbol = this.symbols.getCurrencySymbol();
+
+ // if \u00A4 is doubled, we use the international currency symbol
+- if (i < len && pattern.charAt(i + 1) == '\u00A4')
++ if ((i + 1) < len && pattern.charAt(i + 1) == '\u00A4')
+ {
+ currencySymbol = this.symbols.getInternationalCurrencySymbol();
+ i++;
+@@ -1320,7 +1320,7 @@ public class DecimalFormat extends Numbe
+ else if (ch == '\'')
+ {
+ // QUOTE
+- if (i < len && pattern.charAt(i + 1) == '\'')
++ if ((i + 1) < len && pattern.charAt(i + 1) == '\'')
+ {
+ // we need to add ' to the buffer
+ buffer.append(ch);
+@@ -1692,7 +1692,7 @@ public class DecimalFormat extends Numbe
+ else if (ch == '\'')
+ {
+ // QUOTE
+- if (i < len && pattern.charAt(i + 1) == '\'')
++ if ((i + 1) < len && pattern.charAt(i + 1) == '\'')
+ {
+ // we need to add ' to the buffer
+ buffer.append(ch);