summaryrefslogtreecommitdiff
path: root/packages/classpath/files
diff options
context:
space:
mode:
Diffstat (limited to 'packages/classpath/files')
-rw-r--r--packages/classpath/files/disable-automake-checks-v2.patch11
-rw-r--r--packages/classpath/files/disable-automake-checks.patch11
-rw-r--r--packages/classpath/files/fix-endian-arm-floats.patch11
-rw-r--r--packages/classpath/files/gconf_version.patch11
-rw-r--r--packages/classpath/files/gjar-prefix-patch.diff40
5 files changed, 40 insertions, 44 deletions
diff --git a/packages/classpath/files/disable-automake-checks-v2.patch b/packages/classpath/files/disable-automake-checks-v2.patch
deleted file mode 100644
index 0c1df1acae..0000000000
--- a/packages/classpath/files/disable-automake-checks-v2.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- sablevm-classpath-1.1.7/configure.ac.orig 2004-11-26 00:23:01.000000000 +0100
-+++ sablevm-classpath-1.1.7/configure.ac 2004-11-26 00:23:46.000000000 +0100
-@@ -34,7 +34,7 @@
- AC_SUBST(CLASSPATH_MODULE)
-
- AC_PREREQ(2.59)
--AM_INIT_AUTOMAKE([1.9.0 gnu std-options tar-ustar -Wno-portability])
-+AM_INIT_AUTOMAKE
- AC_CONFIG_HEADERS([include/config.h])
- AC_PREFIX_DEFAULT(/usr/local)
-
diff --git a/packages/classpath/files/disable-automake-checks.patch b/packages/classpath/files/disable-automake-checks.patch
deleted file mode 100644
index d6a55428ad..0000000000
--- a/packages/classpath/files/disable-automake-checks.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- sablevm-classpath-1.1.7/configure.ac.orig 2004-11-26 00:23:01.000000000 +0100
-+++ sablevm-classpath-1.1.7/configure.ac 2004-11-26 00:23:46.000000000 +0100
-@@ -34,7 +34,7 @@
- AC_SUBST(CLASSPATH_MODULE)
-
- AC_PREREQ(2.59)
--AM_INIT_AUTOMAKE([1.9.0 gnu std-options tar-ustar])
-+AM_INIT_AUTOMAKE
- AC_CONFIG_HEADERS([include/config.h])
- AC_PREFIX_DEFAULT(/usr/local)
-
diff --git a/packages/classpath/files/fix-endian-arm-floats.patch b/packages/classpath/files/fix-endian-arm-floats.patch
deleted file mode 100644
index a9af0611b2..0000000000
--- a/packages/classpath/files/fix-endian-arm-floats.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- classpath/native/fdlibm/ieeefp.h.orig 2006-04-14 22:33:09.000000000 -0400
-+++ classpath/native/fdlibm/ieeefp.h 2006-04-14 22:41:46.000000000 -0400
-@@ -13,7 +13,7 @@
- byte ordering was big or little endian depending upon the target.
- Modern floating-point formats are naturally ordered; in this case
- __VFP_FP__ will be defined, even if soft-float. */
--#ifdef __VFP_FP__
-+#ifdef __SOFTFP__
- #ifdef __ARMEL__
- #define __IEEE_LITTLE_ENDIAN
- #else
diff --git a/packages/classpath/files/gconf_version.patch b/packages/classpath/files/gconf_version.patch
deleted file mode 100644
index b1be1209a2..0000000000
--- a/packages/classpath/files/gconf_version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- classpath-0.93/configure.ac~ 2007-03-29 15:52:30.000000000 -0500
-+++ classpath-0.93/configure.ac 2007-03-29 15:52:30.000000000 -0500
-@@ -496,7 +496,7 @@
-
- dnl gconf-peer
- if test "x${COMPILE_GCONF_PEER}" = xyes; then
-- PKG_CHECK_MODULES(GCONF, gconf-2.0 >= 2.11.2)
-+ PKG_CHECK_MODULES(GCONF, gconf-2.0 >= 2.6.0)
- AC_SUBST(GCONF_CFLAGS)
- AC_SUBST(GCONF_LIBS)
- dnl we also need gdk for locking
diff --git a/packages/classpath/files/gjar-prefix-patch.diff b/packages/classpath/files/gjar-prefix-patch.diff
new file mode 100644
index 0000000000..64b262cb41
--- /dev/null
+++ b/packages/classpath/files/gjar-prefix-patch.diff
@@ -0,0 +1,40 @@
+Index: tools/gnu/classpath/tools/jar/Entry.java
+===================================================================
+RCS file: /sources/classpath/classpath/tools/gnu/classpath/tools/jar/Entry.java,v
+retrieving revision 1.1
+diff -u -r1.1 Entry.java
+--- tools/gnu/classpath/tools/jar/Entry.java 8 May 2006 18:38:20 -0000 1.1
++++ tools/gnu/classpath/tools/jar/Entry.java 10 Dec 2007 22:20:05 -0000
+@@ -1,5 +1,5 @@
+ /* Entry.java - represent a single file to write to a jar
+- Copyright (C) 2006 Free Software Foundation, Inc.
++ Copyright (C) 2006, 2007 Free Software Foundation, Inc.
+
+ This file is part of GNU Classpath.
+
+@@ -49,12 +49,22 @@
+ public Entry(File file, String name)
+ {
+ this.file = file;
+- this.name = name;
++
++ /* Removes any './' prefixes automatically. Those caused trouble
++ * in (boot) classpath use-cases. See #32516.
++ */
++ int start = 0;
++ while (name.length() > start + 2
++ && name.codePointAt(start) == '.'
++ && name.codePointAt(start + 1) == File.separatorChar)
++ start += 2;
++
++ this.name = name.substring(start);
+ }
+
+ public Entry(File file)
+ {
+- this.file = file;
+- this.name = file.toString();
++ this(file, file.toString());
+ }
++
+ }