summaryrefslogtreecommitdiff
path: root/packages/busybox/busybox_1.11.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/busybox/busybox_1.11.3.bb')
-rw-r--r--packages/busybox/busybox_1.11.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/busybox/busybox_1.11.3.bb b/packages/busybox/busybox_1.11.3.bb
new file mode 100644
index 0000000000..ce2b51a24b
--- /dev/null
+++ b/packages/busybox/busybox_1.11.3.bb
@@ -0,0 +1,25 @@
+require busybox.inc
+FILE_PR = "r0"
+
+SRC_URI = "\
+ http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
+ \
+ file://udhcpscript.patch;patch=1 \
+ file://busybox-cron \
+ file://busybox-httpd \
+ file://busybox-udhcpd \
+ file://default.script \
+ file://hwclock.sh \
+ file://mount.busybox \
+ file://syslog \
+ file://syslog.conf \
+ file://umount.busybox \
+ file://defconfig \
+"
+
+EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_configure () {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ cml1_do_configure
+}