summaryrefslogtreecommitdiff
path: root/packages/bootshim/bootShim_0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/bootshim/bootShim_0.2.bb')
-rw-r--r--packages/bootshim/bootShim_0.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/bootshim/bootShim_0.2.bb b/packages/bootshim/bootShim_0.2.bb
new file mode 100644
index 0000000000..96bd6e1657
--- /dev/null
+++ b/packages/bootshim/bootShim_0.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Bootshim for Greatwall bootloaders"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+DEPENDS = "sed-native LAB-kernel"
+#requires perl on the host system, will fix that later
+
+SRC_URI = "http://handhelds.org/~mreimer/${P}.tgz"
+
+do_configure() {
+cp ${DEPLOY_DIR}/images/LAB-image-${MACHINE} ${S}/zImage
+sed -i /^CROSS/d Makefile
+}
+
+do_compile() {
+oe_runmake CROSS=${CROSS_DIR}/bin/${TARGET_ARCH}-${TARGET_OS}-
+}
+
+
+do_deploy() {
+ install -d ${DEPLOY_DIR}/images
+ install -m 0644 htc_bootshim.bin ${DEPLOY_DIR}/images/LAB-image-${MACHINE}.shimmed
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+
+