summaryrefslogtreecommitdiff
path: root/packages/boost
diff options
context:
space:
mode:
Diffstat (limited to 'packages/boost')
-rw-r--r--packages/boost/.mtn2git_empty0
-rw-r--r--packages/boost/boost-jam-native_3.1.9.bb35
-rw-r--r--packages/boost/boost_1.32.0.bb139
-rw-r--r--packages/boost/files/.mtn2git_empty0
-rw-r--r--packages/boost/files/linux-uclibc.patch10
-rw-r--r--packages/boost/files/unit_test_log10f.patch20
6 files changed, 204 insertions, 0 deletions
diff --git a/packages/boost/.mtn2git_empty b/packages/boost/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/boost/.mtn2git_empty
diff --git a/packages/boost/boost-jam-native_3.1.9.bb b/packages/boost/boost-jam-native_3.1.9.bb
new file mode 100644
index 0000000000..e13d160a37
--- /dev/null
+++ b/packages/boost/boost-jam-native_3.1.9.bb
@@ -0,0 +1,35 @@
+# The Boost web site provides free peer-reviewed portable
+# C++ source libraries. The emphasis is on libraries which
+# work well with the C++ Standard Library. The libraries are
+# intended to be widely useful, and are in regular use by
+# thousands of programmers across a broad spectrum of applications.
+DESCRIPTION = "Make system for boost (native)"
+HOMEPAGE = "http://www.boost.org/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+
+SRC_URI = "http://download.sourceforge.net/boost/boost-jam-${PV}.tgz"
+
+inherit native
+
+S = "${WORKDIR}/boost-jam-${PV}"
+
+do_compile() {
+ set -ex
+ rm -rf bin.*
+ ./build.sh gcc
+}
+
+# This is too terrible - the build script doesn't give any good
+# way I can see to find out where the binaries are placed, so
+# rely on only one bin.foo directory being created.
+do_stage() {
+ set -ex
+ install -c -m 755 bin.*/jam ${bindir}
+ install -c -m 755 bin.*/mkjambase ${bindir}
+ install -c -m 755 bin.*/yyacc ${bindir}
+ rm -f ${bindir}/bjam
+ ln ${bindir}/jam ${bindir}/bjam
+}
diff --git a/packages/boost/boost_1.32.0.bb b/packages/boost/boost_1.32.0.bb
new file mode 100644
index 0000000000..2dd2a0da28
--- /dev/null
+++ b/packages/boost/boost_1.32.0.bb
@@ -0,0 +1,139 @@
+# The Boost web site provides free peer-reviewed portable
+# C++ source libraries. The emphasis is on libraries which
+# work well with the C++ Standard Library. The libraries are
+# intended to be widely useful, and are in regular use by
+# thousands of programmers across a broad spectrum of applications.
+DESCRIPTION = "Free peer-reviewed portable C++ source libraries"
+HOMEPAGE = "http://www.boost.org/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+PR = "r1"
+
+# need debian package naming for the libs
+inherit debian
+
+DEPENDS += "boost-jam-native"
+
+BOOST_VER = "${@"_".join(bb.data.getVar("PV",d,1).split("."))}"
+BOOST_MAJ = "${@"_".join(bb.data.getVar("PV",d,1).split(".")[0:2])}"
+BOOST_P = "boost_${BOOST_VER}"
+SRC_URI = "http://download.sourceforge.net/boost/${BOOST_P}.tar.bz2 \
+ file://unit_test_log10f.patch;patch=1 \
+ file://linux-uclibc.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/${BOOST_P}"
+
+# Make a package for each library, plus -dev and -python
+PACKAGES =
+
+PACKAGES += boost-date-time
+FILES_boost-date-time = "${libdir}/libboost_date_time.so.${PV}"
+
+PACKAGES += boost-filesystem
+FILES_boost-filesystem = "${libdir}/libboost_filesystem.so.${PV}"
+
+PACKAGES += boost-prg-exec-monitor
+FILES_boost-prg-exec-monitor = "${libdir}/libboost_prg_exec_monitor.so.${PV}"
+
+PACKAGES += boost-program-options
+FILES_boost-program-options = "${libdir}/libboost_program_options.so.${PV}"
+
+PACKAGES += boost-regex
+FILES_boost-regex = "${libdir}/libboost_regex.so.${PV}"
+
+PACKAGES += boost-signals
+FILES_boost-signals = "${libdir}/libboost_signals.so.${PV}"
+
+PACKAGES += boost-test-exec-monitor
+FILES_boost-test-exec-monitor = "${libdir}/libboost_test_exec_monitor.so.${PV}"
+
+PACKAGES += boost-thread-mt
+FILES_boost-thread-mt = "${libdir}/libboost_thread-mt.so.${PV}"
+
+PACKAGES += boost-unit-test-framework
+FILES_boost-unit-test-framework = "${libdir}/libboost_unit_test_framework.so.${PV}"
+
+# Python - remove this and set:
+#PYTHON_ROOT = "/dev/null"
+# to remove the python build
+DEPENDS += "python"
+PYTHON_ROOT = "${STAGING_DIR}/${HOST_SYS}"
+PYTHON_VERSION = "2.4"
+
+PACKAGES += boost-python
+FILES_boost-python = "${libdir}/libboost_python.so.${PV}"
+
+# -dev last to pick up the remaining stuff
+PACKAGES += "${PN}-dev"
+FILES_${PN}-dev = "${includedir} ${libdir}/libboost_*.so ${libdir}/libboost_*.a"
+
+# Oh yippee, a new build system, it's sooo cooool I could eat my own
+# foot. inlining=on lets the compiler choose, I think. At least this
+# stuff is documented...
+# NOTE: if you leave <debug-symbols>on then in a debug build the build sys
+# objcopy will be invoked, and that won't work. Building debug apparently
+# requires hacking gcc-tools.jam
+#
+# Sometimes I wake up screaming. Famous figures are gathered in the nightmare,
+# Steve Bourne, Larry Wall, the whole of the ANSI C committee. They're just
+# standing there, waiting, but the truely terrifying thing is what they carry
+# in their hands. At first sight each seems to bear the same thing, but it is
+# not so for the forms in their grasp are ever so slightly different one from
+# the other. Each is twisted in some grotesque way from the other to make each
+# an unspeakable perversion impossible to perceive without the onset of madness.
+# True insanity awaits anyone who perceives all of these horrors together.
+#
+# Quotation marks, there might be an easier way to do this, but I can't find
+# it. The problem is that the user.hpp configuration file must receive a
+# pre-processor macro defined as the appropriate string - complete with "'s
+# around it. (<> is a possibility here but the danger to that is that the
+# failure case interprets the < and > as shell redirections, creating
+# random files in the source tree.)
+#
+#bjam: '-DBOOST_PLATFORM_CONFIG=\"config\"'
+#do_compile: '-sGCC=... '"'-DBOOST_PLATFORM_CONFIG=\"config\"'"
+SQD = '"'
+EQD = '\"'
+#boost.bb: "... '-sGCC=... '${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}config${EQD}'${SQD} ..."
+BJAM_CONF = "${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}boost/config/platform/${TARGET_OS}.hpp${EQD}'${SQD}"
+
+BJAM_TOOLS = "-sTOOLS=gcc \
+ '-sGCC=${CC} '${BJAM_CONF} \
+ '-sGXX=${CXX} '${BJAM_CONF} \
+ -sBUILD='release <optimization>space <inlining>on <debug-symbols>off' \
+ '-sPYTHON_VERSION=${PYTHON_VERSION}' \
+ --layout=system \
+ "
+
+BJAM_OPTS = '${BJAM_TOOLS} \
+ --builddir=${S}/${TARGET_SYS} \
+ --with-python-root=${PYTHON_ROOT} \
+ ${BJAM_EXTRA}'
+
+
+do_compile() {
+ set -ex
+ bjam ${BJAM_OPTS} --prefix=${prefix} \
+ --exec-prefix=${exec_prefix} \
+ --libdir=${libdir} \
+ --includedir=${includedir}
+}
+
+do_stage() {
+ set -ex
+ bjam ${BJAM_OPTS} \
+ --libdir=${STAGING_LIBDIR} \
+ --includedir=${STAGING_INCDIR} \
+ install
+}
+
+do_install() {
+ set -ex
+ bjam ${BJAM_OPTS} \
+ --libdir=${D}${libdir} \
+ --includedir=${D}${includedir} \
+ install
+}
diff --git a/packages/boost/files/.mtn2git_empty b/packages/boost/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/boost/files/.mtn2git_empty
diff --git a/packages/boost/files/linux-uclibc.patch b/packages/boost/files/linux-uclibc.patch
new file mode 100644
index 0000000000..79f14dea88
--- /dev/null
+++ b/packages/boost/files/linux-uclibc.patch
@@ -0,0 +1,10 @@
+--- /dev/null 1969-12-31 16:00:00.000000000 -0800
++++ boost_1_32_0/boost/config/platform/linux-uclibc.hpp 2005-07-05 14:51:56.237294460 -0700
+@@ -0,0 +1,7 @@
++// Modifications required to support uClibC libc implementation.
++// Default to Linux...
++#include "linux.hpp"
++
++// Override anything uClibC doesn't support.
++// At present (0.9.27) the nl_types.h header exists but is not implemented
++#undef BOOST_HAS_NL_TYPES_H
diff --git a/packages/boost/files/unit_test_log10f.patch b/packages/boost/files/unit_test_log10f.patch
new file mode 100644
index 0000000000..b235e12446
--- /dev/null
+++ b/packages/boost/files/unit_test_log10f.patch
@@ -0,0 +1,20 @@
+--- boost_1_32_0/libs/test/src/unit_test_result.cpp.orig 2005-07-05 11:00:53.887594850 -0700
++++ boost_1_32_0/libs/test/src/unit_test_result.cpp 2005-07-05 11:01:20.683533034 -0700
+@@ -144,7 +144,7 @@
+ unit_test_counter num_passed, unit_test_counter num_failed )
+ {
+ unit_test_counter total_test_cases = num_passed + num_failed;
+- std::size_t width = static_cast<std::size_t>( std::log10( (float)(std::max)( num_passed, num_failed ) ) ) + 1;
++ std::size_t width = static_cast<std::size_t>( std::log10( (double)(std::max)( num_passed, num_failed ) ) ) + 1;
+
+ where_to << std::setw( indent ) << "" << std::setw( width ) << num_passed
+ << " test " << ps_name( num_passed != 1, "case" ) << " out of " << total_test_cases << " passed\n"
+@@ -158,7 +158,7 @@
+ {
+ unit_test_counter total_assertions = num_passed + num_failed;
+ std::size_t width = total_assertions > 0
+- ? static_cast<std::size_t>( std::log10( (float)(std::max)( num_passed, num_failed ) ) ) + 1
++ ? static_cast<std::size_t>( std::log10( (double)(std::max)( num_passed, num_failed ) ) ) + 1
+ : 1;
+
+ where_to << std::setw( indent ) << "" << std::setw( width ) << num_passed