summaryrefslogtreecommitdiff
path: root/packages/boost
diff options
context:
space:
mode:
Diffstat (limited to 'packages/boost')
-rw-r--r--packages/boost/boost-jam-native_3.1.10.bb (renamed from packages/boost/boost-jam-native_3.1.9.bb)16
-rw-r--r--packages/boost/boost_1.32.0.bb7
2 files changed, 11 insertions, 12 deletions
diff --git a/packages/boost/boost-jam-native_3.1.9.bb b/packages/boost/boost-jam-native_3.1.10.bb
index e13d160a37..3a844b191e 100644
--- a/packages/boost/boost-jam-native_3.1.9.bb
+++ b/packages/boost/boost-jam-native_3.1.10.bb
@@ -9,13 +9,13 @@ MAINTAINER = "John Bowler <jbowler@acm.org>"
SECTION = "devel"
PRIORITY = "optional"
LICENSE = "Boost Software License"
+PR = "r0"
-SRC_URI = "http://download.sourceforge.net/boost/boost-jam-${PV}.tgz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
+S = "${WORKDIR}/boost-jam-${PV}"
inherit native
-S = "${WORKDIR}/boost-jam-${PV}"
-
do_compile() {
set -ex
rm -rf bin.*
@@ -27,9 +27,9 @@ do_compile() {
# rely on only one bin.foo directory being created.
do_stage() {
set -ex
- install -c -m 755 bin.*/jam ${bindir}
- install -c -m 755 bin.*/mkjambase ${bindir}
- install -c -m 755 bin.*/yyacc ${bindir}
- rm -f ${bindir}/bjam
- ln ${bindir}/jam ${bindir}/bjam
+ install -c -m 755 bin.*/jam ${STAGING_BINDIR}/
+ install -c -m 755 bin.*/mkjambase ${STAGING_BINDIR}/
+ install -c -m 755 bin.*/yyacc ${STAGING_BINDIR}/
+ rm -f ${STAGING_BINDIR}/bjam
+ ln -sf ./jam ${STAGING_BINDIR}/bjam
}
diff --git a/packages/boost/boost_1.32.0.bb b/packages/boost/boost_1.32.0.bb
index 2dd2a0da28..1cf399599f 100644
--- a/packages/boost/boost_1.32.0.bb
+++ b/packages/boost/boost_1.32.0.bb
@@ -6,7 +6,8 @@
DESCRIPTION = "Free peer-reviewed portable C++ source libraries"
HOMEPAGE = "http://www.boost.org/"
MAINTAINER = "John Bowler <jbowler@acm.org>"
-SECTION = "devel"
+SECTION = "libs"
+DEPENDS = "boost-jam-native"
PRIORITY = "optional"
LICENSE = "Boost Software License"
PR = "r1"
@@ -14,12 +15,10 @@ PR = "r1"
# need debian package naming for the libs
inherit debian
-DEPENDS += "boost-jam-native"
-
BOOST_VER = "${@"_".join(bb.data.getVar("PV",d,1).split("."))}"
BOOST_MAJ = "${@"_".join(bb.data.getVar("PV",d,1).split(".")[0:2])}"
BOOST_P = "boost_${BOOST_VER}"
-SRC_URI = "http://download.sourceforge.net/boost/${BOOST_P}.tar.bz2 \
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2 \
file://unit_test_log10f.patch;patch=1 \
file://linux-uclibc.patch;patch=1 \
"