summaryrefslogtreecommitdiff
path: root/packages/boost/boost-jam-native_3.1.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/boost/boost-jam-native_3.1.11.bb')
-rw-r--r--packages/boost/boost-jam-native_3.1.11.bb28
1 files changed, 1 insertions, 27 deletions
diff --git a/packages/boost/boost-jam-native_3.1.11.bb b/packages/boost/boost-jam-native_3.1.11.bb
index 843f912f46..2e92146a83 100644
--- a/packages/boost/boost-jam-native_3.1.11.bb
+++ b/packages/boost/boost-jam-native_3.1.11.bb
@@ -1,30 +1,4 @@
-# The Boost web site provides free peer-reviewed portable
-# C++ source libraries. The emphasis is on libraries which
-# work well with the C++ Standard Library. The libraries are
-# intended to be widely useful, and are in regular use by
-# thousands of programmers across a broad spectrum of applications.
-DESCRIPTION = "Make system for boost (native)"
-HOMEPAGE = "http://www.boost.org/"
-SECTION = "devel"
-PRIORITY = "optional"
-LICENSE = "Boost Software License"
-PR = "r0"
+include boost-jam-native.inc
SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
-S = "${WORKDIR}/boost-jam-${PV}"
-inherit native
-
-do_compile() {
- set -ex
- rm -rf bin.*
- ./build.sh gcc
-}
-
-# This is too terrible - the build script doesn't give any good
-# way I can see to find out where the binaries are placed, so
-# rely on only one bin.foo directory being created.
-do_stage() {
- set -ex
- install -c -m 755 bin.*/bjam ${STAGING_BINDIR}/
-}