summaryrefslogtreecommitdiff
path: root/packages/bluez
diff options
context:
space:
mode:
Diffstat (limited to 'packages/bluez')
-rw-r--r--packages/bluez/bluez-utils.inc8
-rw-r--r--packages/bluez/bluez-utils/ppoll-uclibc-arm-r0.patch14
-rw-r--r--packages/bluez/bluez-utils/uclibc-fix.patch46
-rw-r--r--packages/bluez/bluez-utils_3.10.1.bb45
-rw-r--r--packages/bluez/bluez-utils_3.9.bb12
5 files changed, 101 insertions, 24 deletions
diff --git a/packages/bluez/bluez-utils.inc b/packages/bluez/bluez-utils.inc
index 886a5a3d55..b6f9660fa7 100644
--- a/packages/bluez/bluez-utils.inc
+++ b/packages/bluez/bluez-utils.inc
@@ -48,10 +48,10 @@ do_install_append() {
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
${sysconfdir}/default/bluetooth"
-PACKAGES =+ "${PN}-ciptool bluez-cups-backend"
-FILES_${PN}-ciptool = "/bin/ciptool"
-RREPLACES_${PN}-ciptool = "bluez-utils-dbus-ciptool"
-RCONFLICTS_${PN}-ciptool = "bluez-utils-dbus-ciptool bluez-utils-nodbus"
+PACKAGES =+ " bluez-cups-backend"
+
+FILES_${PN} += " ${libdir}/alsa-lib/*.so "
+FILES_${PN}-dev += " ${libdir}/alsa-lib/*.la "
FILES_bluez-cups-backend = "${libdir}/cups/backend/bluetooth"
RDEPENDS_bluez-cups-backend = "cups"
diff --git a/packages/bluez/bluez-utils/ppoll-uclibc-arm-r0.patch b/packages/bluez/bluez-utils/ppoll-uclibc-arm-r0.patch
new file mode 100644
index 0000000000..391a7ae3de
--- /dev/null
+++ b/packages/bluez/bluez-utils/ppoll-uclibc-arm-r0.patch
@@ -0,0 +1,14 @@
+Index: bluez-utils-3.9/common/ppoll.h
+===================================================================
+--- bluez-utils-3.9.orig/common/ppoll.h 2007-05-17 17:42:23.000000000 +0200
++++ bluez-utils-3.9/common/ppoll.h 2007-05-17 17:43:18.000000000 +0200
+@@ -1,4 +1,8 @@
+-static inline int ppoll(struct pollfd *fds, nfds_t nfds,
++#ifdef ppoll
++#undef ppoll
++#endif
++#define ppoll bluez_ppoll
++static inline int bluez_ppoll(struct pollfd *fds, nfds_t nfds,
+ const struct timespec *timeout, const sigset_t *sigmask)
+ {
+ return poll(fds, nfds, timeout ? timeout->tv_sec * 1000 : 500);
diff --git a/packages/bluez/bluez-utils/uclibc-fix.patch b/packages/bluez/bluez-utils/uclibc-fix.patch
new file mode 100644
index 0000000000..6d4753c2e5
--- /dev/null
+++ b/packages/bluez/bluez-utils/uclibc-fix.patch
@@ -0,0 +1,46 @@
+Uclibc doesn't define or support speeds above 115200. So check the existence
+of the defines before allowing them to actually be used.
+
+Index: bluez-utils-3.9/tools/hciattach.c
+===================================================================
+--- bluez-utils-3.9.orig/tools/hciattach.c 2007-05-17 12:34:28.000000000 +1000
++++ bluez-utils-3.9/tools/hciattach.c 2007-05-17 12:40:20.000000000 +1000
+@@ -105,22 +105,38 @@
+ return B57600;
+ case 115200:
+ return B115200;
++#ifdef B230400
+ case 230400:
+ return B230400;
++#endif
++#ifdef B460800
+ case 460800:
+ return B460800;
++#endif
++#ifdef B500000
+ case 500000:
+ return B500000;
++#endif
++#ifdef B576000
+ case 576000:
+ return B576000;
++#endif
++#ifdef B921600
+ case 921600:
+ return B921600;
++#endif
++#ifdef B1000000
+ case 1000000:
+ return B1000000;
++#endif
++#ifdef B1152000
+ case 1152000:
+ return B1152000;
++#endif
++#ifdef B1500000
+ case 1500000:
+ return B1500000;
++#endif
+ default:
+ return B57600;
+ }
diff --git a/packages/bluez/bluez-utils_3.10.1.bb b/packages/bluez/bluez-utils_3.10.1.bb
index 59dde38571..44827dc2d0 100644
--- a/packages/bluez/bluez-utils_3.10.1.bb
+++ b/packages/bluez/bluez-utils_3.10.1.bb
@@ -8,11 +8,10 @@ SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
file://02dtl1_cs.sh \
"
-PR = "r2"
+PR = "r3"
EXTRA_OECONF = " \
--enable-bccmd \
- --enable-bcm203x \
--disable-hid2hci \
--disable-alsa \
--enable-cups \
@@ -63,7 +62,7 @@ EXTRA_OECONF = " \
# --disable-hid2hci
-PACKAGES =+ "${PN}-compat bluez-cups-backend"
+PACKAGES =+ "${PN}-compat"
CONFFILES_${PN} = " \
${sysconfdir}/bluetooth/hcid.conf \
@@ -75,30 +74,38 @@ CONFFILES_${PN}-compat = " \
"
FILES_${PN} = " \
- ${sbindir}/hcid \
+ ${base_sbindir}/hcid \
${libdir}/bluetooth \
${sysconfdir}/init.d/bluetooth \
${sysconfdir}/bluetooth/*.service \
${sysconfdir}/bluetooth/hcid.conf \
${sysconfdir}/default \
${sysconfdir}/dbus-1 \
- ${bindir}/hciattach \
- "
+ ${base_sbindir}/hciattach \
+ "
+
+#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
+FILES_${PN} += "${sysconfdir}/apm/"
+
+FILES_${PN}-dbg += " \
+ ${libdir}/bluetooth/.debug \
+ "
FILES_${PN}-compat = " \
- ${bindir}/sdptool \
- ${bindir}/dund \
- ${bindir}/rctest \
- ${bindir}/ciptool \
- ${bindir}/l2test \
- ${bindir}/rfcomm \
- ${bindir}/hcitool \
- ${bindir}/pand \
- ${bindir}/hidd \
- ${bindir}/l2ping \
- ${bindir}/hciconfig \
- ${bindir}/bccmd \
- ${bindir}/hciemu \
+ ${base_bindir}/sdptool \
+ ${base_bindir}/dund \
+ ${base_bindir}/rctest \
+ ${base_bindir}/ciptool \
+ ${base_bindir}/l2test \
+ ${base_bindir}/rfcomm \
+ ${base_bindir}/hcitool \
+ ${base_bindir}/pand \
+ ${base_bindir}/hidd \
+ ${base_bindir}/l2ping \
+ ${base_sbindir}/hciconfig \
+ ${base_sbindir}/bccmd \
+ ${base_sbindir}/hciemu \
+ ${base_bindir}/passkey-agent \
${sysconfdir}/bluetooth/rfcomm.conf \
"
diff --git a/packages/bluez/bluez-utils_3.9.bb b/packages/bluez/bluez-utils_3.9.bb
index e710e8c8f6..29c472fbbd 100644
--- a/packages/bluez/bluez-utils_3.9.bb
+++ b/packages/bluez/bluez-utils_3.9.bb
@@ -1,3 +1,13 @@
require bluez-utils.inc
-PR = "r4"
+PACKAGES =+ "${PN}-ciptool"
+
+SRC_URI += "file://uclibc-fix.patch;patch=1 \
+ file://ppoll-uclibc-arm-r0.patch;patch=1 "
+
+FILES_${PN}-ciptool = "/bin/ciptool"
+RREPLACES_${PN}-ciptool = "bluez-utils-dbus-ciptool"
+RCONFLICTS_${PN}-ciptool = "bluez-utils-dbus-ciptool bluez-utils-nodbus"
+
+
+PR = "r5"